Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Kepler - JSP editing slowness(Kepler - JSP editing slowness during cut/copy/paste)
Kepler - JSP editing slowness [message #1091483] Wed, 21 August 2013 15:17 Go to next message
sri yell is currently offline sri yell
Messages: 3
Registered: August 2013
Junior Member
Editing JSP files in Kepler seem to be slow.
Especially, cut/copy/paste of any tags (angled brackets) is taking 5 to 8 seconds.
Is anyone else having the same problem ?

I created brand new workspace and imported existing projects from subversion.
My earlier version was Indigo and never had this problem before.
Un-checking 'Validate JSP fragments' in preferences did not help.

OS : Windows XP
Eclipse Version : Kepler, 32 bit, Build id: 20130614-0229.

Can someone help suggest how to troubleshoot, please ?

Re: Kepler - JSP editing slowness [message #1093085 is a reply to message #1091483] Fri, 23 August 2013 14:45 Go to previous messageGo to next message
Nick Sandonato is currently offline Nick Sandonato
Messages: 126
Registered: July 2009
Senior Member
It may be related to to an m2e-wtp bug [1]. You may be able to install the latest dev build linked in comment #9 on the defect to see if it improves performance for you.

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=412092
Re: Kepler - JSP editing slowness [message #1094646 is a reply to message #1093085] Mon, 26 August 2013 02:40 Go to previous messageGo to next message
sri yell is currently offline sri yell
Messages: 3
Registered: August 2013
Junior Member
Sorry, it did not help. Installing 1.5 version of Maven or latest snapshot or completely removing Maven plugin did not help improve. Looks like it is not related to Maven at all. No luck yet.
Re: Kepler - JSP editing slowness [message #1105339 is a reply to message #1094646] Mon, 09 September 2013 18:14 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2308
Registered: July 2009
Senior Member
The problem Nick was referring to is with the Maven Eclipse Plug-ins, not Maven itself or a Maven plug-in.

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Kepler - JSP editing slowness [message #1106127 is a reply to message #1091483] Tue, 10 September 2013 18:42 Go to previous messageGo to next message
sri yell is currently offline sri yell
Messages: 3
Registered: August 2013
Junior Member
Maven is included in Kepler..hence, I did not download any maven plugins.
Re: Kepler - JSP editing slowness [message #1221911 is a reply to message #1091483] Wed, 18 December 2013 17:17 Go to previous messageGo to next message
paul Mising name is currently offline paul Mising name
Messages: 2
Registered: September 2010
Junior Member
sri yell, did you ever get this resolved? I am experiencing the same issues. 5-8 second lag on pasting text with angle brackets, and 2-3 seconds per character when typing.

I have tried reinstalling WTP (3.5.0, 3.5.1 and 3.5.1 with patches), fresh installations of Eclipse (SE and JEE, 64bit for both).I have updated the m2e-wtp, tried various combinations of validation disabling as well as content assist.

I'd go back to Juno, which was fine for JSPs but slower overall.

[Updated on: Wed, 18 December 2013 18:50]

Report message to a moderator

Re: Kepler - JSP editing slowness [message #1230065 is a reply to message #1221911] Fri, 10 January 2014 22:38 Go to previous message
Nick Sandonato is currently offline Nick Sandonato
Messages: 126
Registered: July 2009
Senior Member
paul Mising name wrote on Wed, 18 December 2013 12:17
sri yell, did you ever get this resolved? I am experiencing the same issues. 5-8 second lag on pasting text with angle brackets, and 2-3 seconds per character when typing.

I have tried reinstalling WTP (3.5.0, 3.5.1 and 3.5.1 with patches), fresh installations of Eclipse (SE and JEE, 64bit for both).I have updated the m2e-wtp, tried various combinations of validation disabling as well as content assist.

I'd go back to Juno, which was fine for JSPs but slower overall.


Hi Paul,

Do you have any stackdumps that might help in tracking down the culprit?
Previous Topic:Why does Dynamic Web facet require JavaScript facet
Next Topic:Cannot reconnect to an encrypted database
Goto Forum:
  


Current Time: Wed Oct 22 08:01:36 GMT 2014

Powered by FUDForum. Page generated in 0.01782 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software