Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [xcore] synchronized
[xcore] synchronized [message #1087378] Thu, 15 August 2013 14:59 Go to next message
Martin Jacob is currently offline Martin JacobFriend
Messages: 116
Registered: July 2009
Senior Member
Hi,

how do I specify a synchronized(mutex) { .... } section using xcore?

When I use it as usual in Java I get these error message:

Couldn't resolve reference to JvmIdentifiableElement 'synchronized'.

Any Idea how to solve the issue?


Martin
Re: [xcore] synchronized [message #1087390 is a reply to message #1087378] Thu, 15 August 2013 15:11 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 26285
Registered: July 2009
Senior Member
Martin,

It's more of an Xbase question, so I asked the experts and they said
"that's currently not supported and unlikely that we'll do something
like that; it's possible to use util.concurrent apis instead"...

On 15/08/2013 4:59 PM, Martin Jacob wrote:
> Hi,
>
> how do I specify a synchronized(mutex) { .... } section using xcore?
>
> When I use it as usual in Java I get these error message:
>
> Couldn't resolve reference to JvmIdentifiableElement 'synchronized'.
>
> Any Idea how to solve the issue?
>
>
> Martin
Previous Topic:[CDO] Create an offline Server
Next Topic:[CDO] Problems running cdo-server-Windows
Goto Forum:
  


Current Time: Sat Dec 20 21:00:21 GMT 2014

Powered by FUDForum. Page generated in 0.01801 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software