Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Can't Revert from Rap 2.1 to RAP 1.5(Failed to Create VMBridge)
Can't Revert from Rap 2.1 to RAP 1.5 [message #1086864] Wed, 14 August 2013 21:10 Go to next message
Mark Leone is currently offline Mark Leone
Messages: 67
Registered: April 2012
Member
I was using RAP 1.5.2 for a while, and switched my target to RAP 2.1. Because I have a problem in RAP 2.1 that I have no solution for, I want to go back to 1.5, so I can continue working on my project while hoping a solution for 2.1 is found some day.

But now when I launch the same app I that launched just two days ago in RAP 1.5, I get

!
ENTRY org.eclipse.rap.ui.workbench 4 0 2013-08-14 16:49:24.510
!MESSAGE FrameworkEvent ERROR
!STACK 0
java.lang.ExceptionInInitializerError
	at org.mozilla.javascript.Context.getCurrentContext(Context.java:329)
	at org.mozilla.javascript.ScriptRuntime.getMessage(ScriptRuntime.java:3312)
	at org.mozilla.javascript.ScriptRuntime.getMessage0(ScriptRuntime.java:3273)

<snip>

Caused by: java.lang.IllegalStateException: Failed to create VMBridge instance
	at org.mozilla.javascript.VMBridge.makeInstance(VMBridge.java:68)
	at org.mozilla.javascript.VMBridge.<clinit>(VMBridge.java:48)
	... 132 more


I think this is because I still have RAP 2.1 tooling, and there seems to be no way to remove it without gutting my IDE. The feature that provides it is named "Eclipse for RCP and RAP developers" and it contains the eclipse platform, the p2 bundles, and the RCP/RAP feature--the latter which contains a plugin that upgraded my rap tooling from 1.5 to 2.1.

If there's a way to fix the problem I'm having while still using RAP 2.1 tooling, that's fine. But I assume that's not recommended since I'm developing for a RAP 1.5 target.

So is there a way to downgrade RAP tooling, or do I have to start with a new IDE?
Re: Can't Revert from Rap 2.1 to RAP 1.5 [message #1086950 is a reply to message #1086864] Thu, 15 August 2013 00:28 Go to previous message
Mark Leone is currently offline Mark Leone
Messages: 67
Registered: April 2012
Member
After running my workspace in an Indigo IDE with RAP 1.5 tooling, and then running the workspace again in the Juno IDE with RAP 2.1 tooling where I had the problem originally, the exception above is no longer occurring. I'll write this off as another case of eclipse holding onto some bundle after switching targets, which happens from time to time, even after restarting with -clean.

So my remaining questions are:

1. Is it a bad idea to use RAP 2.1 tooling when developing a RAP 1.5 app?
2. If the answer to 1. is yes, is there a way to revert the tooling from 2.1 to 1.5?
Previous Topic:RAP/EMF Integration
Next Topic:Adding a MouseMove Listener to a Remote Object-based Custom Widget
Goto Forum:
  


Current Time: Thu Sep 18 07:51:34 GMT 2014

Powered by FUDForum. Page generated in 0.02711 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software