Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Install missing dependencies(Missing )
Install missing dependencies [message #1086043] Tue, 13 August 2013 18:26 Go to next message
George Foster is currently offline George Foster
Messages: 2
Registered: August 2013
Junior Member
I would love some help - I'm sitting in one of Paul Anderson's JavaFX classes and trying to setup in Eclipse instead of using NetBeans. I am trying to install e(fx)clipse from the nightly builds site. The install fails due to lack of the org.eclipse.xtext.ui 0.0.0.

My update sites enabled are:

http://download.eclipse.org/eclipse/updates/4.3
http://download.eclipse.org/efxclipse/updates-nightly/site/
http://download.eclipse.org/efxclipse/runtime-nightly/site/

I am selecting this option:
e(fx)clipse - IDE - Kepler 0.9.0.201308040611

Environment:
Running Win7 Home Premium 64bit
Eclipse 4.3 Kepler
Using jdk 1.7.0_25 inside Eclipse, but Eclipse is running on JRE

The error message is:
Cannot complete the install because one or more required items could not be found.
  Software being installed: e(fx)clipse - IDE - Kepler 0.9.0.201308040611 (org.eclipse.fx.ide.all.kepler.feature.feature.group 0.9.0.201308040611)
  Missing requirement: FXGraph UI 0.9.0.201308040611 (org.eclipse.fx.ide.fxgraph.ui 0.9.0.201308040611) requires 'bundle org.eclipse.xtext.ui 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: e(fx)clipse - IDE - Kepler 0.9.0.201308040611 (org.eclipse.fx.ide.all.kepler.feature.feature.group 0.9.0.201308040611)
    To: org.eclipse.fx.ide.fxgraph.feature.feature.group [0.9.0.201308040611]
  Cannot satisfy dependency:
    From: e(fx)clipse - IDE - FXGraph 0.9.0.201308040611 (org.eclipse.fx.ide.fxgraph.feature.feature.group 0.9.0.201308040611)
    To: org.eclipse.fx.ide.fxgraph.ui [0.9.0.201308040611]
Re: Install missing dependencies [message #1086446 is a reply to message #1086043] Wed, 14 August 2013 08:03 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5422
Registered: July 2009
Senior Member
Hi,

Easiest solution is to download
http://downloads.efxclipse.org/eclipse.org/sdks/nightly/ which is a
completely prebuild Eclipse 4.3 including xtext, efxclipse and a bit more.

If you need xtext you need to add the Kepler updatesite which is at
http://download.eclipse.org/releases/kepler

Tom

On 13.08.13 20:30, George Foster wrote:
> I would love some help - I'm sitting in one of Paul Anderson's JavaFX
> classes and trying to setup in Eclipse instead of using NetBeans. I am
> trying to install e(fx)clipse from the nightly builds site. The install
> fails due to lack of the org.eclipse.xtext.ui 0.0.0.
>
> My update sites enabled are:
>
> http://download.eclipse.org/eclipse/updates/4.3
> http://download.eclipse.org/efxclipse/updates-nightly/site/
> http://download.eclipse.org/efxclipse/runtime-nightly/site/
>
> I am selecting this option:
> e(fx)clipse - IDE - Kepler 0.9.0.201308040611
>
> Environment:
> Running Win7 Home Premium 64bit
> Eclipse 4.3 Kepler
> Using jdk 1.7.0_25 inside Eclipse, but Eclipse is running on JRE
> The error message is:
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: e(fx)clipse - IDE - Kepler 0.9.0.201308040611
> (org.eclipse.fx.ide.all.kepler.feature.feature.group 0.9.0.201308040611)
> Missing requirement: FXGraph UI 0.9.0.201308040611
> (org.eclipse.fx.ide.fxgraph.ui 0.9.0.201308040611) requires 'bundle
> org.eclipse.xtext.ui 0.0.0' but it could not be found
> Cannot satisfy dependency:
> From: e(fx)clipse - IDE - Kepler 0.9.0.201308040611
> (org.eclipse.fx.ide.all.kepler.feature.feature.group 0.9.0.201308040611)
> To: org.eclipse.fx.ide.fxgraph.feature.feature.group
> [0.9.0.201308040611]
> Cannot satisfy dependency:
> From: e(fx)clipse - IDE - FXGraph 0.9.0.201308040611
> (org.eclipse.fx.ide.fxgraph.feature.feature.group 0.9.0.201308040611)
> To: org.eclipse.fx.ide.fxgraph.ui [0.9.0.201308040611]
Re: Install missing dependencies [message #1087002 is a reply to message #1086446] Thu, 15 August 2013 02:23 Go to previous messageGo to next message
George Foster is currently offline George Foster
Messages: 2
Registered: August 2013
Junior Member
The full download of the preconfigured 4.3 with e(fx)clipse did the trick.

Comparing this version to the regular 4.3 I already have, I see that I am getting p2 errors in the "broken" version of Eclipse when I point to the Kepler directory, so it appears the problem is in p2 or equinox in my install, totally unrelated to e(fx)clipse - it just couldn't read that update site properly to get the dependency.

Thanks for your assistance. My brief look at the e(fx)clipse capabilities reassure me that switching to NetBeans wouldn't be any improvement over Eclipse and I can stay in my usual environment.
Re: Install missing dependencies [message #1087196 is a reply to message #1087002] Thu, 15 August 2013 09:12 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5422
Registered: July 2009
Senior Member
Hi George,

We are steadily improving and have cool new features in the upcoming
release 0.9.0, e.g. the preview will allow you preview your stuff in
different resolutions (fixed Java7 problems just last night) and more in
the pipeline for 1.0 (maven, robovm, gradient editing, css editor
improvements).

Tom

On 15.08.13 04:23, George Foster wrote:
> The full download of the preconfigured 4.3 with e(fx)clipse did the trick.
>
> Comparing this version to the regular 4.3 I already have, I see that I
> am getting p2 errors in the "broken" version of Eclipse when I point to
> the Kepler directory, so it appears the problem is in p2 or equinox in
> my install, totally unrelated to e(fx)clipse - it just couldn't read
> that update site properly to get the dependency.
>
> Thanks for your assistance. My brief look at the e(fx)clipse
> capabilities reassure me that switching to NetBeans wouldn't be any
> improvement over Eclipse and I can stay in my usual environment.
Previous Topic:install problems
Next Topic:Running and exporting Tutorial 3 (Java8) problems
Goto Forum:
  


Current Time: Sat Oct 25 09:32:14 GMT 2014

Powered by FUDForum. Page generated in 0.03349 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software