Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » SCM Polling threads(SCM polling activities not being kept up with threads)
SCM Polling threads [message #1085977] Tue, 13 August 2013 16:20 Go to next message
Stuart Lorber is currently offline Stuart LorberFriend
Messages: 44
Registered: June 2013
Member
I've just gotten this for the first time.

I'm using 3.1.0-RC1.

I noticed my SCM polling jobs were not being kicked off but I happened to go into Configuration and saw this message.

"There are more SCM polling activities scheduled than handled, so the threads are not keeping up with the demands. Check if your polling is hanging, and/or increase the number of threads if necessary."

Polling doesn't seem to restart right away or requires more than one restart and / or restarting of the slave agents.
Re: SCM Polling threads [message #1086759 is a reply to message #1085977] Wed, 14 August 2013 17:21 Go to previous messageGo to next message
Geoff Waymark is currently offline Geoff WaymarkFriend
Messages: 26
Registered: July 2012
Junior Member
Hi Stuart,

How often are your jobs polling?
And what is/are the scm(s) in question?

Using a * * * * * polling scheme will quickly run out of threads. I use every 2 mins with no problems on 3.1.0-RC1 */2 * * * *

Thanks


Geoff Waymark
Eclipse Hudson team
Re: SCM Polling threads [message #1086775 is a reply to message #1086759] Wed, 14 August 2013 17:51 Go to previous messageGo to next message
Stuart Lorber is currently offline Stuart LorberFriend
Messages: 44
Registered: June 2013
Member
They are:

15,35,55 * * * *
10,30,50 * * * *
*/10 * * * *
Re: SCM Polling threads [message #1088030 is a reply to message #1086775] Fri, 16 August 2013 13:26 Go to previous message
Geoff Waymark is currently offline Geoff WaymarkFriend
Messages: 26
Registered: July 2012
Junior Member
That all looks fine.

If it happens again could you get a thread dump of the VM. Ctrl - \ on linux or Ctrl - Break on Windows and email it to me at

mygwaymark [A T] gmail [D O T] com

Thanks


Geoff Waymark
Eclipse Hudson team
Previous Topic:Using Git with Hudson
Next Topic:Still Having Problems with Git on Hudson
Goto Forum:
  


Current Time: Mon Dec 22 20:51:16 GMT 2014

Powered by FUDForum. Page generated in 0.01747 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software