Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » NatTable » Multiple Selection is not enforced after setting flag in the selection model.
Multiple Selection is not enforced after setting flag in the selection model. [message #1085032] Mon, 12 August 2013 11:10 Go to next message
SD Khan is currently offline SD KhanFriend
Messages: 63
Registered: May 2013
Member
Hi!

i have set the multiple selection in nattable as false, through selection model like,

selectionlayer.getSelectionModel().setMultipleSelectionAllowed(false);


when i try to select multiple rows using "ctrl" key, it is not allowed and previous selection gets unselected and it restrain multiple selection but
when i select rows consecutively using mouse or using "shift" key then multiple selection is not enforced.

So, my question, is it a bug or work as designed?, if it is work as designed and no built in support is provided then it means i should listen to selection event and perform this mechanism manually to enforce multiple selection as not allowed?,

Regards,
SD Khan

[Updated on: Mon, 12 August 2013 11:12]

Report message to a moderator

Re: Multiple Selection is not enforced after setting flag in the selection model. [message #1085049 is a reply to message #1085032] Mon, 12 August 2013 11:32 Go to previous messageGo to next message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 1405
Registered: July 2012
Senior Member
Sounds like a bug which is related to inspecting the multipleSelectionAllowed flag. Haven't investigated it much but it is only inspected in addSelectionIntoList() which is getting a Rectangle to select. I guess selecting holding the mouse key or the shift key pressed will call this method susequently using a greater Rectangle, but using the original starting points.

I guess the solution could be to inspect that flag in the commands that perform the selection and respectively transform the Rectangle according to it.

Could you please open a ticket and link to this thread?
Re: Multiple Selection is not enforced after setting flag in the selection model. [message #1085061 is a reply to message #1085049] Mon, 12 August 2013 11:52 Go to previous message
SD Khan is currently offline SD KhanFriend
Messages: 63
Registered: May 2013
Member
I have opened the ticket.

Bug ID = 414862
URL = https://bugs.eclipse.org/bugs/show_bug.cgi?id=414862

Thanks,
Safdar Khan
Previous Topic:Editing and RowSpans
Next Topic:activateCell() method doesn't get called
Goto Forum:
  


Current Time: Mon Nov 24 04:09:43 GMT 2014

Powered by FUDForum. Page generated in 0.02216 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software