Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » install problems
install problems [message #1082338] Thu, 08 August 2013 12:31 Go to next message
Enrico R. is currently offline Enrico R.Friend
Messages: 43
Registered: July 2009
Location: Germany
Member

Hello,

I try to install efxclipse 0.8.1 into Kepler (4.3.0 I20130605-2000) but i still get these errors:

Cannot complete the install because one or more required items could not be found.
  Software being installed: e(fx)clipse - All in One 0.8.1.201303200240 (at.bestsolution.efxclipse.feature.feature.group 0.8.1.201303200240)
  Missing requirement: Jemmy 0.8.1.201303112105 (at.bestsolution.efxclipse.runtime.jemmy 0.8.1.201303112105) requires 'bundle org.junit4 4.8.1' but it could not be found
  Missing requirement: Jemmy 0.8.1.201303200240 (at.bestsolution.efxclipse.runtime.jemmy 0.8.1.201303200240) requires 'bundle org.junit4 4.8.1' but it could not be found
  Cannot satisfy dependency:
    From: e(fx)clipse - All in One 0.8.1.201303200240 (at.bestsolution.efxclipse.feature.feature.group 0.8.1.201303200240)
    To: at.bestsolution.efxclipse.tooling.feature.feature.group [0.8.1.201303200240]
  Cannot satisfy dependency:
    From: e(fx)clipse - Jemmy FX to Junit Test OSGi-Apps 0.8.1.201303112105 (at.bestsolution.efxclipse.runtime.jemmy.junit.feature.feature.group 0.8.1.201303112105)
    To: at.bestsolution.efxclipse.runtime.jemmy [0.8.1.201303112105]
  Cannot satisfy dependency:
    From: e(fx)clipse - Jemmy FX to Junit Test OSGi-Apps 0.8.1.201303200240 (at.bestsolution.efxclipse.runtime.jemmy.junit.feature.feature.group 0.8.1.201303200240)
    To: at.bestsolution.efxclipse.runtime.jemmy [0.8.1.201303200240]
  Cannot satisfy dependency:
    From: e(fx)clipse - Composite - FX Tooling 0.8.1.201303200240 (at.bestsolution.efxclipse.tooling.feature.feature.group 0.8.1.201303200240)
    To: at.bestsolution.efxclipse.runtime.jemmy.junit.feature.feature.group 0.8.1


Running Kepler (64Bit) on Win7 (64Bit) with JDK 1.7u25 (64Bit) and I used these update sites:
http://www.efxclipse.org/p2-repos/nightly/site/
http://downloads.efxclipse.org/p2-repos/releases/latest/

both with same results.

I also tried to install only "e(fx)clipse - Composite - FX Tooling 0.8.1.201303112105" but it ended in the same result.

Is there something broken? Should I use other update sites?

I appreciate any help.

Thanks...
Re: install problems [message #1082427 is a reply to message #1082338] Thu, 08 August 2013 14:51 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5467
Registered: July 2009
Senior Member
For Kepler install please use
http://download.eclipse.org/efxclipse/updates-nightly/site and if you
want to setup a target use
http://download.eclipse.org/efxclipse/runtime-nightly/site

Tom

On 08.08.13 14:31, Enrico R. wrote:
> Hello,
>
> I try to install efxclipse 0.8.1 into Kepler (4.3.0 I20130605-2000) but
> i still get these errors:
>
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: e(fx)clipse - All in One 0.8.1.201303200240
> (at.bestsolution.efxclipse.feature.feature.group 0.8.1.201303200240)
> Missing requirement: Jemmy 0.8.1.201303112105
> (at.bestsolution.efxclipse.runtime.jemmy 0.8.1.201303112105) requires
> 'bundle org.junit4 4.8.1' but it could not be found
> Missing requirement: Jemmy 0.8.1.201303200240
> (at.bestsolution.efxclipse.runtime.jemmy 0.8.1.201303200240) requires
> 'bundle org.junit4 4.8.1' but it could not be found
> Cannot satisfy dependency:
> From: e(fx)clipse - All in One 0.8.1.201303200240
> (at.bestsolution.efxclipse.feature.feature.group 0.8.1.201303200240)
> To: at.bestsolution.efxclipse.tooling.feature.feature.group
> [0.8.1.201303200240]
> Cannot satisfy dependency:
> From: e(fx)clipse - Jemmy FX to Junit Test OSGi-Apps
> 0.8.1.201303112105
> (at.bestsolution.efxclipse.runtime.jemmy.junit.feature.feature.group
> 0.8.1.201303112105)
> To: at.bestsolution.efxclipse.runtime.jemmy [0.8.1.201303112105]
> Cannot satisfy dependency:
> From: e(fx)clipse - Jemmy FX to Junit Test OSGi-Apps
> 0.8.1.201303200240
> (at.bestsolution.efxclipse.runtime.jemmy.junit.feature.feature.group
> 0.8.1.201303200240)
> To: at.bestsolution.efxclipse.runtime.jemmy [0.8.1.201303200240]
> Cannot satisfy dependency:
> From: e(fx)clipse - Composite - FX Tooling 0.8.1.201303200240
> (at.bestsolution.efxclipse.tooling.feature.feature.group
> 0.8.1.201303200240)
> To:
> at.bestsolution.efxclipse.runtime.jemmy.junit.feature.feature.group 0.8.1
>
>
> Running Kepler (64Bit) on Win7 (64Bit) with JDK 1.7u25 (64Bit) and I
> used these update sites:
> http://www.efxclipse.org/p2-repos/nightly/site/
> http://downloads.efxclipse.org/p2-repos/releases/latest/
>
> both with same results.
>
> I also tried to install only "e(fx)clipse - Composite - FX Tooling
> 0.8.1.201303112105" but it ended in the same result.
>
> Is there something broken? Should I use other update sites?
>
> I appreciate any help.
>
> Thanks...
Re: install problems [message #1082433 is a reply to message #1082427] Thu, 08 August 2013 15:02 Go to previous message
Enrico R. is currently offline Enrico R.Friend
Messages: 43
Registered: July 2009
Location: Germany
Member

Thanks alot Thomas!
It works now.
Previous Topic:Re: application doesn't start anymore
Next Topic:Install missing dependencies
Goto Forum:
  


Current Time: Wed Nov 26 03:22:40 GMT 2014

Powered by FUDForum. Page generated in 0.08727 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software