Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » application doesn't start anymore
application doesn't start anymore [message #1081462] Wed, 07 August 2013 04:58 Go to next message
Patrick Sowada is currently offline Patrick Sowada
Messages: 6
Registered: July 2009
Junior Member
Hi,

my application doesn't start anymore and i don't know what is wrong:

Quote:
!ENTRY org.eclipse.e4.ui.workbench 4 0 2013-08-07 10:18:05.375
!MESSAGE Unable to retrieve the bundle from the URI: bundleclass://at.bestsolution.efxclipse.runtime
.workbench.renderers.fx/at.bestsolution.efxclipse.runtime.workbench.renderers.fx.DefWorkbenchRendere
rFactory
Exception in Application start method
Exception in Application stop method

!ENTRY org.eclipse.equinox.app 4 0 2013-08-07 10:18:05.430
!MESSAGE Exception in Application start method
!STACK 0
java.lang.RuntimeException: Exception in Application start method
at com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:403)
at com.sun.javafx.application.LauncherImpl.access$000(LauncherImpl.java:47)
at com.sun.javafx.application.LauncherImpl$1.run(LauncherImpl.java:115)
at java.lang.Thread.run(Thread.java:724)
Caused by: java.lang.NullPointerException
at at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.getRenderer(PartRenderingEngi
ne.java:162)
at at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.createWidget(PartRenderingEng
ine.java:147)
at at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.createGui(PartRenderingEngine
.java:114)
at at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.createGui(PartRenderingEngine
.java:220)
at at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.run(PartRenderingEngine.java:
335)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:86)
at at.bestsolution.efxclipse.runtime.workbench.fx.E4Application.jfxStart(E4Application.java:114)
at at.bestsolution.efxclipse.runtime.application.AbstractJFXApplication$JFXApp.start(AbstractJFXApp
lication.java:46)
at com.sun.javafx.application.LauncherImpl$5.run(LauncherImpl.java:319)
at com.sun.javafx.application.PlatformImpl$5.run(PlatformImpl.java:215)
at com.sun.javafx.application.PlatformImpl$4$1.run(PlatformImpl.java:179)
at com.sun.javafx.application.PlatformImpl$4$1.run(PlatformImpl.java:176)
at java.security.AccessController.doPrivileged(Native Method)
at com.sun.javafx.application.PlatformImpl$4.run(PlatformImpl.java:176)
at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
at com.sun.glass.ui.win.WinApplication.access$100(WinApplication.java:29)
at com.sun.glass.ui.win.WinApplication$3$1.run(WinApplication.java:73)
... 1 more


The message said that my application cannot load the "DefWorkbenchRendererFactory" class but the plugin that contains this class is in my product.

<plugins>
      <plugin id="at.bestsolution.efxclipse.runtime.application"/>
      <plugin id="at.bestsolution.efxclipse.runtime.bindings"/>
      <plugin id="at.bestsolution.efxclipse.runtime.bindings.e4"/>
      <plugin id="at.bestsolution.efxclipse.runtime.core"/>
      <plugin id="at.bestsolution.efxclipse.runtime.databinding"/>
      <plugin id="at.bestsolution.efxclipse.runtime.di"/>
      <plugin id="at.bestsolution.efxclipse.runtime.javafx"/>
      <plugin id="at.bestsolution.efxclipse.runtime.osgi" fragment="true"/>
      <plugin id="at.bestsolution.efxclipse.runtime.osgi.util"/>
      <plugin id="at.bestsolution.efxclipse.runtime.panels"/>
      <plugin id="at.bestsolution.efxclipse.runtime.services"/>
      <plugin id="at.bestsolution.efxclipse.runtime.theme"/>
      <plugin id="at.bestsolution.efxclipse.runtime.workbench.base"/>
      <plugin id="at.bestsolution.efxclipse.runtime.workbench.fx"/>
      <plugin id="com.ibm.icu"/>
      <plugin id="javax.annotation"/>
      <plugin id="javax.inject"/>
      <plugin id="javax.xml"/>
      <plugin id="org.apache.batik.css"/>
      <plugin id="org.apache.batik.util"/>
      <plugin id="org.apache.batik.util.gui"/>
      <plugin id="org.eclipse.core.commands"/>
      <plugin id="org.eclipse.core.contenttype"/>
      <plugin id="org.eclipse.core.databinding"/>
      <plugin id="org.eclipse.core.databinding.beans"/>
      <plugin id="org.eclipse.core.databinding.observable"/>
      <plugin id="org.eclipse.core.databinding.property"/>
      <plugin id="org.eclipse.core.expressions"/>
      <plugin id="org.eclipse.core.jobs"/>
      <plugin id="org.eclipse.core.runtime"/>
      <plugin id="org.eclipse.core.runtime.compatibility.registry" fragment="true"/>
      <plugin id="org.eclipse.e4.core.commands"/>
      <plugin id="org.eclipse.e4.core.contexts"/>
      <plugin id="org.eclipse.e4.core.di"/>
      <plugin id="org.eclipse.e4.core.di.extensions"/>
      <plugin id="org.eclipse.e4.core.services"/>
      <plugin id="org.eclipse.e4.ui.bindings"/>
      <plugin id="org.eclipse.e4.ui.css.core"/>
      <plugin id="org.eclipse.e4.ui.css.swt"/>
      <plugin id="org.eclipse.e4.ui.css.swt.theme"/>
      <plugin id="org.eclipse.e4.ui.di"/>
      <plugin id="org.eclipse.e4.ui.model.workbench"/>
      <plugin id="org.eclipse.e4.ui.services"/>
      <plugin id="org.eclipse.e4.ui.widgets"/>
      <plugin id="org.eclipse.e4.ui.workbench"/>
      <plugin id="org.eclipse.e4.ui.workbench.addons.swt"/>
      <plugin id="org.eclipse.e4.ui.workbench.renderers.swt"/>
      <plugin id="org.eclipse.e4.ui.workbench.swt"/>
      <plugin id="org.eclipse.e4.ui.workbench3"/>
      <plugin id="org.eclipse.emf.common"/>
      <plugin id="org.eclipse.emf.ecore"/>
      <plugin id="org.eclipse.emf.ecore.change"/>
      <plugin id="org.eclipse.emf.ecore.xmi"/>
      <plugin id="org.eclipse.equinox.app"/>
      <plugin id="org.eclipse.equinox.common"/>
      <plugin id="org.eclipse.equinox.ds"/>
      <plugin id="org.eclipse.equinox.event"/>
      <plugin id="org.eclipse.equinox.preferences"/>
      <plugin id="org.eclipse.equinox.registry"/>
      <plugin id="org.eclipse.equinox.util"/>
      <plugin id="org.eclipse.help"/>
      <plugin id="org.eclipse.jface"/>
      <plugin id="org.eclipse.jface.databinding"/>
      <plugin id="org.eclipse.osgi"/>
      <plugin id="org.eclipse.osgi.services"/>
      <plugin id="org.eclipse.swt"/>
      <plugin id="org.eclipse.swt.win32.win32.x86_64" fragment="true"/>
      <plugin id="org.eclipse.ui"/>
      <plugin id="org.eclipse.ui.workbench"/>
      <plugin id="org.w3c.css.sac"/>
      <plugin id="org.w3c.dom.smil"/>
      <plugin id="org.w3c.dom.svg"/>
      ... // my plug-ins
   </plugins>


Regards,
Patrick
Re: application doesn't start anymore [message #1081478 is a reply to message #1081462] Wed, 07 August 2013 05:21 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5191
Registered: July 2009
Senior Member
So the root problem is that
at.bestsolution.efxclipse.runtime.workbench.renderers.fx is not available!

Any other statements in the log? Please use the eclipse.efxclipse for
efx questions!

Tom

On 07.08.13 10:58, Patrick Sowada wrote:
> Hi,
>
> my application doesn't start anymore and i don't know what is wrong:
>
> Quote:
>> !ENTRY org.eclipse.e4.ui.workbench 4 0 2013-08-07 10:18:05.375
>> !MESSAGE Unable to retrieve the bundle from the URI:
>> bundleclass://at.bestsolution.efxclipse.runtime
>> .workbench.renderers.fx/at.bestsolution.efxclipse.runtime.workbench.renderers.fx.DefWorkbenchRendere
>>
>> rFactory
>> Exception in Application start method
>> Exception in Application stop method
>>
>> !ENTRY org.eclipse.equinox.app 4 0 2013-08-07 10:18:05.430
>> !MESSAGE Exception in Application start method
>> !STACK 0
>> java.lang.RuntimeException: Exception in Application start method
>> at
>> com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:403)
>>
>> at
>> com.sun.javafx.application.LauncherImpl.access$000(LauncherImpl.java:47)
>> at
>> com.sun.javafx.application.LauncherImpl$1.run(LauncherImpl.java:115)
>> at java.lang.Thread.run(Thread.java:724)
>> Caused by: java.lang.NullPointerException
>> at
>> at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.getRenderer(PartRenderingEngi
>>
>> ne.java:162)
>> at
>> at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.createWidget(PartRenderingEng
>>
>> ine.java:147)
>> at
>> at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.createGui(PartRenderingEngine
>>
>> .java:114)
>> at
>> at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.createGui(PartRenderingEngine
>>
>> .java:220)
>> at
>> at.bestsolution.efxclipse.runtime.workbench.fx.PartRenderingEngine.run(PartRenderingEngine.java:
>>
>> 335)
>> at
>> org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:86)
>>
>> at
>> at.bestsolution.efxclipse.runtime.workbench.fx.E4Application.jfxStart(E4Application.java:114)
>>
>> at
>> at.bestsolution.efxclipse.runtime.application.AbstractJFXApplication$JFXApp.start(AbstractJFXApp
>>
>> lication.java:46)
>> at
>> com.sun.javafx.application.LauncherImpl$5.run(LauncherImpl.java:319)
>> at
>> com.sun.javafx.application.PlatformImpl$5.run(PlatformImpl.java:215)
>> at
>> com.sun.javafx.application.PlatformImpl$4$1.run(PlatformImpl.java:179)
>> at
>> com.sun.javafx.application.PlatformImpl$4$1.run(PlatformImpl.java:176)
>> at java.security.AccessController.doPrivileged(Native Method)
>> at
>> com.sun.javafx.application.PlatformImpl$4.run(PlatformImpl.java:176)
>> at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
>> at
>> com.sun.glass.ui.win.WinApplication.access$100(WinApplication.java:29)
>> at
>> com.sun.glass.ui.win.WinApplication$3$1.run(WinApplication.java:73)
>> ... 1 more
>
>
> The message said that my application cannot load the
> "DefWorkbenchRendererFactory" class but the plugin that contains this
> class is in my product.
>
> <plugins>
> <plugin id="at.bestsolution.efxclipse.runtime.application"/>
> <plugin id="at.bestsolution.efxclipse.runtime.bindings"/>
> <plugin id="at.bestsolution.efxclipse.runtime.bindings.e4"/>
> <plugin id="at.bestsolution.efxclipse.runtime.core"/>
> <plugin id="at.bestsolution.efxclipse.runtime.databinding"/>
> <plugin id="at.bestsolution.efxclipse.runtime.di"/>
> <plugin id="at.bestsolution.efxclipse.runtime.javafx"/>
> <plugin id="at.bestsolution.efxclipse.runtime.osgi" fragment="true"/>
> <plugin id="at.bestsolution.efxclipse.runtime.osgi.util"/>
> <plugin id="at.bestsolution.efxclipse.runtime.panels"/>
> <plugin id="at.bestsolution.efxclipse.runtime.services"/>
> <plugin id="at.bestsolution.efxclipse.runtime.theme"/>
> <plugin id="at.bestsolution.efxclipse.runtime.workbench.base"/>
> <plugin id="at.bestsolution.efxclipse.runtime.workbench.fx"/>
> <plugin id="com.ibm.icu"/>
> <plugin id="javax.annotation"/>
> <plugin id="javax.inject"/>
> <plugin id="javax.xml"/>
> <plugin id="org.apache.batik.css"/>
> <plugin id="org.apache.batik.util"/>
> <plugin id="org.apache.batik.util.gui"/>
> <plugin id="org.eclipse.core.commands"/>
> <plugin id="org.eclipse.core.contenttype"/>
> <plugin id="org.eclipse.core.databinding"/>
> <plugin id="org.eclipse.core.databinding.beans"/>
> <plugin id="org.eclipse.core.databinding.observable"/>
> <plugin id="org.eclipse.core.databinding.property"/>
> <plugin id="org.eclipse.core.expressions"/>
> <plugin id="org.eclipse.core.jobs"/>
> <plugin id="org.eclipse.core.runtime"/>
> <plugin id="org.eclipse.core.runtime.compatibility.registry"
> fragment="true"/>
> <plugin id="org.eclipse.e4.core.commands"/>
> <plugin id="org.eclipse.e4.core.contexts"/>
> <plugin id="org.eclipse.e4.core.di"/>
> <plugin id="org.eclipse.e4.core.di.extensions"/>
> <plugin id="org.eclipse.e4.core.services"/>
> <plugin id="org.eclipse.e4.ui.bindings"/>
> <plugin id="org.eclipse.e4.ui.css.core"/>
> <plugin id="org.eclipse.e4.ui.css.swt"/>
> <plugin id="org.eclipse.e4.ui.css.swt.theme"/>
> <plugin id="org.eclipse.e4.ui.di"/>
> <plugin id="org.eclipse.e4.ui.model.workbench"/>
> <plugin id="org.eclipse.e4.ui.services"/>
> <plugin id="org.eclipse.e4.ui.widgets"/>
> <plugin id="org.eclipse.e4.ui.workbench"/>
> <plugin id="org.eclipse.e4.ui.workbench.addons.swt"/>
> <plugin id="org.eclipse.e4.ui.workbench.renderers.swt"/>
> <plugin id="org.eclipse.e4.ui.workbench.swt"/>
> <plugin id="org.eclipse.e4.ui.workbench3"/>
> <plugin id="org.eclipse.emf.common"/>
> <plugin id="org.eclipse.emf.ecore"/>
> <plugin id="org.eclipse.emf.ecore.change"/>
> <plugin id="org.eclipse.emf.ecore.xmi"/>
> <plugin id="org.eclipse.equinox.app"/>
> <plugin id="org.eclipse.equinox.common"/>
> <plugin id="org.eclipse.equinox.ds"/>
> <plugin id="org.eclipse.equinox.event"/>
> <plugin id="org.eclipse.equinox.preferences"/>
> <plugin id="org.eclipse.equinox.registry"/>
> <plugin id="org.eclipse.equinox.util"/>
> <plugin id="org.eclipse.help"/>
> <plugin id="org.eclipse.jface"/>
> <plugin id="org.eclipse.jface.databinding"/>
> <plugin id="org.eclipse.osgi"/>
> <plugin id="org.eclipse.osgi.services"/>
> <plugin id="org.eclipse.swt"/>
> <plugin id="org.eclipse.swt.win32.win32.x86_64" fragment="true"/>
> <plugin id="org.eclipse.ui"/>
> <plugin id="org.eclipse.ui.workbench"/>
> <plugin id="org.w3c.css.sac"/>
> <plugin id="org.w3c.dom.smil"/>
> <plugin id="org.w3c.dom.svg"/>
> ... // my plug-ins
> </plugins>
>
> Regards,
> Patrick
Re: application doesn't start anymore [message #1081499 is a reply to message #1081478] Wed, 07 August 2013 05:48 Go to previous message
Patrick Sowada is currently offline Patrick Sowada
Messages: 6
Registered: July 2009
Junior Member
Thx, it works, i will keep it in my mind for the next time with the correct forum place.
Previous Topic:@Inject EMenuService ends in Nullpointer - Why?
Next Topic:Remove service registration from EventBroker when the service's context is getting disposed
Goto Forum:
  


Current Time: Thu Jul 10 03:22:45 EDT 2014

Powered by FUDForum. Page generated in 0.11351 seconds