Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » JGit lacking full support for https?(Problems when pushing to https-based repository)
JGit lacking full support for https? [message #1080847] Tue, 06 August 2013 08:55
Birgit Moeller is currently offline Birgit Moeller
Messages: 1
Registered: August 2013
Junior Member
Hi all,
we have a Git repository on a server accessible via the https protocol. While cloning the repository with the latest version of Egit from within Eclipse Kepler (running on Linux 64-bit) worked fine, we have now problems on doing a push. Basically Eclipse returns with the error message that "...remote does not support smart HTTP push". The same happens if we try to access the repository directly from command line using the stand-alone version of JGit packaged in org.eclipse.jgit.pgm-3.0.0.201306101825-r.sh, see exception below.
However, if we use git for Linux as downloadable from git-scm.com via command line we don't have any problems accessing the repository. Hence it seems that there is nothing wrong with the repository, but that JGit/EGit currently does not properly support the https protocol. Nevertheless, Egit claims to as it let's you select that protocol in the configuration dialog. I also did not find any restrictions with regard to that in the documentation. Or did we miss a configuration step and have to apply specific settings to push to the repository? Any hints are welcome!
Thanks in advance,

Birgit

P.S.: We already tried to add user login and password to the push URL, without success.

P.P.S: Exception of JGit stand-alone version:
org.eclipse.jgit.api.errors.JGitInternalException: Exception caught during execution of push command
at org.eclipse.jgit.api.PushCommand.call(PushCommand.java:174)
at org.eclipse.jgit.pgm.Push.run(Push.java:126)
at org.eclipse.jgit.pgm.TextBuiltin.execute(TextBuiltin.java:174)
at org.eclipse.jgit.pgm.Main.execute(Main.java:213)
at org.eclipse.jgit.pgm.Main.run(Main.java:121)
at org.eclipse.jgit.pgm.Main.main(Main.java:95)
Caused by: org.eclipse.jgit.errors.NotSupportedException: remote does not support smart HTTP push
at org.eclipse.jgit.transport.TransportHttp.openPush(TransportHttp.java:411)
at org.eclipse.jgit.transport.PushProcess.execute(PushProcess.java:154)
at org.eclipse.jgit.transport.Transport.push(Transport.java:1167)
at org.eclipse.jgit.api.PushCommand.call(PushCommand.java:156)
Previous Topic:Commit change in 2 branches
Next Topic:Cannot retrieve file from SHA-1 string
Goto Forum:
  


Current Time: Mon Jul 28 00:33:59 EDT 2014

Powered by FUDForum. Page generated in 0.02145 seconds