Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » scout - 3.9 - desktop node not showing
scout - 3.9 - desktop node not showing [message #1074731] Sat, 27 July 2013 11:37 Go to next message
Chris Snow is currently offline Chris Snow
Messages: 50
Registered: December 2011
Member
I have created a scout 3.9 application selecting the template 'Outline Tree and Table Form'.

The Desktop not does not show in the SDK. Is this expected?

How can I change menu's, etc without having access to the desktop node?
Re: scout - 3.9 - desktop node not showing [message #1074734 is a reply to message #1074731] Sat, 27 July 2013 11:41 Go to previous messageGo to next message
Chris Snow is currently offline Chris Snow
Messages: 50
Registered: December 2011
Member
the Desktop node has now stopped displaying on projects created using the template: "Application with a single Form"

[Updated on: Sat, 27 July 2013 11:41]

Report message to a moderator

Re: scout - 3.9 - desktop node not showing [message #1075270 is a reply to message #1074734] Mon, 29 July 2013 02:41 Go to previous messageGo to next message
Jeremie Bresson is currently offline Jeremie Bresson
Messages: 657
Registered: October 2011
Senior Member
Hi,

Can you provide more informations about your setting?

I have tried with 3.9.0.20130612-0904 (default version that is provided on the download page eclipse-scout-kepler-R-win32)

I have created a new application with a single form.
I see the Desktop node.

index.php/fa/15739/0/

This makes sense, because menus can be added to the desktop even in a "single form application".

Can you browse to the Java class with CTRL-Shift-T > "Desktop"?
What is your version?
Is this an old project (created with Juno) that you try to open with Kepler?
  • Attachment: Desktop.png
    (Size: 78.16KB, Downloaded 405 times)

[Updated on: Mon, 29 July 2013 02:43]

Report message to a moderator

Re: scout - 3.9 - desktop node not showing [message #1075290 is a reply to message #1075270] Mon, 29 July 2013 03:31 Go to previous messageGo to next message
Chris Snow is currently offline Chris Snow
Messages: 50
Registered: December 2011
Member
These were new projects created with kepler version of scout (3.9.0-20130612-0904).

I could see the Desktop files in the package view, even though the Desktop Nodes weren't showing in the scout view.

The Desktop node have become available after restarting eclipse.

I just created a new project (projectz) - and again no desktop:

index.php/fa/15741/0/

There is nothing reported in the eclipse .log file to indicate an error:

!SESSION 2013-07-29 08:16:38.464 -----------------------------------------------
eclipse.buildId=4.3.0.I20130605-2000
java.version=1.6.0_25
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Framework arguments:  -product org.eclipse.epp.package.scout.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.scout.product

!ENTRY org.eclipse.scout.sdk 1 0 2013-07-29 08:16:48.243
!MESSAGE org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	Starting SCOUT SDK Plugin.

!ENTRY org.eclipse.egit.ui 2 0 2013-07-29 08:18:44.333
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'C:\Users\snowc'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.






  • Attachment: nodesktop.png
    (Size: 21.35KB, Downloaded 371 times)

[Updated on: Mon, 29 July 2013 03:33]

Report message to a moderator

Re: scout - 3.9 - desktop node not showing [message #1075882 is a reply to message #1075290] Tue, 30 July 2013 05:08 Go to previous messageGo to next message
Jeremie Bresson is currently offline Jeremie Bresson
Messages: 657
Registered: October 2011
Senior Member
Hi,

I managed to reproduce your case. When I create a second project, the Desktop node is not visible.
Thanks a lot for reporting it.

=> Can you file a bug for this?

I know there are a couple of bugs (to be fixed with Luna) that address "project creation". Maybe this bug is also related.

In the meantime, I hope the workaround "restart the IDE" is sufficient for you.
Re: scout - 3.9 - desktop node not showing [message #1075957 is a reply to message #1075882] Tue, 30 July 2013 07:58 Go to previous messageGo to next message
Chris Snow is currently offline Chris Snow
Messages: 50
Registered: December 2011
Member
Bug created: https://bugs.eclipse.org/bugs/show_bug.cgi?id=414058

[Updated on: Tue, 30 July 2013 14:55]

Report message to a moderator

Re: scout - 3.9 - desktop node not showing [message #1076436 is a reply to message #1075957] Wed, 31 July 2013 07:53 Go to previous messageGo to next message
Jeremie Bresson is currently offline Jeremie Bresson
Messages: 657
Registered: October 2011
Senior Member
Thanks for having opened this bug.
Re: scout - 3.9 - desktop node not showing [message #1101323 is a reply to message #1075957] Wed, 04 September 2013 05:57 Go to previous messageGo to next message
Matthias Villiger is currently offline Matthias Villiger
Messages: 78
Registered: September 2011
Member
Bug is fixed for Kepler SR1.

Thanks for opening the bug.
[CLOSED]Re: scout - 3.9 - desktop node not showing [message #1112848 is a reply to message #1075957] Fri, 20 September 2013 04:57 Go to previous message
Dominic Hanlan is currently offline Dominic Hanlan
Messages: 98
Registered: July 2009
Member
Hi,

sorry didn't pick that thread up. Yes it's the same issue.
Previous Topic:New project wizard doesn't create all assets
Next Topic:No tabbed view with SWING
Goto Forum:
  


Current Time: Fri Aug 22 14:01:11 EDT 2014

Powered by FUDForum. Page generated in 0.15469 seconds