Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » [SOLVED] CDT Managed Build Setting Entry Include Paths
[SOLVED] CDT Managed Build Setting Entry Include Paths [message #1071350] Fri, 19 July 2013 22:42 Go to next message
DB Mising name is currently offline DB Mising nameFriend
Messages: 11
Registered: July 2009
Junior Member
The "Project Explorer > ${ProjName} > Includes" setting is showing incorrect/added include paths, for example, "/usr/include". It already has the correct version "/usr/local/angstrom/arm/arm-angstrom-linux-gnueabi/include".

It looks like it is coming from "Properties > C/C++ General > Preprocessor Include Paths, Macros etc." > "CDT Managed Build Setting Entries [ Shared ]". The "CDT GCC Built-in Compiler Settings" option here is adding the correct "/usr/local/angstrom/..." locations, however, all items in the "CDT Managed Build Setting Entries [ Shared ]" look to be using "gcc" not "arm-angstrom-eabi-gcc" for discovery.

If I deselect the "CDT Managed Build Setting Entires [ Shared ]" option, then I lose all my custom project includes via C/C++ Build > Settings > Includes, but the "Project Explorer > ${ProjName} > Includes" list is correct. Even after clearing the "Paths and Symbols" list readding the "CDT Managed Build Setting Entries [ Shared ]" provider adds the incorrect 'built-in' includes.

How do I:
a) Changed "CDT Managed Build Setting Entries [ Shared ]" to "[ Non-Shared ]" (similar to other providers).
b) Tell "CDT Managed Build Setting Entries" to use "arm-angstrom-eabi-"?

[Updated on: Fri, 26 July 2013 01:47]

Report message to a moderator

Re: CDT Managed Build Setting Entry Include Paths [message #1072235 is a reply to message #1071350] Mon, 22 July 2013 11:05 Go to previous messageGo to next message
Axel Mueller is currently offline Axel MuellerFriend
Messages: 1967
Registered: July 2009
Senior Member
In Project properties->C/C++ Build->Tool chain Editor you must specify your toolchain (I guess it is set to Linux gcc).

Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: CDT Managed Build Setting Entry Include Paths [message #1074011 is a reply to message #1072235] Thu, 25 July 2013 23:41 Go to previous messageGo to next message
DB Mising name is currently offline DB Mising nameFriend
Messages: 11
Registered: July 2009
Junior Member
It says "Current toolchain: Cross GCC". Also note the "C/C++ Build > Settings" has the "Prefix" set. But I have also tried "Current toolchain: Linux GCC" and manually changing each of the "C/C++ Build > XXX > Command:" items from, for example "gcc" to "arm-angstrom-eabi-gcc". Both result in the same observations though.

I think the problem (maybe bug?) is that the "C/C++ General > Preprocessor Includes > Providers" item "CDT Managed Build Setting Entries [ Shared ]" somehow adds "/usr/include" (aka gcc discovery item) when it shouldn't be to my knowledge? That task should be left to the "CDT GCC Build-In Compiler Settings" provider?

I suspect this because when I disable the "CDT Managed Build Settings Entries [ Shared ]" item the bad includes go away, then come back when I re-enable it.
http://snag.gy/8vSBA.jpg

Does anyone know why "CDT Managed Build Setting Entries [ Shared ]" would be adding GCC include paths? and how to edit this provider like the other providers so it uses my Cross GCC?


EDIT: Also note I'm using latest eclipse/CDT
Eclipse: Kepler Release Build ID: 20130614-0229
Eclipse CDT: 8.2.0.20130611238

[Updated on: Thu, 25 July 2013 23:48]

Report message to a moderator

Re: CDT Managed Build Setting Entry Include Paths [message #1074042 is a reply to message #1074011] Fri, 26 July 2013 01:22 Go to previous messageGo to next message
Andrew Gvozdev is currently offline Andrew GvozdevFriend
Messages: 256
Registered: July 2009
Senior Member
Sounds like your project is using 2 competing discovery methods. Check project properties -> C/C++ Build "Discovery Options" and disable "Automate discovery...". If this page does not show up enable it in Preferences-> C/C++ > Property Pages Settings.

You may also need to "Clear" entries discovered earlier on "Discovery Options" page for each language.
Re: CDT Managed Build Setting Entry Include Paths [message #1074048 is a reply to message #1074042] Fri, 26 July 2013 01:46 Go to previous message
DB Mising name is currently offline DB Mising nameFriend
Messages: 11
Registered: July 2009
Junior Member
Perfect, that was it thank you. These projects were imported from an older eclipse and the "Discovery Options" settings must of been retained from before. Enabling the page, unchecking "Automate discovery of paths and symbols", and clearing the old entries, fixed everything up.

[Updated on: Fri, 26 July 2013 01:48]

Report message to a moderator

Previous Topic:CDebugger Extension Does Not Load
Next Topic:Why is there no Index import but only index export?
Goto Forum:
  


Current Time: Mon Nov 24 08:24:55 GMT 2014

Powered by FUDForum. Page generated in 0.02255 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software