Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Changing from EL 2.1.3 to 2.5.0
Changing from EL 2.1.3 to 2.5.0 [message #1069913] Tue, 16 July 2013 21:38 Go to next message
Christian Eugster is currently offline Christian Eugster
Messages: 134
Registered: July 2009
Location: St. Gallen Switzerland
Senior Member
Hi, I want to update my app by changing eclipselink from 2.1.3 to 2.5.0 (or other) because in the 2.1.3 there is datepart function not properly implemented as I mean. In the mean time there seems a lot has changed and one has to use gemini to set up a db-connection. I installed gemini jpa 1.1.0 and eclipselink 2.5.0. Now gemini jpa does complain about unresolved constraints against javax.persistence;version 1.1.0. What is the best combination so I have no troubles with eclipselink and gemini concerning dependencies?
Thanks a lot!
Re: Changing from EL 2.1.3 to 2.5.0 (Resolved) [message #1070048 is a reply to message #1069913] Wed, 17 July 2013 06:39 Go to previous message
Christian Eugster is currently offline Christian Eugster
Messages: 134
Registered: July 2009
Location: St. Gallen Switzerland
Senior Member
Hi, I found the solution by not using gemini in my rcp app. Just eclipselink by instantiating org.eclipse.persistence.jpa.PersistenceProvider and using this to obtain EntityManagerFactories.
Previous Topic:Out of memory with level 2 cache enabled
Next Topic:How to use datepart function in expression
Goto Forum:
  


Current Time: Thu Oct 02 14:36:58 GMT 2014

Powered by FUDForum. Page generated in 0.02189 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software