Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Java headless build problems
Java headless build problems [message #1069639] Tue, 16 July 2013 09:40
Daniel Hausmacher is currently offline Daniel HausmacherFriend
Messages: 1
Registered: July 2013
Junior Member
Dear all,

I want to build a Java project using org.eclipse.ant.core.antRunner and productBuild.xml.

The build fails for one plugin, when it cannot find the definition of another plugin. Let's call them A and B, to keep the names short. So A depends on B, but B has been not compiled yet, when A is to be compiled. The autogenerated build.xml for A contains
. . . <pathelement path="../B/bin/"/>
. . . <pathelement path="../B/@dot"/>
as one would expect, but in ../B there is only src at this stage.

The first error is:
[javac] 1. ERROR in /home/daniel/eclipse/build/build/BuildDirectory/plugins/A/src/A/Runner.java (at line 9)
[javac] import B.TestReader;
[javac] ^
[javac] The import B cannot be resolved

All other errors are a direct consequence of this.

While debugging, I noticed that no build.xml has been generated for B. The setup of the plugin looks OK as far as I can tell.

Looking through my notes, I found that I previously had problems with this very dependency when building from within the Eclipse GUI. During the startup of the application, B was missing. I worked around that by including not only A, but also B in the feature that should include A. That made the application start OK. Again, as far as I can tell, the dependency from A to B looks OK as far as I can tell. I tried both Require-Package and Import-Bundle. All versioning has been removed from the dependency in the meantime.

B is listed in plugins.list and is available in the expected place.

So I think, there are two closely related issues, here:
- Why is there no build.xml for B?
- Why is the dependency from A on B missed?

What configuration files could be involved? I checked build.properties, .classpath, plugin.xml, .project, META-INF/MANIFEST.MF and found nothing that raised my suspicions.

Thanks, Daniel
Previous Topic:Moving .eclipse folder
Next Topic:Error "factory already defined" when trying to export jar
Goto Forum:
  


Current Time: Wed Nov 26 20:50:25 GMT 2014

Powered by FUDForum. Page generated in 0.08795 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software