Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » Dali and Plug-in Tooling Conflicts(Dali and Plug-in tools do not appear to work together)
Dali and Plug-in Tooling Conflicts [message #1069259] Mon, 15 July 2013 14:37 Go to next message
Dale Smith is currently offline Dale Smith
Messages: 3
Registered: June 2013
Junior Member
I am trying to create a plug-in that wraps JPA (EclipseLink) and exposes a small number of my own persistence methods. I've set up a JSE plugin project and added the JPA facet. The tools base is:
Kepler: 4.3.0 Build id: I20130605-2000
Dali EclipseLink and JPA Support: 3.3.0

I am not using Maven.

I want to use both eclipse plug-in tools and JPA (Dali) tools. The problem I'm facing is that the plugin tooling wants the META-INF folder to be located directly off the project root folder while the Dali tooling wants the META-INF folder to be located within the project/src folder.

For example, when META-INF is located at the project root, I get generation errors from "JPA Tools -> Generate Tables from Entities..." presumably because it can't locate persistence.xml When I move META-INF under the src folder, I can generate tables but I get dependency resolution errors because my plug-in dependencies can't be resolved by the plugin builder.

Am I missing something or does anyone have reasonable workarounds?

Pls let me know if there's a better spot in the forums to post this.

Thanks.
Re: Dali and Plug-in Tooling Conflicts [message #1069288 is a reply to message #1069259] Mon, 15 July 2013 15:48 Go to previous messageGo to next message
Paul Fullbright is currently offline Paul Fullbright
Messages: 200
Registered: July 2009
Senior Member
Dale,

I think you're running into this issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=373870

That said, there's no requirement that there be only one META-INF folder per project. A workaround is to put a second META-INF folder in the source folder and to put the JPA artifacts there. That should at least get your tables generated.

Cheers
Re: Dali and Plug-in Tooling Conflicts [message #1069367 is a reply to message #1069288] Mon, 15 July 2013 18:58 Go to previous message
Dale Smith is currently offline Dale Smith
Messages: 3
Registered: June 2013
Junior Member
Paul Fullbright wrote on Mon, 15 July 2013 11:48
Dale,

I think you're running into this issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=373870

That said, there's no requirement that there be only one META-INF folder per project. A workaround is to put a second META-INF folder in the source folder and to put the JPA artifacts there. That should at least get your tables generated.

Cheers


Thanks - much appreciated. I'll try the workaround, so consider this question answered.

Previous Topic:Dali 3.3 released with Kepler
Next Topic:Integrating Dali with a third party application
Goto Forum:
  


Current Time: Wed Oct 22 05:03:47 GMT 2014

Powered by FUDForum. Page generated in 0.01811 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software