Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Birt 4.3 in maven repository?
Birt 4.3 in maven repository? [message #1068137] Fri, 12 July 2013 07:13 Go to next message
Achim Heynen is currently offline Achim Heynen
Messages: 2
Registered: July 2013
Junior Member
Hi
I would like to update to birt 4.3 in a maven managed project. Unfortunately it seems as if birt 4.3 has not been published to maven. Am I using the wrong dependency or do I just have to wait?

Currently I'm using this dependency to use the previous birt version:

		<dependency>
			<groupId>org.eclipse.birt.runtime</groupId>
			<artifactId>org.eclipse.birt.runtime</artifactId>
			<version>4.2.2</version>
		</dependency>


I tried to upgrade with this dependency:

		<dependency>
			<groupId>org.eclipse.birt.runtime</groupId>
			<artifactId>org.eclipse.birt.runtime</artifactId>
			<version>4.3</version>
		</dependency>


Thanks in advance!
Re: Birt 4.3 in maven repository? [message #1069134 is a reply to message #1068137] Mon, 15 July 2013 04:16 Go to previous messageGo to next message
Achim Heynen is currently offline Achim Heynen
Messages: 2
Registered: July 2013
Junior Member
Woohoo - they heard me cry Wink

Birt 4.3 is available with:

		<dependency>
			<groupId>org.eclipse.birt.runtime</groupId>
			<artifactId>org.eclipse.birt.runtime</artifactId>
			<version>4.3.0</version>
		</dependency>


I had to exclude org.apache.poi in my project due to compilation errors (that dependency is included at several points). Don't know if that is a general problem, but in my case it works now.
Re: Birt 4.3 in maven repository? [message #1071247 is a reply to message #1069134] Fri, 19 July 2013 12:32 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1560
Registered: July 2009
Senior Member

Great! Thanks for updating the thread!

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Re: Birt 4.3 in maven repository? [message #1131067 is a reply to message #1068137] Thu, 10 October 2013 02:46 Go to previous messageGo to next message
Aym D is currently offline Aym D
Messages: 2
Registered: October 2013
Location: Toulouse
Junior Member
Hi,

Birt 4.3.1 was released on september. It allows to fix an Excel bug (timeZone not used), which I have in some reports.
Is it planned to put birt 4.3.1 in maven repositories ?

Thanks
Re: Birt 4.3 in maven repository? [message #1148428 is a reply to message #1131067] Mon, 21 October 2013 09:55 Go to previous messageGo to next message
Aym D is currently offline Aym D
Messages: 2
Registered: October 2013
Location: Toulouse
Junior Member
Birt 4.3.1 was added today on maven repositories. Thanks.
Re: Birt 4.3 in maven repository? [message #1274566 is a reply to message #1148428] Fri, 21 March 2014 12:46 Go to previous messageGo to next message
James McQuiggan is currently offline James McQuiggan
Messages: 1
Registered: March 2014
Junior Member
When will 4.3.2 make it into Maven?
Re: Birt 4.3 in maven repository? [message #1404366 is a reply to message #1068137] Thu, 31 July 2014 11:00 Go to previous message
Francisco Zuluaga is currently offline Francisco Zuluaga
Messages: 1
Registered: July 2014
Junior Member
After adding maven dependencies for Birt in my project I am getting next exception:

<Jul 31, 2014 10:02:06 AM EDT> <Warning> <HTTP> <BEA-101162> <User defined listener org.eclipse.birt.report.listener.ViewerServletContextListener failed: java.lang.NoClassDefFoundError: org/eclipse/birt/core/framework/eclipse/EclipseExtensionRegistry.
java.lang.NoClassDefFoundError: org/eclipse/birt/core/framework/eclipse/EclipseExtensionRegistry
at org.eclipse.birt.core.framework.eclipse.EclipsePlatform.getExtensionRegistry(EclipsePlatform.java:56)
at org.eclipse.birt.core.framework.eclipse.EclipsePlatform.createFactoryObject(EclipsePlatform.java:351)
at org.eclipse.birt.core.framework.Platform$1.run(Platform.java:297)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.birt.core.framework.Platform.createFactoryObject(Platform.java:293)
Truncated. see log file for complete stacktrace
Caused By: org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle org.eclipse.birt.core (4).
at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:121)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:469)
Truncated. see log file for complete stacktrace
Caused By: org.osgi.framework.BundleException: Exception in org.eclipse.birt.core.internal.plugin.CorePlugin.start() of bundle org.eclipse.birt.core.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:806)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:284)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)
Truncated. see log file for complete stacktrace
Caused By: java.lang.NoSuchMethodError: org.eclipse.birt.core.framework.Platform.setContextClassLoader(Ljava/lang/ClassLoader;)V
at org.eclipse.birt.core.internal.plugin.CorePlugin.start(CorePlugin.java:44)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
Truncated. see log file for complete stacktrace
>

The dependencies that I added are:

(I tried with different versions and I get the same error). Does someone have a suggestion?

<dependency>
<groupId>org.eclipse.birt.runtime</groupId>
<artifactId>org.eclipse.birt.runtime</artifactId>
<version>4.3.0</version>

<exclusions>
<exclusion>
<artifactId>org.apache.poi</artifactId>
<groupId>org.eclipse.birt.runtime</groupId>
</exclusion>
</exclusions>

</dependency>

<dependency>
<groupId>org.apache.poi</groupId>
<artifactId>poi</artifactId>
<version>3.9</version>
</dependency>

<dependency>
<groupId>org.eclipse.birt.runtime</groupId>
<artifactId>org.eclipse.emf.ecore</artifactId>
<version>2.9.1.v20130827-0309</version>
</dependency>

<dependency>
<groupId>org.eclipse.birt.runtime</groupId>
<artifactId>viewservlets</artifactId>
<version>4.3.0</version>
</dependency>
Previous Topic:Building of Birt from source code.
Next Topic:Build Birt Report Engine or Runtime
Goto Forum:
  


Current Time: Wed Aug 20 04:53:20 EDT 2014

Powered by FUDForum. Page generated in 0.02447 seconds