Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Installing EGit from Eclipse Marketplace(Cannot install EGit. Fail on dependency)
Installing EGit from Eclipse Marketplace [message #1067773] Wed, 10 July 2013 14:06 Go to next message
Michal Vitousek is currently offline Michal Vitousek
Messages: 2
Registered: July 2013
Junior Member
Hi,
please help me with installing EGit on my Eclipse - Indigo.

I find out EGit on marketplace and click to install.
During installation process when dependency was checking error appeared with the folowing details:

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Git Team Provider 3.0.0.201306101825-r (org.eclipse.egit.feature.group 3.0.0.201306101825-r)
Software currently installed: Eclipse IDE for Java EE Developers 1.4.2.20120213-0813 (epp.package.jee 1.4.2.20120213-0813)
Only one of the following can be installed at once:
Team Support Core 3.6.100.v20120524-0627 (org.eclipse.team.core 3.6.100.v20120524-0627)
Team Support Core 3.5.100.I20100527-0800 (org.eclipse.team.core 3.5.100.I20100527-0800)
Team Support Core 3.5.100.R36x_v20100825-0800 (org.eclipse.team.core 3.5.100.R36x_v20100825-0800)
Team Support Core 3.5.101.R36x_v20110203-1036 (org.eclipse.team.core 3.5.101.R36x_v20110203-1036)
Team Support Core 3.6.0.I20110525-0800 (org.eclipse.team.core 3.6.0.I20110525-0800)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.4.2.20120213-0813 (epp.package.jee 1.4.2.20120213-0813)
To: org.eclipse.epp.package.jee.feature.feature.group [1.4.2.20120213-0813]
Cannot satisfy dependency:
From: Eclipse Git Team Provider 3.0.0.201306101825-r (org.eclipse.egit.feature.group 3.0.0.201306101825-r)
To: org.eclipse.egit.ui [3.0.0.201306101825-r]
Cannot satisfy dependency:
From: Git Team Provider UI 3.0.0.201306101825-r (org.eclipse.egit.ui 3.0.0.201306101825-r)
To: bundle org.eclipse.team.core [3.6.100,4.0.0)
Cannot satisfy dependency:
From: Java EE IDE Feature 1.4.2.20120213-0813 (org.eclipse.epp.package.jee.feature.feature.group 1.4.2.20120213-0813)
To: org.eclipse.platform.feature.group [3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
To: org.eclipse.team.core [3.6.0.I20110525-0800]

Can you help me with solving this problem ?
Thx
Re: Installing EGit from Eclipse Marketplace [message #1067781 is a reply to message #1067773] Wed, 10 July 2013 14:42 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias Sohn
Messages: 588
Registered: July 2009
Senior Member
EGit 3.0 doesn't support Indigo. As a rule of thumb we always at least support
the last two Eclipse releases which is at the moment Juno and Kepler.
See [1] for details.

[1] http://wiki.eclipse.org/EGit/FAQ#What_versions_of_Eclipse_does_EGit_target.3F
Re: Installing EGit from Eclipse Marketplace [message #1068154 is a reply to message #1067781] Fri, 12 July 2013 12:50 Go to previous messageGo to next message
Michal Vitousek is currently offline Michal Vitousek
Messages: 2
Registered: July 2013
Junior Member
Thank you.
I am upgrading to Kepler (older version of EGit for Indigo failed during installation too).
Re: Installing EGit from Eclipse Marketplace [message #1096346 is a reply to message #1067781] Wed, 28 August 2013 09:01 Go to previous messageGo to next message
Michael Mokhov is currently offline Michael Mokhov
Messages: 2
Registered: August 2013
Junior Member
Matthias Sohn wrote on Wed, 10 July 2013 10:42
EGit 3.0 doesn't support Indigo. As a rule of thumb we always at least support
the last two Eclipse releases which is at the moment Juno and Kepler.
See [1] for details.

[1] http://wiki.eclipse.org/EGit/FAQ#What_versions_of_Eclipse_does_EGit_target.3F


Hi! I want to install the EGIT for FlashBuilder 4.5 (Eclipse Platform 3.6.1.r361), but links to other EGIT builds in wiki is wrong (404 Not Found). Where can I find the build for my version of Eclipse?

Thanks in advance!

[Updated on: Sat, 31 August 2013 09:26]

Report message to a moderator

Re: Installing EGit from Eclipse Marketplace [message #1101999 is a reply to message #1096346] Thu, 05 September 2013 07:58 Go to previous messageGo to next message
Michael Mokhov is currently offline Michael Mokhov
Messages: 2
Registered: August 2013
Junior Member
Oh, do not believe your eyes! It is necessary to click on the link "Show Directory Contents."
Re: Installing EGit from Eclipse Marketplace [message #1152124 is a reply to message #1101999] Wed, 23 October 2013 20:47 Go to previous message
Matthias Sohn is currently offline Matthias Sohn
Messages: 588
Registered: July 2009
Senior Member
The URLs given in [1] column "p2 repository" can't be opened from a browser since browser's don't understand p2 repositories Wink
In Eclipse click "Help > Install new software" and copy the p2 repository URL to the field "work with", click return, then the installer
should show the EGit features of the respective version.

[1] http://wiki.eclipse.org/EGit/FAQ#Where_can_I_find_older_releases_of_EGit.3F
Previous Topic:Why my remote branches are not checked out locally??
Next Topic:.gitignore files in plugin bin/ folders when switching target platforms/clean
Goto Forum:
  


Current Time: Fri Oct 24 18:18:20 GMT 2014

Powered by FUDForum. Page generated in 0.03306 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software