Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » QVT-OML » Object type issues(can't resolve objects from type)
Object type issues [message #1067642] Tue, 09 July 2013 18:50 Go to next message
lin zhang is currently offline lin zhangFriend
Messages: 2
Registered: July 2013
Junior Member
I am very new to QVTo, recently I got this very issue:

I created a model with two BranchRecord and one LoadRecord, totally three objects.
log(lsein.objects()->size().toString());
log(lsein.objects()[BranchRecord]->size().toString());
log(lsein.objectsOfType(LoadRecord)->size().toString());

for these three lines of code, I am supposed to get
3
2
1

Instead I got
3
0
0.

Does anyone know why?

Thanks!
Re: Object type issues [message #1067723 is a reply to message #1067642] Wed, 10 July 2013 09:55 Go to previous messageGo to next message
Christopher Gerking is currently offline Christopher GerkingFriend
Messages: 41
Registered: April 2011
Member
What kind of model did you create, is it a dynamic instance?
Re: Object type issues [message #1067827 is a reply to message #1067723] Wed, 10 July 2013 18:05 Go to previous message
lin zhang is currently offline lin zhangFriend
Messages: 2
Registered: July 2013
Junior Member
No, it's not.
And the weird thing is that this issue is gone when I use another version of eclipse, so I guess it's related with eclipse not the code.
Previous Topic:Shortcut for subpackages?
Next Topic:Ideas for higher-order in QVTo
Goto Forum:
  


Current Time: Fri Nov 28 15:57:31 GMT 2014

Powered by FUDForum. Page generated in 0.54123 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software