Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » External Configuration to Chrome executes no php(Cant get PHP working on my website when using External Conf.Tool)
External Configuration to Chrome executes no php [message #1067494] Tue, 09 July 2013 02:06 Go to next message
Pjotr Bee is currently offline Pjotr Bee
Messages: 5
Registered: July 2013
Junior Member
Hi fogs!

I'm trying to get my first eclipse php-program (Zend Eclipse for PHP 3.2.0) running, i am having trouble to configure the External Tools Configuration to get Chrome running correctly.

In Google Chrome the right URL is : http:// localhost / phpsite / index.php
But my external tools configuration produces: ///C: /xampp / htdocs / phpsite / index.php
This seems to be wrong because it skips all php-statements in my code (no includes etc).

Can I change some setting to replace ///C: with localhost ???
Or do I still miss a setting or link to PHP somewhere ???

My settings:

Project file: c:/xampp/htdocs/phpsite/index.php
Workspace: c:/xampp/htdocs/phpsite

External Tools Configuration for Chrome:
* Location: C:\Program Files\Google\Chrome\Application\chrome.exe
* Working Directory: ${workspace_loc:/phpsite}
* Arguments: -url "${workspace_loc}${project_path}/${resource_name}"

Windows/Preferences/PHP/PHP Executables: C:\xampp\php\php.exe
Apache Web Root: C:/xampp/htdocs


Thanks,
PjotrB
Re: External Configuration to Chrome executes no php [message #1067513 is a reply to message #1067494] Tue, 09 July 2013 04:04 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 345
Registered: July 2009
Location: Japan
Senior Member
>* Arguments: -url "${workspace_loc}${project_path}/${resource_name}"
Why did you choose ${workspace_loc}? It's your choice, isn't it? Or is it being generated automatically somehow? What is ${workspace_loc}? You can see its description in 'Select Variables' dialog. Why don't you set Arguments as '-url http://localhost${project_path}/${resource_name}' for example?

(Zend Eclipse for PHP 3.2.0(Zend Eclipse PDT) is a *product* of Zend. The forum is Zend Studio. I don't know whether they will support their free product or not though.)
Re: External Configuration to Chrome executes no php [message #1067574 is a reply to message #1067513] Tue, 09 July 2013 07:58 Go to previous message
Pjotr Bee is currently offline Pjotr Bee
Messages: 5
Registered: July 2013
Junior Member
Off course you're right.
While configuring Eclipse I got lost in the many ways to configure webservers and webbrowsers.
Thanks for helping!!!!!

PjotrB
Previous Topic:External Configuration to Chrome does not work
Next Topic:How to change the color of this secondary popup?
Goto Forum:
  


Current Time: Sun Aug 31 04:45:27 EDT 2014

Powered by FUDForum. Page generated in 0.01685 seconds