Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Kepler: On start up, I no longer get prompted for workspace location
Kepler: On start up, I no longer get prompted for workspace location [message #1067487] Tue, 09 July 2013 00:31 Go to next message
Dan Thurman is currently offline Dan Thurman
Messages: 57
Registered: July 2009
Member
On first time start up, I was prompted to choose the
default workspace location or to enter another workspace
location, so I entered another workspace location, clicked
OK and the IDE was up and running. I note that the new
location data is listed in the workspace location list
in the 'Preferences' menu.

However, when I closed down Eclipse, then later started
Eclipse again, I am no longer prompted with the workspace
location and was taken to the default (home) workspace.

So in order to switch to the desired location, I am now
required to use File->Switch Location...-> (previously
entered location from first time start up) and go through
the start up process again. This is annoying.

Is this a bug or a new feature? Previous releases worked
fine prior to Kepler.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1067665 is a reply to message #1067487] Tue, 09 July 2013 18:20 Go to previous messageGo to next message
Michel Rainville is currently offline Michel Rainville
Messages: 5
Registered: February 2013
Junior Member
In Eclipse Juno,

It's in Preferences,Startup and Shutdown, Workspaces
Check "Prompt for Workspaces on Startup"

(You may have accidentally checked "Make this the default and don't ask again" in the workspace dialog at the start. )

Re: Kepler: On start up, I no longer get prompted for workspace location [message #1068205 is a reply to message #1067665] Fri, 12 July 2013 13:10 Go to previous messageGo to next message
Dan Thurman is currently offline Dan Thurman
Messages: 57
Registered: July 2009
Member
Juno is not a problem, only in Kepler, and
this problem is 100% repeatable on start up,
at least for me.

I tried what you suggested, but on Kepler, and
to no avail.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1069017 is a reply to message #1068205] Sun, 14 July 2013 21:22 Go to previous messageGo to next message
J L is currently offline J L
Messages: 7
Registered: April 2012
Junior Member
I just tried with Kepler and cheking "Prompt for Workspaces on Startup" did work for me.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1188611 is a reply to message #1069017] Fri, 15 November 2013 13:35 Go to previous messageGo to next message
Andrew Wilkinson is currently offline Andrew Wilkinson
Messages: 6
Registered: November 2013
Junior Member
I have the exact same problem as Dan Thurman. I did not check the "make this the default and do not ask again" box. In Preferences -> Startup and Shutdown -> Workspaces, I have "Prompt for workspace on startup" checked. This worked fine in Juno, but is not working in Kepler.

My process was:

1. The first time I used Kepler I was prompted to select a workspace location.
2. I selected a directory for my workspace (I didn't use the default).
3. I shut down eclipse.
4. I started up eclipse.
5. I was not prompted to select a workspace.
6. Eclipse opened the default workspace location ($USER_HOME\workspace). It does this every time I shut down and start up eclipse.

Oddly, the default workspace location is not even listed under File -> Switch Workspace. It is also not listed under Preferences -> General -> Startup and Shutdown -> Workspaces.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1194656 is a reply to message #1067487] Mon, 18 November 2013 11:23 Go to previous messageGo to next message
TenLeftFingers . is currently offline TenLeftFingers .
Messages: 4
Registered: November 2012
Junior Member
I'm having this issue too. This is the file that stores the settings

C:\Users\<username>\eclipse\configuration\.settings\org.eclipse.ui.ide.prefs

as you can see, it correctly has the settings you expect to be there. It's just not being honoured by Eclipse

[Updated on: Mon, 18 November 2013 11:24]

Report message to a moderator

Re: Kepler: On start up, I no longer get prompted for workspace location [message #1198310 is a reply to message #1194656] Wed, 20 November 2013 03:53 Go to previous messageGo to next message
Christian Sterzl is currently offline Christian Sterzl
Messages: 4
Registered: November 2013
Junior Member
I got the same error. The configuration gets not honoured. The workspace dialog is not shown and the default one is chosen.

It happens only with Kepler.

When I start eclipse with the clean parameter, everything works as expected.

I am running eclipse on Mac OS X Mavericks.

Is there a better solution than cleaning up around?
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1216541 is a reply to message #1198310] Thu, 28 November 2013 09:23 Go to previous messageGo to next message
Kurian Abraham Thampy is currently offline Kurian Abraham Thampy
Messages: 2
Registered: November 2013
Junior Member
I have the same problem on Mavericks. It started after I installed EGit, ADT and ADT Translation Manager.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1219627 is a reply to message #1216541] Wed, 04 December 2013 22:21 Go to previous messageGo to next message
Todd Jones is currently offline Todd Jones
Messages: 1
Registered: December 2013
Junior Member
I'm having the same issue. It stopped working after I installed the Oracle Weblogic Tools. Did anyone else install the same set of tools?
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1219719 is a reply to message #1219627] Thu, 05 December 2013 09:51 Go to previous messageGo to next message
Christian Sterzl is currently offline Christian Sterzl
Messages: 4
Registered: November 2013
Junior Member
Yes, I installed the OEPE Tools for Kepler as well. But I did it before and it worked in earlier versions.
I solved my issue by adding the clean option to my eclipse.ini, but that is not a real solution.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1219922 is a reply to message #1067487] Fri, 06 December 2013 13:52 Go to previous messageGo to next message
Andrew Wilkinson is currently offline Andrew Wilkinson
Messages: 6
Registered: November 2013
Junior Member
Yes, I installed the Oracle WebLogic Server Tools and Oracle Coherence Tools plugins. That was one of the first things I did. I don't know if it was working before that.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1220574 is a reply to message #1067487] Thu, 12 December 2013 10:18 Go to previous messageGo to next message
Guillaume Morin is currently offline Guillaume Morin
Messages: 1
Registered: December 2013
Junior Member
I have exactly the same problem on Kepler and I did install the Oracle Weblogic Tools.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1221031 is a reply to message #1220574] Mon, 16 December 2013 13:31 Go to previous messageGo to next message
Todd Bradley is currently offline Todd Bradley
Messages: 4
Registered: December 2013
Location: Colorado
Junior Member

Same problem here. I would've never guessed it was due to the Oracle WebLogic tools, but I also have those installed and also have this problem with Eclipse using the wrong workspace every time it starts. And like the others who posted before me, the usual methods for resetting the initial workspace are ignored.

Has anyone filed this as a bug with Oracle?
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1221067 is a reply to message #1221031] Mon, 16 December 2013 15:13 Go to previous messageGo to next message
Christian Sterzl is currently offline Christian Sterzl
Messages: 4
Registered: November 2013
Junior Member
I don't think anybody has as of now. Who will?
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1221087 is a reply to message #1221067] Mon, 16 December 2013 16:40 Go to previous messageGo to next message
Todd Bradley is currently offline Todd Bradley
Messages: 4
Registered: December 2013
Location: Colorado
Junior Member

I don't know how, but I did add a note to Oracle's discussion forum about this. However, because I'm a new user on the eclipse.org forum, I'm not allowed to include the link here.

Here is the URL in uuencoded format. Find a web uudecode page to turn this back into a URL. (not including the begin and end lines, just in case you're new to uuencoding)

begin 644 webutils_pl
J:'1T<',Z+R]F;W)U;7,N;W)A8VQE+F-O;2]M97-S86=E+S$Q,S`T,S<Y
`
end

[Updated on: Mon, 16 December 2013 16:41]

Report message to a moderator

Re: Kepler: On start up, I no longer get prompted for workspace location [message #1221187 is a reply to message #1221087] Mon, 16 December 2013 23:25 Go to previous messageGo to next message
Kurian Abraham Thampy is currently offline Kurian Abraham Thampy
Messages: 2
Registered: November 2013
Junior Member
You could have simply left out the http:// ...
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1221435 is a reply to message #1221187] Tue, 17 December 2013 12:46 Go to previous messageGo to next message
Todd Bradley is currently offline Todd Bradley
Messages: 4
Registered: December 2013
Location: Colorado
Junior Member

Kurian Abraham Thampy wrote on Mon, 16 December 2013 21:25
You could have simply left out the http:// ...


Ha ha. Good to know. Well, uuencoded doesn't get nearly enough love these days.

On a tangent, why would you make a rule that new users can't post valid URLs, but then not make that same rule block nearly-valid URLs like ones that are just missing http://? Sounds pretty half-assed to me. Smile
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1221436 is a reply to message #1221435] Tue, 17 December 2013 12:47 Go to previous messageGo to next message
Todd Bradley is currently offline Todd Bradley
Messages: 4
Registered: December 2013
Location: Colorado
Junior Member

Oh, I also wanted to ask the other people who ran into this problem: Are you all using Windows, or a variety of OSes?
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1222165 is a reply to message #1221436] Thu, 19 December 2013 15:12 Go to previous messageGo to next message
Andrew Wilkinson is currently offline Andrew Wilkinson
Messages: 6
Registered: November 2013
Junior Member
I have this problem and I am running Windows 7.

I think the rule against URLs is to cut down on spamming/phishing. There's a java forum that I have used many times. Someone used a spam bot to put the same message and link on every conversation thread. It was rather irritating. If links had been prevented, I doubt that they would have bothered to put the spam message up.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1222166 is a reply to message #1222165] Thu, 19 December 2013 15:15 Go to previous messageGo to next message
Christian Sterzl is currently offline Christian Sterzl
Messages: 4
Registered: November 2013
Junior Member
Have it on Mac OS X 10.9
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1229953 is a reply to message #1222166] Fri, 10 January 2014 11:35 Go to previous messageGo to next message
Clement Viswanathan is currently offline Clement Viswanathan
Messages: 2
Registered: January 2014
Junior Member
I had the same problem with eclipse kepler in Windows 7. Here is what I did to solve the problem.

Click on Windows --> Preferences --> Search for Workspace --> Check "Prompt for workspace on startup" --> Click Apply ---> Click OK ---> Then File ---> Switch Workspace --> Choose your default Workspace --> Now restart eclipse.

You should be good.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1230060 is a reply to message #1229953] Fri, 10 January 2014 17:15 Go to previous messageGo to next message
Andrew Wilkinson is currently offline Andrew Wilkinson
Messages: 6
Registered: November 2013
Junior Member
Clement, that solution doesn't work for me. The "Prompt for workspace on startup" box is already checked. That is the default. My guess is that you must have clicked the "Use this as the default and do not ask again" box when prompted to select a workspace. Checking this box unchecks the other one.

If it is working for you I would also guess that you don't have Oracle Weblogic Tools plugin installed. That seems to be causing the problem.
icon3.gif  Re: Kepler: On start up, I no longer get prompted for workspace location [message #1231701 is a reply to message #1067487] Wed, 15 January 2014 03:22 Go to previous messageGo to next message
Michael Niedermaier is currently offline Michael Niedermaier
Messages: 2
Registered: December 2012
Junior Member
try to use the -clean. Worked for me.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1232334 is a reply to message #1231701] Thu, 16 January 2014 13:05 Go to previous messageGo to next message
Andrew Wilkinson is currently offline Andrew Wilkinson
Messages: 6
Registered: November 2013
Junior Member
I've been using the -clean startup parameter. It works. It just makes startup very slow.
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1234247 is a reply to message #1232334] Tue, 21 January 2014 09:35 Go to previous messageGo to next message
Magnus Skoglund is currently offline Magnus Skoglund
Messages: 1
Registered: January 2014
Junior Member
this issue might be involved: bugs.eclipse.org/bugs/show_bug.cgi?id=409552
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1234587 is a reply to message #1234247] Wed, 22 January 2014 05:14 Go to previous messageGo to next message
Dariusz Dziadek is currently offline Dariusz Dziadek
Messages: 1
Registered: January 2014
Location: Poland
Junior Member
I also "had" this problem after installing OEPE Tools (only Database Tools and WebLogic Tools) and/or WindowBuilder Pro for Kepler.
In OEPE, Database Tools module causes this issue (if only WebLogic Tools is installed it works fine).

It seems that problem depends (somehow, I didn't investigate in details and deeper) on OSGI Runtime configuration.
Anyway, if you look into ${ECLIPSE_HOME}/configuration/config.ini file you will find default entry:

osgi.instance.area.default=@user.home/workspace

As you can see it points to workspace in user home folder.
You can change this entry to point your target workspace, e.g.:

osgi.instance.area.default=D\:/KeplerWorkspace

It works fine for me.

More information you can find at:
http://help.eclipse.org/kepler/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Freference%2Fmisc%2Fruntime-options.html
Re: Kepler: On start up, I no longer get prompted for workspace location [message #1244743 is a reply to message #1234587] Wed, 12 February 2014 15:40 Go to previous message
Andrew Wilkinson is currently offline Andrew Wilkinson
Messages: 6
Registered: November 2013
Junior Member
The link to the eclipse bug that Magnus Skoglund posted has the best workaround:

eclipse -data <workspace>

I use multiple workspaces, so I created a shortcut for each workspace and modified the Target.
Previous Topic:Consistent installations
Next Topic:JFace TextCellEditor fires events twice...
Goto Forum:
  


Current Time: Sat Aug 02 00:37:12 EDT 2014

Powered by FUDForum. Page generated in 0.03065 seconds