Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Admin Virgo Console(Missing Browse/Update on Artifacts panel)
Admin Virgo Console [message #1067405] Mon, 08 July 2013 14:26 Go to next message
jesse henson is currently offline jesse henson
Messages: 3
Registered: July 2013
Junior Member
Thanks in advance to anyone who can help.
I'm fairly Eclipse proficient and running VTS on Win 7 for the first time.
BUT... the "Artifacts" page of my admin console does not match the documentation.
I'm logged in as "admin (pw=springsource)"
There is no Browse/Upload bundle option... see attached...

I've performed "Check for Updates", read the user/program/tooling guides, Googled and browsed this forum, ...
Am I missing configuration info? Bundle(s)? etc...?

I have to say, there appears to be a big gap between the online documentation for using Virgo and the realities of getting started for the first time.
I have yet to set up a working sample of a Virgo app (like greenpages).
(some luck with RAP and Jetty, but that's not where I want to be).
Thanks again
-jesse
Re: Admin Virgo Console [message #1067418 is a reply to message #1067405] Mon, 08 July 2013 14:49 Go to previous messageGo to next message
Mihael Schmidt is currently offline Mihael Schmidt
Messages: 25
Registered: August 2010
Junior Member
There are at least three ways of installing bundles.


  • pickup directory
  • repository (f. e. usr)
  • web interface


To install a bundle via the web interface go to the "Artifacts" tab and click on the "Deployer" button. The rest should be easy to follow.

Browse bundle: Click on the bundle tree node. This will show all installed bundles.

Re: Admin Virgo Console [message #1067420 is a reply to message #1067418] Mon, 08 July 2013 14:54 Go to previous messageGo to next message
Florian Waibel is currently offline Florian Waibel
Messages: 94
Registered: June 2010
Member
Clicking the Deployer button will reveal what you are looking for:
index.php/fa/15516/0/

[Updated on: Mon, 08 July 2013 14:57]

Report message to a moderator

Re: Admin Virgo Console [message #1067421 is a reply to message #1067405] Mon, 08 July 2013 14:56 Go to previous message
Chris Frost is currently offline Chris Frost
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

You got it, use the + button to deploy multiple artifacts in the order specified.

------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Previous Topic:HTTP Service - Missing JARs?
Next Topic:Uses violtion with cxf-dosgi 1.4 in virgo 3.6
Goto Forum:
  


Current Time: Tue Sep 02 21:32:18 GMT 2014

Powered by FUDForum. Page generated in 0.01698 seconds