Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » extend jubula(Problem with extend swt apps)
extend jubula [message #1067296] Mon, 08 July 2013 08:46 Go to next message
Rodrigo Revuelta Roca is currently offline Rodrigo Revuelta RocaFriend
Messages: 12
Registered: January 2012
Junior Member
Hi,

I'm trying to extend a simple swt application to test a canvas. I'm following the steps on the extend manual but i have an error when i try to launch my application (5009:Aut Start failed). If I uninstall the rc and toolkit plug-in from the ite I can start my application from jubula.

I have the same error following the example in swing app (from the extend manual), when i try to start my app i have the 5009 error, however it works perfectly extending an rcp application.

I don't have any error on the logs.

Anyone have the same error?
Re: extend jubula [message #1067298 is a reply to message #1067296] Mon, 08 July 2013 08:50 Go to previous messageGo to next message
Achim Loerke is currently offline Achim LoerkeFriend
Messages: 357
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

Which version of Jubula are you using (version number, standalone or feature, Eclipse for Testers)? There have been major changes in the extension (non-)API in the last few month.

- Achim
Re: extend jubula [message #1067311 is a reply to message #1067296] Mon, 08 July 2013 09:35 Go to previous messageGo to next message
Rodrigo Revuelta Roca is currently offline Rodrigo Revuelta RocaFriend
Messages: 12
Registered: January 2012
Junior Member
Jubula_7.1.00054

I'm using eclipse kepler rcp (Build id: 20130614-0229) to import and develop the plug-ins.

I'm following this version of the extend manual
Functional Testing Extension
Manual
BREDEX GmbH
June 17, 2013
Re: extend jubula [message #1067313 is a reply to message #1067311] Mon, 08 July 2013 09:36 Go to previous messageGo to next message
Rodrigo Revuelta Roca is currently offline Rodrigo Revuelta RocaFriend
Messages: 12
Registered: January 2012
Junior Member
i'm using the standalone jubula
Re: extend jubula [message #1067512 is a reply to message #1067313] Tue, 09 July 2013 08:02 Go to previous messageGo to next message
Rodrigo Revuelta Roca is currently offline Rodrigo Revuelta RocaFriend
Messages: 12
Registered: January 2012
Junior Member
My problem is with the rc fragment. If i install only the toolkit the application works fine and the object mapping mode recognize my new component (a canvas). However, when i install the rc fragment in the ite i can't start my application (error 5009). I can't see any problem in the logs.
Re: extend jubula [message #1070238 is a reply to message #1067512] Wed, 17 July 2013 14:21 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1193
Registered: July 2009
Senior Member
Hi,

The jubula-dev and jubula-rc-dev mailing list archives have some threads within them that have dealt with extensions. It might be worth having a look there. If those threads don't help, it would be great if you could repost the question to the jubula-rc-dev mailing list.

Thanks!
Alex
Previous Topic:Reusable project and object mapping
Next Topic:Jubula doesn´t recognize running AUT after upgrade to 2.0
Goto Forum:
  


Current Time: Sun Dec 21 15:57:09 GMT 2014

Powered by FUDForum. Page generated in 0.01756 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software