Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Tycho build with RAP 2.1
Tycho build with RAP 2.1 [message #1066963] Fri, 05 July 2013 09:07 Go to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hello everyone,

I try to build my RAP application with tycho and I get an error:
"Missing Constraint: Import-Package: javax.servlet;"

I have a target platform definition which uses local software site (update site) to fetch bundles. javax.servlet (3.0.0) is in the target platform. I use your example from here: https://github.com/eclipsesource/tabris-demos to configure poms. If I build my projects with maven I get get following errors:

NOT RESOLVED org.eclipse.rap.ui_2.1.0.20130604-1251 : C:\Users\d.huber\.m2\repository\p2\osgi\bundle\org.eclipse.rap.ui\2.1.0.20130604-1251\org.eclipse.rap.ui-2.1.0.20130604-1251.jar
Missing Constraint: Import-Package: javax.servlet.http; version="2.3.0"

[ERROR] Internal error: java.lang.RuntimeException: org.osgi.framework.BundleException: Bundle MyProject cannot be resolved
[ERROR] Resolution errors:
[ERROR] Bundle MyProject- Missing Constraint: Import-Package: javax.servlet; version="0.0.0"
[ERROR] Bundle MyProject- Missing Constraint: Import-Package: javax.servlet.http; version="0.0.0"

Have you any idea what it can be? I build with RAP 2.1.0 and maven 3.0.5 an tycho 0.17

Best regards,
Daria

Re: Tycho build with RAP 2.1 [message #1067139 is a reply to message #1066963] Sat, 06 July 2013 09:36 Go to previous messageGo to next message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 113
Registered: July 2009
Senior Member

Hi Daria,

I don't know the reason of your problem but usually it is connected with the org.eclipse.equinox.servletbridge.extensionbundle bundle - see bug 348045 [1] for further information about changes in Kepler in that area.

Speaking of changes... your tabris example that you mentioned seems a bit old. I'm not aware of any particular problems with this build, but on the other hand I cannot guarantee that it is still working. Maybe it helps to look closer into our build of the RAP examples. They are in our RAP Runtime Git repository [2] in the releng/org.eclipse.rap.examples.build subdirectory [3].

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=348045
[2] http://git.eclipse.org/c/rap/org.eclipse.rap.git/
[3] http://git.eclipse.org/c/rap/org.eclipse.rap.git/tree/releng/org.eclipse.rap.examples.build

Regards,
Markus


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Tycho build with RAP 2.1 [message #1067532 is a reply to message #1067139] Tue, 09 July 2013 09:03 Go to previous messageGo to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hi Markus,

thanks for your reply.
Tycho build for RAP 2.1 is a bit differently to RAP 2.0. So I changed my build just like in your example from releng.
But it doesn't work.
I get:
Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:0.18.0:compile (default-compile) on project MyProject: Compilation failure: Compilation failure:
Access restriction: The type ServletException is not accessible due to restriction on classpath entry...

My application bundles has project.build/parent/pom.xml as parent pom. And only feature and product has a top parent as parent pom. Also I added my bundles to project.build/pom.xml as modules.

Is it still a bug like 348045 or my problem is between keypad and a chair? Smile

Thanks in advance
Re: Tycho build with RAP 2.1 [message #1067882 is a reply to message #1067532] Thu, 11 July 2013 05:35 Go to previous messageGo to next message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 113
Registered: July 2009
Senior Member

Obviously there's still something wrong but the error message doesn't tell me the real reason. "ServletException is not accessible due to restriction on classpath entry...". I'm puzzled.

E.g. in our workbench example, we are using javax.servlet_3.0.0.v201112011016.jar and org.eclipse.rap.ui_2.1.0.20130604-1251.jar in our .war file and the build (and the application) run successfully.

How can we proceed? If MyProject is just one example standalone project and does not include any secret information nor code it may help to attach this project to this newsgroup thread.

Regards, Markus


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Tycho build with RAP 2.1 [message #1067909 is a reply to message #1067882] Thu, 11 July 2013 08:30 Go to previous messageGo to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hi Markus,

I figured out what the problem is. Thanks for your help.
Version in MANIFEST for javax.servlet caused this curious exception. I deleted all versions in Manifest under dependecies and I could build war archive for my application. But I think it is not a proper way. I think I have to specify what versions of bundles I want to build with.
I tried to deploy my war archive on a tomcat. But it fails. Bundle org.eclipse.persistence.jpa.osgi is missing some dependecies:

org.eclipse.persistence.jpa.osgi
osgi> diag 69
reference:file:plugins/org.eclipse.persistence.jpa.osgi_2.4.1.v20121003-ad44345.jar [268]
Direct constraints which are unresolved:
Missing imported package javax.persistence_[1.1.0,2.2.0).
Missing imported package javax.persistence.criteria_[1.1.0,2.2.0).
Missing imported package javax.persistence.metamodel_[1.1.0,2.2.0).
Missing imported package javax.persistence.spi_[1.1.0,2.2.0).

I found this https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&id=407730. Is my target platform not complete? But javax.persistence is contained and I see it under osgi console.
What is a proper way to manage my target platform bundles?


  • Maven Central repository
  • Target definition with links to p2 repositories
  • Nexus


I would like to have our target platform in our local company network. But solution with a target definition file with p2 repositories is not very reliable. Some bundles like axis2 or eclipelink 2.4.1 are not available with p2. What is the best way to share the same target platform configuration between Tycho and Eclipse?

Thanks in advance
Re: Tycho build with RAP 2.1 [message #1068160 is a reply to message #1067909] Fri, 12 July 2013 13:11 Go to previous messageGo to next message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 113
Registered: July 2009
Senior Member

Hi Daria,

great, it seems to work! Maybe part of the problem is the different versioning between OSGi bundle and Java packages in javax.servlet. The bundle has version 3.0.0, whereas the Java packages are exported as 2.6.0.

Then... I see you are familiar with the OSGi console and how to use it on a server. It's the same way of debugging that I would do: Find out which missing dependencies are causing the errors in the dependency chain. It's very likely another bundle that is missing or another incarnation of bug 407730.

Managing target bundles? There are at least as many ways to do this as there are different requirements. I'm usually using the upstream p2 repositories at eclipse.org if possible. If that's not possible (which is sometimes the case behind company firewalls), I am mirroring these p2 repositories to a local location, or I am using a Nexus server as a "p2 proxy". In all cases, I'm adding the remote p2 repositories as a repository with p2 layout to my pom's.

Maven Central is in most cases not suitable. Why? Because most Eclipse projects do not publish their artifacts there.

Regards, Markus


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Tycho build with RAP 2.1 [message #1069610 is a reply to message #1068160] Tue, 16 July 2013 08:33 Go to previous messageGo to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hi Markus,

Sorry, but I have still a problem with javax.servlet. I tried to build a very simple project with your example from releng. But my war doesn't work. Here is osgi console:

id State Bundle
0 ACTIVE org.eclipse.osgi_3.9.0.v20130529-1710
1 ACTIVE org.eclipse.equinox.simpleconfigurator_1.0.400.v20130327-211
9
2 INSTALLED com.pt.rwt_1.0.0.20130716-0755
3 STARTING com.ibm.icu.base_50.1.1.v201304230130
4 ACTIVE org.apache.felix.gogo.command_0.10.0.v201209301215
5 ACTIVE org.apache.felix.gogo.runtime_0.10.0.v201209301036
6 ACTIVE org.apache.felix.gogo.shell_0.10.0.v201212101605
7 RESOLVED org.eclipse.core.commands_3.6.100.v20130515-1857
8 STARTING org.eclipse.core.contenttype_3.4.200.v20130326-1255
9 STARTING org.eclipse.core.databinding_1.4.1.v20130515-1857
10 RESOLVED org.eclipse.core.databinding.beans_1.2.200.v20130515-1857
11 STARTING org.eclipse.core.databinding.observable_1.4.1.v20130515-1857

12 STARTING org.eclipse.core.databinding.property_1.4.200.v20130515-1857

13 STARTING org.eclipse.core.expressions_3.4.500.v20130515-1343
14 STARTING org.eclipse.core.jobs_3.5.300.v20130429-1813
15 STARTING org.eclipse.core.runtime_3.9.0.v20130326-1255
16 STARTING org.eclipse.equinox.app_1.3.100.v20130327-1442
17 ACTIVE org.eclipse.equinox.common_3.6.200.v20130402-1505
18 ACTIVE org.eclipse.equinox.console_1.0.100.v20130429-0953
19 ACTIVE org.eclipse.equinox.ds_1.4.100.v20130515-2026
20 INSTALLED org.eclipse.equinox.http.registry_1.1.300.v20130402-1529
21 INSTALLED org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354
22 INSTALLED org.eclipse.equinox.http.servletbridge_1.0.300.v20130327-144
2
23 STARTING org.eclipse.equinox.preferences_3.5.100.v20130422-1538
24 STARTING org.eclipse.equinox.registry_3.5.300.v20130327-1442
25 INSTALLED org.eclipse.equinox.servletbridge_1.2.300.v20130508-1243
26 ACTIVE org.eclipse.equinox.util_1.0.500.v20130404-1337
27 ACTIVE org.eclipse.osgi.services_3.3.100.v20130513-1956
28 INSTALLED org.eclipse.rap.jface_2.1.0.20130506-1748
29 INSTALLED org.eclipse.rap.jface.databinding_2.1.0.20130506-1748
30 INSTALLED org.eclipse.rap.rwt_2.1.0.20130611-2139
31 INSTALLED org.eclipse.rap.rwt.osgi_2.1.0.20130506-1748
osgi> diag 20
reference:file:plugins/org.eclipse.equinox.http.registry_1.1.300.v20130402-1529.
jar
Direct constraints which are unresolved:
Missing imported package javax.servlet_2.3.0.
Missing imported package javax.servlet.http_2.3.0.
Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.e
e=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
osgi> diag 21
reference:file:plugins/org.eclipse.equinox.http.servlet_1.1.400.v20130418-1354.j
ar [21]
Direct constraints which are unresolved:
Missing imported package javax.servlet_[2.3.0,3.1.0).
Missing optionally imported package javax.servlet.annotation_2.6.0.
Missing optionally imported package javax.servlet.descriptor_2.6.0.
Missing imported package javax.servlet.http_[2.3.0,3.1.0).
Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.e
e=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".

I do not understand what is wrong. My war is deployed on Tomcat 6.0. And I would say tomcat has servlet-api.jar with correct version. Have I forgot any bundle?

Thanks in advance
Daria
Re: Tycho build with RAP 2.1 [message #1070137 is a reply to message #1068160] Wed, 17 July 2013 09:56 Go to previous messageGo to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hallo everyone,

I have still problem to run WAR on tomcat. I attached my projects. Maybe it helps to figure out what is the problem.
My p2 repository <rap-repository> is only a mirror of RAP p2 repository and <others-repository> contains only "simpleconfigurator" bundle.

I have no idea what is wrong. I would be grateful if anyone can help me. All poms are configurated like Markus's example under releng.

Thanks in advance,
Daria
  • Attachment: apollo13.zip
    (Size: 90.94KB, Downloaded 43 times)
Re: Tycho build with RAP 2.1 [message #1071044 is a reply to message #1067909] Fri, 19 July 2013 08:16 Go to previous messageGo to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hallo everyone,

I suppose the whole RAP team is on holiday. But if somebody is there and can help me I will be very glad!

I tried a very basic maven build with demos from git. Steps to reproduce:

1. Clone git repository: http://git.eclipse.org/gitroot/rap/incubator/org.eclipse.rap.incubator.releng.git and import projects.
2. go to .../org.eclipse.rap/releng/org.eclipse.rap.examples.build/ and execute "maven clean install"
3. copy worbenchdemo from /org.eclipse.rap/releng/org.eclipse.rap.examples.build/workbenchdemo/product/target to Tomcat 6.0 webbapps directory
4. turn osgi console in web.xml on
5. start tomcat
6. Exception!!!
org.osgi.framework.BundleException: The bundle "org.eclipse.rap.rwt.osgi_2.2.0.2
0130702-1310 [36]" could not be resolved. Reason: Missing Constraint: Import-Pac
kage: javax.servlet; version="[2.5.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverEr
ror(AbstractBundle.java:1332)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolution
FailureException(AbstractBundle.java:1316)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(Bundl
eHost.java:323)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(Abstra
ctBundle.java:390)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Frame
work.java:1176)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.setBundleS
L(StartLevelManager.java:670)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEv
ent(StartLevelManager.java:435)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEv
ent(StartLevelManager.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventM
anager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(Even
tManager.java:340)

I suppose it's my mistake.

Thanks in advance

Daria
Re: Tycho build with RAP 2.1 [message #1072701 is a reply to message #1071044] Tue, 23 July 2013 10:14 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 1872
Registered: July 2009
Senior Member
Hi Daria,
which exact Tomcat version are you using? I've tested our demos with
latest 6 ( 6.0.37 ) and 7 ( 7.0.42 ) versions on Windows and it's
working fine. I observed the same problem like you with Tomcat 5.5.35
(exported demos with WAR Product against RAP master). Could you try
Tomcat 6.0.37 or 7.0.42?
Best,
Ivan

On 7/19/2013 11:16 AM, Daria Huber wrote:
> Hallo everyone,
>
> I suppose the whole RAP team is on holiday. But if somebody is there
> and can help me I will be very glad!
>
> I tried a very basic maven build with demos from git. Steps to reproduce:
>
> 1. Clone git repository:
> http://git.eclipse.org/gitroot/rap/incubator/org.eclipse.rap.incubator.releng.git
> and import projects.
> 2. go to .../org.eclipse.rap/releng/org.eclipse.rap.examples.build/
> and execute "maven clean install"
> 3. copy worbenchdemo from
> /org.eclipse.rap/releng/org.eclipse.rap.examples.build/workbenchdemo/product/target
> to Tomcat 6.0 webbapps directory
> 4. turn osgi console in web.xml on
> 5. start tomcat
> 6. Exception!!!
> org.osgi.framework.BundleException: The bundle
> "org.eclipse.rap.rwt.osgi_2.2.0.2
> 0130702-1310 [36]" could not be resolved. Reason: Missing Constraint:
> Import-Pac
> kage: javax.servlet; version="[2.5.0,4.0.0)"
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverEr
> ror(AbstractBundle.java:1332)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolution
> FailureException(AbstractBundle.java:1316)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(Bundl
> eHost.java:323)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(Abstra
> ctBundle.java:390)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Frame
> work.java:1176)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.setBundleS
> L(StartLevelManager.java:670)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEv
> ent(StartLevelManager.java:435)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEv
> ent(StartLevelManager.java:1)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventM
> anager.java:230)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(Even
> tManager.java:340)
>
> I suppose it's my mistake.
>
> Thanks in advance
>
> Daria
>

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Tycho build with RAP 2.1 [message #1072736 is a reply to message #1072701] Tue, 23 July 2013 11:58 Go to previous messageGo to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hallo Ivan,

I have Tomcat 6.0.35. My colleague have the same version and gets also "missing javax.servlet" exception. Under Tomcat 7.0.39 is the same behaviour.

It's very strange.

Regards,
Daria
Re: Tycho build with RAP 2.1 [message #1072780 is a reply to message #1072736] Tue, 23 July 2013 13:26 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 1872
Registered: July 2009
Senior Member
Hi Daria,
I've run the maven build locally in
org.eclipse.rap.examples.buildproject and I can reproduce the same
problem as you. I found that in the config.ini (located in
"apache-tomcat-7.0.39\work\Catalina\localhost\workbenchdemo\eclipse\configuration")
the "osgi.framework.extensions=" is empty. For now the reason is unknown
for me (I'll check it with Markus tomorrow). Please change the
config.ini as follows:
----------------
#This configuration file was written by:
org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Tue Jul 23 15:20:46 EEST 2013
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.400.v20130327-2119.jar@1\:start
equinox.use.ds=true
osgi.bundles.defaultStartLevel=4
osgi.framework=file\:plugins/org.eclipse.osgi_3.9.0.v20130529-1710.jar
/osgi.framework.extensions=reference\:file\:org.eclipse.equinox.servletbridge.extensionbundle_1.3.0.jar/
eclipse.p2.data.area=@config.dir/../p2
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.p2.profile=DefaultProfile
-----------------
After adding the
"org.eclipse.equinox.servletbridge.extensionbundle_1.3.0.jar" to
"osgi.framework.extensions" everything is working fine for me.
HTH,
Ivan

On 7/23/2013 2:58 PM, Daria Huber wrote:
> Hallo Ivan,
>
> I have Tomcat 6.0.35. My colleague have the same version and gets also
> "missing javax.servlet" exception. Under Tomcat 7.0.39 is the same
> behaviour.
>
> It's very strange.
>
> Regards,
> Daria

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Tycho build with RAP 2.1 [message #1073145 is a reply to message #1072780] Wed, 24 July 2013 08:07 Go to previous messageGo to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hallo Ivan,

it works!
We tried to start workbenchdemo with your changes on "apache-tomcat-7.0.39\work\Catalina\localhost\workbenchdemo\eclipse\configuration\config.ini", but it didn't work.

So we changed config.ini in workbenchdemo.war:

#This configuration file was written by:
#org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Tue Jul 23 15:20:46 EEST 2013
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.400.v20130327-2119.jar@1\:start
equinox.use.ds=true
osgi.bundles.defaultStartLevel=4
osgi.framework=file\:plugins/org.eclipse.osgi_3.9.0.v20130529-1710.jar
osgi.framework.extensions=reference\:file\:org.eclipse.equinox.servletbridge.extensionbundle_1.3.0.jar/
eclipse.p2.data.area=@config.dir/../p2
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.p2.profile=DefaultProfile

and deployed again. And now it works in Tomcat 6.0 too!

Is config.ini generated by simpleconfigurator bundle? It would be nice if war file would work out of the box.

Thanks a lot
Daria
Re: Tycho build with RAP 2.1 [message #1073241 is a reply to message #1073145] Wed, 24 July 2013 11:28 Go to previous messageGo to next message
Daria Huber is currently offline Daria HuberFriend
Messages: 14
Registered: June 2013
Junior Member
Hallo everybody,

I tried to find automatic way to generate proper config.ini. So I added some lines to product pom.xml to replace "osgi.framework.extensions=" by "osgi.framework.extensions=reference\:file\:org.eclipse.equinox.servletbridge.extensionbundle_1.3.0.jar/"

My pom.xml under /workbenchdemo/product looks like...
....
<plugin>
<groupId>com.google.code.maven-replacer-plugin</groupId>
<artifactId>maven-replacer-plugin</artifactId>
<version>${replacer-version}</version>
<executions>
<execution>
<id>regex</id>
<phase>verify</phase>
<goals>
<goal>replace</goal>
</goals>
<configuration>
<file>target/products/${project.artifactId}/win32/win32/x86/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info</file>
<token>javax\.servlet.*false|org\.hamcrest.*false|org\.junit.*false</token>
<regexFlags>
<regexFlag>CASE_INSENSITIVE</regexFlag>
<regexFlag>UNIX_LINES</regexFlag>
</regexFlags>
</configuration>
</execution>
<execution>
<id>non-regex</id>
<phase>verify</phase>
<goals>
<goal>replace</goal>
</goals>
<configuration>
<file>target/products/${project.artifactId}/win32/win32/x86/configuration/config.ini</file>
<token>osgi.framework.extensions=</token>
<value>osgi.framework.extensions=reference\:file\:org.eclipse.equinox.servletbridge.extensionbundle_1.3.0.jar/</value>
<regex>false</regex>
<quiet>false</quiet>
</configuration>
</execution>
</executions>
</plugin>
....

It's only a workaround but I think it's ok....

Thanks for all

Daria
icon4.gif  Re: Tycho build with RAP 2.1 [message #1201322 is a reply to message #1071044] Thu, 21 November 2013 17:40 Go to previous message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 113
Registered: July 2009
Senior Member

UPDATE: In our master branch of our RAP Runtime Git repository [1] I made some changes to the Examples build. Thiese changes will go into RAP 2.2 (RC1).

One of the changes removes the simpleconfigurator, the other changes updates the config.ini with the required extensionbundle. With these changes the created .war files are working out of the box in my local Tomcat.

[1] http://git.eclipse.org/c/rap/org.eclipse.rap.git/
[2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=421863


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:Bug with fix contributed hasn't made it into code base in two years
Next Topic:About dialog
Goto Forum:
  


Current Time: Sun Dec 21 06:27:27 GMT 2014

Powered by FUDForum. Page generated in 0.03249 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software