Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Uses violtion with cxf-dosgi 1.4 in virgo 3.6(Uses violtion with cxf-dosgi 1.4 in virgo 3.6)
Uses violtion with cxf-dosgi 1.4 in virgo 3.6 [message #1066933] Fri, 05 July 2013 08:14 Go to next message
Jay Huang is currently offline Jay Huang
Messages: 20
Registered: February 2012
Junior Member
Hi,

I am using virgo 3.6 and trying to use apache cxf distributed osgi. I downloaded 'cxf-dosgi-ri-singlebundle-distribution-1.4.0', and put in repository/usr,
on startup, it throws uses violation error:

Resolver report:
An Import-Package could not be resolved. Resolver error data <Import-Package: javax.servlet; version="0.0.0">. Caused by missing constraint in bundle <com.javcly.jms.activemq_1.0.0>
constraint: <Import-Package: javax.servlet; version="0.0.0"> constrained to bundle <cxf-dosgi-ri-singlebundle-distribution> constrained bundle version range "[1.4.0,1.4.0]"
Uses violation: <Import-Package: javax.servlet; version="[2.3.0,4.0.0)"> in bundle <cxf-dosgi-ri-singlebundle-distribution_1.4.0[1373011492980]>
Found conflicts:
package 'javax.servlet.descriptor_2.6.0' in bundle 'javax.servlet_3.0.0.v201112011016[109]' used by 'javax.servlet_2.6.0' in bundle 'javax.servlet_3.0.0.v201112011016[109]'
conflicts with 'javax.servlet.descriptor_2.5.0' in bundle 'cxf-dosgi-ri-singlebundle-distribution_1.4.0[1373011492980]'
package 'javax.servlet.annotation_2.6.0' in bundle 'javax.servlet_3.0.0.v201112011016[109]' used by 'javax.servlet_2.6.0' in bundle 'javax.servlet_3.0.0.v201112011016[109]'
conflicts with 'javax.servlet.annotation_2.5.0' in bundle 'cxf-dosgi-ri-singlebundle-distribution_1.4.0[1373011492980]'


Then I extract the cxf-dosgi jar and open the MANIFEST.MF, change the 'uses' parts of javax.servlet.* to version 2.6.0, rejar it and replace the old one.

This time it throws an import constraint error:
Resolver report:
An Import-Package could not be resolved. Resolver error data <Import-Package: org.osgi.service.log; version="0.0.0">. Caused by missing constraint in bundle <com.javcly.jms.activemq_1.0.0>
constraint: <Import-Package: org.osgi.service.log; version="0.0.0"> constrained to bundle <cxf-dosgi-ri-singlebundle-distribution> constrained bundle version range "[1.4.0,1.4.0]"

It seems dropping the cxf jar into virgo does not 'just work', am I using a wrong version of cxf-dosgi? Has anyone successfully get cxf-dosgi 1.4 working with virgo 3.6?
Thanks.

Jay
Re: Uses violtion with cxf-dosgi 1.4 in virgo 3.6 [message #1067435 is a reply to message #1066933] Mon, 08 July 2013 16:33 Go to previous message
Mdu Mising name is currently offline Mdu Mising name
Messages: 22
Registered: October 2009
Junior Member
We are using 1.4.0 multiple bundle with a custom plan to order dosgi artifacts.

plan sample:

<?xml version="1.0" encoding="UTF-8"?>
<plan name="cxf-dosgi-ri-discovery-distributed-plan" version="1.4.0" scoped="false" atomic="false"
        xmlns="http://www.eclipse.org/virgo/schema/plan"
		xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
		xsi:schemaLocation="
		        http://www.eclipse.org/virgo/schema/plan 
		        http://www.eclipse.org/virgo/schema/plan/eclipse-virgo-plan.xsd">   
	<artifact type="bundle" name="org.apache.geronimo.specs.geronimo-osgi-registry" version="1.1"/> 
	<artifact type="bundle" name="org.apache.geronimo.specs.geronimo-annotation_1.0_spec" version="1.1.1"/>
	<artifact type="bundle" name="org.apache.servicemix.specs.activation-api-1.1" version="2.2.0"/>
	<artifact type="bundle" name="org.apache.geronimo.specs.geronimo-jpa_2.0_spec" version="1.1"/>
	<artifact type="bundle" name="org.apache.geronimo.specs.geronimo-javamail_1.4_spec" version="1.7.1"/>	
	<artifact type="bundle" name="org.apache.geronimo.specs.geronimo-servlet_3.0_spec" version="1.0"/>
	<artifact type="bundle" name="org.apache.geronimo.specs.geronimo-ws-metadata_2.0_spec" version="1.1.3"/>
	<artifact type="bundle" name="org.apache.servicemix.bundles.jdom" version="1.1.2.1"/>
	<artifact type="bundle" name="org.eclipse.jetty.aggregate.jetty-all-server" version="7.4.2.v20110526"/>
	<artifact type="bundle" name="org.ops4j.pax.web.pax-web-spi" version="1.0.11"/>
	<artifact type="bundle" name="org.ops4j.pax.web.pax-web-runtime" version="1.0.11"/>
	<artifact type="bundle" name="org.ops4j.pax.logging.pax-logging-api" version="1.7.0"/>
	<artifact type="bundle" name="org.apache.servicemix.specs.jaxb-api-2.2" version="2.2.0"/>
	<artifact type="bundle" name="org.apache.servicemix.bundles.wsdl4j" version="1.6.2.6"/>
	<artifact type="bundle" name="org.apache.santuario.xmlsec" version="1.5.3"/>
	<artifact type="bundle" name="org.apache.ws.xmlschema.core" version="2.0.3"/>
	<artifact type="bundle" name="org.apache.servicemix.bundles.asm" version="3.3.1.1"/>
	<artifact type="bundle" name="org.apache.servicemix.bundles.xmlresolver" version="1.2.0.5"/>
	<artifact type="bundle" name="org.apache.neethi" version="3.0.2"/>
	<artifact type="bundle" name="stax2-api" version="3.1.1"/>
	
	<artifact type="bundle" name="woodstox-core-asl" version="4.1.4"/>
	<artifact type="bundle" name="org.apache.servicemix.bundles.commons-pool" version="1.5.4.1"/>
	<artifact type="bundle" name="org.apache.servicemix.specs.saaj-api-1.3" version="2.2.0"/>
	<artifact type="bundle" name="org.apache.servicemix.specs.stax-api-1.0" version="2.2.0"/>
	<artifact type="bundle" name="org.apache.servicemix.specs.jsr339-api-m10" version="2.2.0"/>
	<artifact type="bundle" name="org.apache.servicemix.bundles.joda-time" version="1.5.2.4"/>
	<artifact type="bundle" name="org.apache.aries.util" version="0.3.1"/>
	<artifact type="bundle" name="org.apache.aries.proxy" version="0.3.1"/>
	<artifact type="bundle" name="org.apache.aries.blueprint" version="0.3.2"/>
	
	<artifact type="bundle" name="org.apache.felix.configadmin" version="1.2.8"/>
	<artifact type="bundle" name="org.apache.felix.fileinstall" version="3.1.10"/>
	
	<artifact type="bundle" name="org.apache.cxf.cxf-api" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-frontend-simple" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-frontend-jaxws" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-frontend-jaxrs" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-databinding-jaxb" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-databinding-aegis" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-bindings-xml" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-bindings-soap" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-transports-http" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-transports-http-jetty" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-ws-policy" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-rs-extension-providers" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.cxf-rt-core" version="2.7.2"/>
	<artifact type="bundle" name="org.apache.cxf.bundle" version="2.7.2"/>
	
	<artifact type="bundle" name="cxf-dosgi-ri-dsw-cxf" version="1.4.0"/>
	<artifact type="bundle" name="cxf-dosgi-ri-topology-manager" version="1.4.0"/>
	<artifact type="bundle" name="cxf-dosgi-ri-discovery-local" version="1.4.0"/>	
	<artifact type="bundle" name="cxf-dosgi-ri-discovery-distributed" version="1.4.0"/>
</plan>
Previous Topic:Admin Virgo Console
Next Topic:Installing bundle via plan fails
Goto Forum:
  


Current Time: Tue Sep 30 17:57:32 GMT 2014

Powered by FUDForum. Page generated in 0.01709 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software