Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Can't upgrade to BIRT Runtime 4.3
Can't upgrade to BIRT Runtime 4.3 [message #1066918] Fri, 05 July 2013 07:15 Go to next message
Juliane Harbarth is currently offline Juliane Harbarth
Messages: 20
Registered: July 2009
Junior Member


Good morning,

we used to include a BIRT runtime as part of our SOA environment and this worked fine for a long time (for something like four years now). The last time we upgraded to a higher BIRT runtime we went to:
viewerVersion/engineVersion = "2.6.1";

For previous upgrades, I just took the birt.war from the respective download and with this replaced our previous birt.war in the build-process that includes the reporting facilities into the overall system. Since this went well the last times, I intended to proceed like this for (232->261) but this proves impossible.

The first problem is that on the download page (http://download.eclipse.org/birt/downloads) there are now two BIRT runtimes, i.e. birt-runtime-4_3_0.zip and birt-runtime-osgi-4_3_0.zip. After looking at the birt.war's, I decided for the one from birt-runtime-osgi-4_3_0.zip, since the other one does not contain \WEB-INF\platform\ which our previously included birt.war did. We also need this because our building process adds to its 'plugins' subfolder.

When utilizing the built result in our environment (which is basically Apache Tomcat/7.0.29) by running a report this resulted in

Fatal error occurred when try to startup report engine.
org.eclipse.birt.report.exception.ViewerException: Fatal error occurred when try to startup report engine.
at org.eclipse.birt.report.service.ReportEngineService.setEngineContext(ReportEngineService.java:342)

complete stack trace is added at the end.

To make sure this is not caused by our additions to the downloaded birt.war, I tried it with the original birt.war 4.3 also with the same result. To make sure this is not caused by the way we call it in our environment, I called the birt webapp directly from the browser and this yielded 'BIRT viewer has been installed', but 'View Example' gave me the same error.

So the error must be caused by the fact that the 4.3 birt.war I took does not fit into the environment I deployed it into. Next I'll try with a raw Tomcat 7.0.29. Googling with the above error gave me lots of ideas, but these were rather diverse. Can anybody give me a hint about what I am doing wrong, it might be a very fundamental thing having to do with this OSGi-fication? Does the error message ring a bell for somebody?

Thank you very much & regards,
Juliane.


- Fatal error occurred when try to startup report engine.
org.eclipse.birt.report.exception.ViewerException: Fatal error occurred when try to startup report engine.

at org.eclipse.birt.report.service.ReportEngineService.setEngineContext(ReportEngineService.java:342)

at org.eclipse.birt.report.service.BirtViewerReportService.setContext(BirtViewerReportService.java:1022)

at org.eclipse.birt.report.servlet.ViewerServlet.__getContext(ViewerServlet.java:148)

at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.doGet(BirtSoapMessageDispatcherServlet.java:151)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:621)

at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)

at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.service(BirtSoapMessageDispatcherServlet.java:122)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)

at org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.java:68)

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)

at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)

at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:225)

at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)

at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)

at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:168)

at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98)

at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)

at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)

at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1001)

at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:585)

at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

at java.lang.Thread.run(Thread.java:724)




Re: Can't upgrade to BIRT Runtime 4.3 [message #1067052 is a reply to message #1066918] Fri, 05 July 2013 15:23 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1639
Registered: July 2009
Senior Member

Yes. There are now two versions of the runtime. In 3.7.0, the runtime switched to a POJO runtime. This caused a problem for some people, so in 3.7.2, the OSGi option was added back as a separate option. This is why there are two. As for the issue you're having, I'm downloading the OSGi runtime to check it out. I've got Tomcat 7.0.41 that I'll try it on. I'll let you know if I have any issues.

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Re: Can't upgrade to BIRT Runtime 4.3 [message #1067069 is a reply to message #1067052] Fri, 05 July 2013 16:25 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1639
Registered: July 2009
Senior Member

I didn't have any issues. Did you have issues when you tried with a raw version of 7.0.29?

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
icon7.gif  Re: Can't upgrade to BIRT Runtime 4.3 [message #1068152 is a reply to message #1066918] Fri, 12 July 2013 12:39 Go to previous messageGo to next message
Jakob Kühne is currently offline Jakob Kühne
Messages: 1
Registered: July 2013
Junior Member
Hey Michael,

yesterday we tried the installation again with the following versions:

Tomcat: 7.0.41
BIRT Viewer Version: 4.3.0
BIRT Engine Version: 4.3.0
JRE version: 1.7.0_25

Now everything works without any issues.

Thank you very much & regards,
Jakob.
Re: Can't upgrade to BIRT Runtime 4.3 [message #1071240 is a reply to message #1068152] Fri, 19 July 2013 16:20 Go to previous message
Michael Williams is currently offline Michael Williams
Messages: 1639
Registered: July 2009
Senior Member

Very good to hear! Let us know whenever you have questions!

Michael

Add interactivity, scheduling, sharing, live Excel export, and JS integration to your BIRT app with the new, free BIRT server, BIRT iHub F-Type.
Previous Topic:2.6.2 report failures with BIRT 4.3
Next Topic:populate textbox when radio button selected
Goto Forum:
  


Current Time: Thu Oct 23 14:39:04 GMT 2014

Powered by FUDForum. Page generated in 0.03570 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software