Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BPMN 2.0 Modeler » Invalid BPMN2 from the modeler?
Invalid BPMN2 from the modeler? [message #1066339] Tue, 02 July 2013 04:51 Go to next message
Midhat Ali is currently offline Midhat Ali
Messages: 6
Registered: June 2012
Junior Member
On creating a BPMN 2 Choreography Diagram and adding a message and an item deifnition by using a wsdl, the following BPMN 2 file is generated: ttp://pastebin.com/YUQeFPG5

<bpmn2:interface id="Interface_1" implementationRef="ttp://www.webservicex.net/RealTimeMarketData.asmx?WSDL#//@ePortTypes.0" name="RealTimeMarketDataSoap">

The implementationRef is supposed to be a QName, and if I deserialize it with a JAXB, I get a null implementationRef. Is this is a bug? I want to associate a choreography partner with an Interface, and the interface to a WSDL, while keeping true to the BPMN 2 syntax and semantic. How do I do that?

These are the loaded plugins from org.eclipse.bpmn2 namespace

org.eclipse.bpmn2 (0.7.0.201304230617) "BPMN2 Model" [Active]
org.eclipse.bpmn2.edit (0.7.0.201304230617) "BPMN2 Edit Support" [Active]
org.eclipse.bpmn2.editor (0.7.0.201304230617) "BPMN2 Editor" [Active]
org.eclipse.bpmn2.modeler.core (0.2.5.201305082126) "BPMN2 Editor Core" [Active]
org.eclipse.bpmn2.modeler.runtime.example (0.2.5.201305082126) "Example Runtime Plugin" [Active]
org.eclipse.bpmn2.modeler.runtime.jboss.jbpm5 (0.2.5.201305082126) "BPMN2 Editor Runtime extensions for JBoss jBPM5" [Active]
org.eclipse.bpmn2.modeler.ui (0.2.5.201305082126) "BPMN2 Editor UI" [Active]
org.eclipse.bpmn2.modeler.wsil (0.2.5.201305082126) "WSIL Support for BPMN2 Modeler" [Active]

[Updated on: Tue, 02 July 2013 04:58]

Report message to a moderator

Re: Invalid BPMN2 from the modeler? [message #1066424 is a reply to message #1066339] Tue, 02 July 2013 11:32 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

I've confirmed that this is a bug Sad
Can you please file a bugzilla report here?
Thanks!
Bob
Re: Invalid BPMN2 from the modeler? [message #1066433 is a reply to message #1066424] Tue, 02 July 2013 11:56 Go to previous messageGo to next message
Midhat Ali is currently offline Midhat Ali
Messages: 6
Registered: June 2012
Junior Member
Unfortunately I cannot seem to be able to log into Bugzilla. My account is working fine for forums and wiki, but not for bugzilla. (as someone else also reported at www.eclipse.org/forums/index.php/m/1066429/)

I will do it when I can access bugzilla, or you can do it and post the link here.

Thanks
Re: Invalid BPMN2 from the modeler? [message #1066529 is a reply to message #1066433] Tue, 02 July 2013 22:18 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Hmm, I seem to remember that bugzilla accounts are separate from the eclipse forum, wiki, portal, etc. Have you tried creating a new account using this link?

https://dev.eclipse.org/site_login/createaccount.php

I will go ahead and create the bug report, but please let me know if you are unable to create a new bugzilla account, or if you need me to let the admins know about this problem.

Thanks again,
Bob

P.S. Here's the link to the bugzilla report:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=412156
Re: Invalid BPMN2 from the modeler? [message #1066572 is a reply to message #1066529] Wed, 03 July 2013 04:44 Go to previous messageGo to next message
Midhat Ali is currently offline Midhat Ali
Messages: 6
Registered: June 2012
Junior Member
I can access bugzilla now with this account. Thanks for all your help

[Updated on: Wed, 03 July 2013 04:44]

Report message to a moderator

Re: Invalid BPMN2 from the modeler? [message #1066597 is a reply to message #1066572] Wed, 03 July 2013 07:17 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

You're welcome Smile We should have a fix for this by end of this week.
Re: Invalid BPMN2 from the modeler? [message #1067099 is a reply to message #1066597] Fri, 05 July 2013 16:41 Go to previous message
Robert Brodt is currently offline Robert Brodt
Messages: 593
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

This should be fixed in the nightly build. Can you please install from http://download.eclipse.org/bpmn2-modeler/updates/nightly/kepler/ (or http://download.eclipse.org/bpmn2-modeler/updates/nightly/juno/ depending on your platform) and test?

Note that I still need to do some testing with the jBPM plugin to make sure there are no regressions, but a smoke test did not reveal any problems.

Thanks again!
Bob
Previous Topic:Error - Tutorial Custom Task
Next Topic:Name attribute
Goto Forum:
  


Current Time: Tue Sep 02 15:10:09 EDT 2014

Powered by FUDForum. Page generated in 0.03462 seconds