Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Trying to use Graphiti with Juno SR2 but getting dependency error(Trying to use Graphiti with Juno SR2 but getting missing requirement: Graphiti requires 'bundle org.)
Trying to use Graphiti with Juno SR2 but getting dependency error [message #1066268] Mon, 01 July 2013 19:18 Go to next message
Eduardo Pereira is currently offline Eduardo PereiraFriend
Messages: 4
Registered: July 2013
Junior Member
I am trying to install Graphiti on Juno SR2 but I am getting an error.

* I installed/run eclipse-modeling-juno-SR2-win32-x86_64.zip
* Added the Graphiti repository http://download.eclipse.org/graphiti/updates/0.10.0
* Tried to install Graphiti but got the error:

** Missing requirement: Graphiti Composite Examples (Incubation) requires 'bundle org.eclipse.ui [3.105.0,4.0.0)' but it could not be found

The Graphiti download page (http://www.eclipse.org/graphiti/download.php) says that it is compatible with Kepler and Juno.

Is there something I can do to workaround thhis? Is this a bug? Should I log a ticket somewhere?
Re: Trying to use Graphiti with Juno SR2 but getting dependency error [message #1066329 is a reply to message #1066268] Tue, 02 July 2013 08:13 Go to previous messageGo to next message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1637
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Eduardo,

thanks for raising that here, I should have posted that here as well...

There's an open Bugzilla for this already
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=411891). The reason for this
is that one of the examples of Graphiti lacks version range definitions for
some of its dependencies, so they got hard wired to the exact versions
contained in Kepler by the build.

A fix is on the way for Luna M1 and Kepler SR1, please follow the bug to
track progress.

Until then you can install the Kepler Examples of Graphiti only into an
Eclipse Kepler. It is possible however to install the Kepler Graphiti
framework into an Eclipse Juno, so I would propose to use a Kepler as
development IDE and Juno as target until the issue is solved.

Just let me know in case this does not help (best to report back on the
bug).

Thanks,
Michael
Re: Trying to use Graphiti with Juno SR2 but getting dependency error [message #1076047 is a reply to message #1066329] Tue, 30 July 2013 15:28 Go to previous messageGo to next message
Eduardo Pereira is currently offline Eduardo PereiraFriend
Messages: 4
Registered: July 2013
Junior Member
Michael,

Should the kepler nightly build update side work also?
I took a look at http://download.eclipse.org/graphiti/updates/nightly but it seems to have a build from 20130308. I expected something from last night. Is this the right url for the nightly build? I got it from http://www.eclipse.org/graphiti/download.php.

Thanks
Eduardo.
Re: Trying to use Graphiti with Juno SR2 but getting dependency error [message #1076553 is a reply to message #1076047] Wed, 31 July 2013 15:15 Go to previous message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1637
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Eduardo,

hm, it seems that propmoting the nightly build to that update site is
broken. I will look into that...

Assuming you would rather like to consume a fixed Kepler contribution
instead of our Luna contribution, which should actually be on the nightly
update site, I would suggest to use
http://download.eclipse.org/graphiti/updates/maintenance/ . There is an
integration version of Graphiti for Kepler SR1 already containing the fix.

Michael
Previous Topic:Better movement inside an editor
Next Topic:Manhattan Connection routing
Goto Forum:
  


Current Time: Sat Nov 29 02:58:04 GMT 2014

Powered by FUDForum. Page generated in 0.01599 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software