Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Console output does not appear
Console output does not appear [message #1066085] Sun, 30 June 2013 05:14 Go to next message
Mark Murphy is currently offline Mark MurphyFriend
Messages: 2
Registered: June 2013
Location: Cincinnati, OH
Junior Member
I posted this on Eclipse 4, but haven't gotten a bite. Maybe someone here can help.

Fresh copy of Eclipse 4.2.2 with Subversion, Mylin, and PDT installed from update site.

I set up an external tool that interacts with the console, but the output does not appear until after a significant portion of the job is run, even though the console session successfully asks for and receives input. I happen to know what that input should be, so I typed it, just to see what happened, and when I pressed enter, the prompt, and the results displayed in the console. It is like the output is not sent to the console until a certain amount has been written, and not even an input operation will cause it to display. Here is an example console session:

yes

Yii Migration Tool v1.0 (based on Yii v1.1.13)

Total 2 new migrations to be applied:
    m130412_132354_Main
    m130418_155952_Main_Data

Apply the above migrations? (yes|no) [no]:*** applying m130412_132354_Main
    > create table sys_table ... done (time: 0.035s)
    > refresh table sys_table schema cache ... done (time: 0.032s)
    > create table sys_table_detail ... done (time: 0.044s)
    > refresh table sys_table_detail schema cache ... done (time: 0.013s)
    > create table sys_country ... done (time: 0.074s)
    > refresh table sys_country schema cache ... done (time: 0.021s)
    > create table sys_state ...


There is more, but it looks just like the last few lines. The thing to notice is that 'yes' above is what I typed into the console, then pressed enter. The prompt does not appear until after I type my response. The lines immediately following 'yes' up to and including '[no]:' are the prompt. Note that the newline that normally is provided by the user pressing enter after responding to the prompt is not there, and the result output immediately follows '[no]:' beginning with '***'.

Has anyone else experienced this? The language writing to the console is PHP if that matters. does anyone know of a fix for this behavior?
Re: Console output does not appear [message #1066098 is a reply to message #1066085] Sun, 30 June 2013 13:47 Go to previous message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 359
Registered: July 2009
Location: Japan
Senior Member
Did you set output_handler directive in your php.ini?

(blogged here http://blog.goo.ne.jp/atlanto/e/19ff7c7d1331b146e9a88f5f0c9a220a Rolling Eyes )

[Updated on: Sun, 07 July 2013 01:19]

Report message to a moderator

Previous Topic:Console Output Does Not Appear
Next Topic:wysiwyg editor
Goto Forum:
  


Current Time: Sun Dec 21 02:07:41 GMT 2014

Powered by FUDForum. Page generated in 0.01564 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software