Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Observation button and mapping buttons disabled
Observation button and mapping buttons disabled [message #1066019] Sat, 29 June 2013 00:25 Go to next message
Jiajian Lei is currently offline Jiajian LeiFriend
Messages: 36
Registered: June 2013
Member
Hi all,

I have set up my own RCP product and a testcase/testsuit the same way as tutorial. When I connected to AUT server and launch the AUT, both Observation mode button and object mapping mode button are disabled. But they are enabled in the tutorial after connecting to AUT server. Please guide me how to get it work. I am trying to write a testcase for the project wizard function for my RCP project.

Thanks a lot.
Re: Observation button and mapping buttons disabled [message #1066038 is a reply to message #1066019] Sat, 29 June 2013 08:45 Go to previous messageGo to next message
Achim Loerke is currently offline Achim LoerkeFriend
Messages: 357
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

Did you add the RCP accessor to your AUT? You have to copy the bundle and add a startup line to your AUT's configuration (check the documentation on configuring RCP AUTs). If you don't see your AUT in the "Running AUTs" view you probably missed this. If, on the other hand, the AUT is listed you might have found a bug.

- Achim
Re: Observation button and mapping buttons disabled [message #1066039 is a reply to message #1066038] Sat, 29 June 2013 08:53 Go to previous messageGo to next message
Jiajian Lei is currently offline Jiajian LeiFriend
Messages: 36
Registered: June 2013
Member
Thanks a lot. I think I did miss adding the accessor to my AUT.
I am still a bit confused with how Jubula works. Could anyone please explain me a little bit? What's the point of using the observation mode? And how do I know which practice I should drag and add to my testcase? I am currently trying to make a testcase for a project wizard, but will eventually extend it for more GUI functional testing.

Please help.

thanks a lot.
Re: Observation button and mapping buttons disabled [message #1066259 is a reply to message #1066038] Mon, 01 July 2013 18:06 Go to previous messageGo to next message
Jiajian Lei is currently offline Jiajian LeiFriend
Messages: 36
Registered: June 2013
Member
I have added the org.eclipse.jubula.rc.rcp_2.1.0.201306171048.jar to the plugin folder in my RCP directory and tried to add 'org.eclipse.jubula.rc.rcp' or 'org.eclipse.jubula.rc.rcp_2.1.0.201306171048' in config.ini. It's still no t working though - the Observation button and mapping buttons disabled and nothing is shown in Running AUT windows.
Screenshot is attached.

[Updated on: Mon, 01 July 2013 18:27]

Report message to a moderator

Re: Observation button and mapping buttons disabled [message #1066279 is a reply to message #1066259] Mon, 01 July 2013 20:39 Go to previous messageGo to next message
Jiajian Lei is currently offline Jiajian LeiFriend
Messages: 36
Registered: June 2013
Member
I was reading this post, http://www.eclipse.org/forums/index.php/m/1059144/?srch=RUNNING+AUT#msg_1059144
I am having the exact same problem except that I generated my AUT product with eclipse RCP Juno (Juno Service Release 1), not Kepler. Jubula is not able to test my product because it's somehow not compatible with products built and generated by Eclipse juno?

[Updated on: Mon, 01 July 2013 21:29]

Report message to a moderator

Re: Observation button and mapping buttons disabled [message #1066287 is a reply to message #1066279] Mon, 01 July 2013 22:20 Go to previous messageGo to next message
Jiajian Lei is currently offline Jiajian LeiFriend
Messages: 36
Registered: June 2013
Member
I just tried generated the Mail Template with Indigo RCP, and it's still not working.
I followed through every instruction on the tutorial though. To add the RCP accessor to my AUT, I just extract rcp-support.zip and copy the jar file (org.eclipse.jubula.rc.rcp_2.1.0.201306171048.jar) to the plugins folder in my AUT product directory, right? Then I add 'org.eclipse.jubula.rc.rcp' to the end of 'osgi.bundles=' in config.ini under 'jubula_destination_product\mail2\configuration'
If I open my AUT through Jubula and go to about/installations details, it shows one jubula plugin, 'Jubula Remote Control - RCP Common' for plug-in name.
How come there is nothing shown in the Running AUT window and the progress bar for 'starting AUT with AUT MAIL2 Test' just hangs?

[Updated on: Mon, 01 July 2013 23:17]

Report message to a moderator

Re: Observation button and mapping buttons disabled [message #1066355 is a reply to message #1066287] Tue, 02 July 2013 09:56 Go to previous messageGo to next message
Achim Loerke is currently offline Achim LoerkeFriend
Messages: 357
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

I've noticed that you wrote that you added the RCP accessor bundle without the "start" parameter. Please refer to the documentation and keep in mind that none of the steps are optional (well, maybe the -clear is only required once) and that RCP is extremely picky wrt typos, additional spaces etc.

- Achim
Re: Observation button and mapping buttons disabled [message #1066446 is a reply to message #1066355] Tue, 02 July 2013 17:00 Go to previous messageGo to next message
Jiajian Lei is currently offline Jiajian LeiFriend
Messages: 36
Registered: June 2013
Member
Thanks for the response. I tried adding 'org.eclipse.update.configurator#3:start,org.eclipse.jubula.rc.rcp' to the end of osgi.bundle in config.ini, it still didn't fix the issue.(I replaced @ with # since it was being recognized as an email format)
Also, when I copied the content within rcp-support.zip into my AUT plugins folder, I noticed there was only one bundle file, which is the org.eclipse.jubula.rc.rcp_2.1.0.201306171048.jar. That was the only bundle file that I added to my AUT plugins folder.

[Updated on: Tue, 02 July 2013 17:08]

Report message to a moderator

Re: Observation button and mapping buttons disabled [message #1066564 is a reply to message #1066446] Wed, 03 July 2013 08:05 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1193
Registered: July 2009
Senior Member
Hi,

It looks like Achim accidentally referred you to the older version of the help. If you're using the latest version of Jubula (7.1 standalone or Eclipse Kepler), then the instructions are different. They are here.

HTH,
Alex
Re: Observation button and mapping buttons disabled [message #1066682 is a reply to message #1066564] Wed, 03 July 2013 17:48 Go to previous messageGo to next message
Jiajian Lei is currently offline Jiajian LeiFriend
Messages: 36
Registered: June 2013
Member
Thanks a lot. It is working now. The tutorials out there are really misleading.
Could you please send me the correct and up-to-date documentation or tutorial on how to integrate Jubula with Jenkins as well?
Thanks!
Re: Observation button and mapping buttons disabled [message #1067263 is a reply to message #1066682] Mon, 08 July 2013 07:14 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1193
Registered: July 2009
Senior Member
The documentation on the testexec is in the same manual as the one linked above.
Previous Topic:Could testexec Command offer an error message of screen shot besides .htm & .xml file?
Next Topic:Can the search scope of "Show where used" be extended?
Goto Forum:
  


Current Time: Sat Dec 20 13:11:04 GMT 2014

Powered by FUDForum. Page generated in 0.09330 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software