Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Problems when following the article "Getting started with CDT development"
Problems when following the article "Getting started with CDT development" [message #1065545] Wed, 26 June 2013 12:46 Go to next message
E J is currently offline E JFriend
Messages: 2
Registered: May 2013
Junior Member
I have:
- installed eclipse classic 4.2.2
- installed eclipse cdt 8.1.2 separately, and established an api baseline to this installation from the classic installation.
- imported all the projects from git://git.eclipse.org/gitroot/cdt/org.eclipse.cdt.git
into the classic installation workspace.
- Installed the additional dependencies listed under "Dependencies" in the "getting starte..." article.
- Installed API Tools Execution Environment Descriptions from http://download.eclipse.org/eclipse/updates/4.2.

From what I can tell the projects are supposed to build after this,
but I still get 30 errors:

Invalid @since 5.6 tag on FORWARD_DECLARE_TEMPLATES; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 1997 @since tag problem

Invalid @since 5.6 tag on FORWARD_DECLARE_NAMESPACE_ELEMENTS; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2007 @since tag problem

Invalid @since 5.6 tag on FORWARD_DECLARE_ENUMS; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 1976 @since tag problem

Invalid @since 5.6 tag on FORWARD_DECLARE_FUNCTIONS; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 1986 @since tag problem

Invalid @since 5.6 tag on FORWARD_DECLARE_COMPOSITE_TYPES; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 1966 @since tag problem

Invalid @since 5.6 tag on IMG_OBJS_WRAP_LINE; expecting @since 5.7 CDTSharedImages.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 119 @since tag problem

Invalid @since 5.6 tag on getPreference(String, ICProject, String); expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2431 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_EXTERNAL; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2154 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_OTHER_PROJECT; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2146 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_MATCHING_PATTERN; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2162 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_RELATED; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2074 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_SAME_PROJECT; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2138 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_PARTNER; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2082 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_OTHER; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2130 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_SAME_FOLDER; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2090 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_SYSTEM_WITH_EXTENSION; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2114 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_SUBFOLDER; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2098 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_SYSTEM_WITHOUT_EXTENSION; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2122 @since tag problem

Invalid @since 5.6 tag on INCLUDE_STYLE_SYSTEM; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2106 @since tag problem

Invalid @since 5.6 tag on INCLUDES_ALLOW_REORDERING; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2039 @since tag problem

Invalid @since 5.6 tag on org.eclipse.cdt.ui.text.ISemanticToken; expecting @since 5.7 ISemanticToken.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui/text line 12 @since tag problem

Invalid @since 5.6 tag on org.eclipse.cdt.ui.text.ISemanticHighlighter; expecting @since 5.7 ISemanticHighlighter.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui/text line 18 @since tag problem

Invalid @since 5.6 tag on INCLUDES_UNUSED_STATEMENTS_DISPOSITION; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2056 @since tag problem

Invalid @since 5.6 tag on INCLUDES_HEURISTIC_HEADER_SUBSTITUTION; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2026 @since tag problem

Invalid @since 5.6 tag on INCLUDES_PARTNER_FILE_SUFFIXES; expecting @since 5.7 PreferenceConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui line 2016 @since tag problem

The type org.eclipse.cdt.ui.refactoring.actions.Messages in org.eclipse.cdt.ui_5.7.0 is no longer API Messages.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui/refactoring/actions line 15 Compatibility Problem

The method org.eclipse.cdt.core.language.settings.providers.ScannerDiscoveryLegacySupport.getDefaultProvidersLegacy() has been removed ScannerDiscoveryLegacySupport.java /org.eclipse.cdt.core/model/org/eclipse/cdt/core/language/settings/providers line 40 Compatibility Problem

The major version should be incremented in version 5.5.0, since API breakage occurred since version 5.4.1 MANIFEST.MF /org.eclipse.cdt.core/META-INF line 5 Version Numbering Problem

Invalid @since 5.6 tag on ORGANIZE_INCLUDES; expecting @since 5.7 CdtActionConstants.java /org.eclipse.cdt.ui/src/org/eclipse/cdt/ui/actions line 147 @since tag problem

The major version should be incremented in version 5.7.0, since API breakage occurred since version 5.5.0 MANIFEST.MF /org.eclipse.cdt.ui/META-INF line 5 Version Numbering Problem

What am I supposed to do to get rid of these errors (without changing the
source code) ?

Thanks for any help.

[Updated on: Wed, 26 June 2013 13:01]

Report message to a moderator

Re: Problems when following the article "Getting started with CDT development" [message #1065859 is a reply to message #1065545] Thu, 27 June 2013 22:17 Go to previous message
Andrew Gvozdev is currently offline Andrew GvozdevFriend
Messages: 256
Registered: July 2009
Senior Member
Your baseline has to match the branch you checked out. Did you check out master? The latest master requires CDT 8.2.0 baseline (from Kepler). If you want to develop 8.1.2 you would need to check out branch cdt_8_1 and use CDT 8.1.0 as baseline.

Andrew
Previous Topic:Adapting working Eclipse plugin to Eclipse C++
Next Topic:CDT loses contact with gdb after a few commands
Goto Forum:
  


Current Time: Wed Nov 26 09:21:48 GMT 2014

Powered by FUDForum. Page generated in 0.04061 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software