Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EMF-IncQuery » Support for Xtext 2.4?
Support for Xtext 2.4? [message #1065322] Tue, 25 June 2013 10:27 Go to next message
Emre T is currently offline Emre T
Messages: 119
Registered: April 2013
Senior Member
Hello,

for the time being, when I try do update the EMF-IncQuery from the Integration Build, there come up some dependency problems pointing to the missing support of Xtext 2.4 etc. Does that mean, that the EMF-IncQuery can function from now on with the newest version of Xtext?

Since I couldn't risk for the time being the functionality of my project, I wanted to be sure about this matter. And on the Viatra website, there is still the warning, that EMF-IncQuery only works with the Xtext 2.3.

Thank you!
Re: Support for Xtext 2.4? [message #1065326 is a reply to message #1065322] Tue, 25 June 2013 10:47 Go to previous messageGo to next message
Emre T is currently offline Emre T
Messages: 119
Registered: April 2013
Senior Member
And please, this is the dependency problems occuring, when I try to update the EMF-IncQuery from the Integration Build:

Cannot complete the install because one or more required items could not be found.
Software being installed: EMF-IncQuery SDK (Incubation) 0.7.0.201306250751 (org.eclipse.incquery.sdk.feature.source.feature.group 0.7.0.201306250751)
Missing requirement: IncQuery-based derived feature tooling (Incubation) 0.7.0.201306250751 (org.eclipse.incquery.querybasedfeatures.tooling 0.7.0.201306250751) requires 'bundle org.eclipse.xtext.xbase.lib [2.4.2,2.5.0)' but it could not be found
Cannot satisfy dependency:
From: EMF-IncQuery Query Based Feature Tooling (Incubation) 0.7.0.201306250751 (org.eclipse.incquery.querybasedfeatures.tooling.feature.feature.group 0.7.0.201306250751)
To: org.eclipse.incquery.querybasedfeatures.tooling [0.7.0.201306250751]
Cannot satisfy dependency:
From: EMF-IncQuery Query Based Feature Tooling (Incubation) Developer Resources 0.7.0.201306250751 (org.eclipse.incquery.querybasedfeatures.tooling.feature.source.feature.group 0.7.0.201306250751)
To: org.eclipse.incquery.querybasedfeatures.tooling.feature.feature.group [0.7.0.201306250751]
Cannot satisfy dependency:
From: EMF-IncQuery SDK (Incubation) 0.7.0.201306250751 (org.eclipse.incquery.sdk.feature.source.feature.group 0.7.0.201306250751)
To: org.eclipse.incquery.querybasedfeatures.tooling.feature.source.feature.group [0.7.0.201306250751]
Re: Support for Xtext 2.4? [message #1065327 is a reply to message #1065326] Tue, 25 June 2013 10:51 Go to previous messageGo to next message
Abel Hegedus is currently offline Abel Hegedus
Messages: 92
Registered: July 2009
Member
Hi Emre,

yes, we created the new integration build with Xtext 2.4 support just today.

The webpages will be updated shortly, but consider that both the milestone and release versions are still Xtext 2.3 dependent.

Cheers
Re: Support for Xtext 2.4? [message #1065335 is a reply to message #1065327] Tue, 25 June 2013 10:59 Go to previous messageGo to next message
Emre T is currently offline Emre T
Messages: 119
Registered: April 2013
Senior Member
Hello Abel,

thanks for the quick reply. So I can update the EMF-IncQuery from the Integration Build today, right?

Emre
Re: Support for Xtext 2.4? [message #1065338 is a reply to message #1065335] Tue, 25 June 2013 11:07 Go to previous messageGo to next message
Abel Hegedus is currently offline Abel Hegedus
Messages: 92
Registered: July 2009
Member
Hi,

if you would like to update, you will also have to update at least EMF (to 2.9) and Xtext (to 2.4.2).

I advise you to wait until Kepler is out officially (tomorrow) and both the above are released.

Cheers,
Re: Support for Xtext 2.4? [message #1065346 is a reply to message #1065338] Tue, 25 June 2013 11:35 Go to previous message
Istvan Rath is currently offline Istvan Rath
Messages: 54
Registered: July 2009
Member
Hi Emre,

if you need a fairly recent version of IncQuery that is still Xtext 2.3 compatible (but e.g. contains the support for dynamic resources), use the previous integration version (0.7.0.201306182010).

Istvan
Previous Topic:Non-persisted resources for AdvancedAPI
Next Topic:Package declaration "does not match the container package"
Goto Forum:
  


Current Time: Tue Sep 16 23:40:00 GMT 2014

Powered by FUDForum. Page generated in 0.03359 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software