Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Context menu problems(Some of the AUT's context menus are not found by Jubula)
Context menu problems [message #1064849] Fri, 21 June 2013 07:21 Go to next message
Olav Beyermann is currently offline Olav Beyermann
Messages: 7
Registered: May 2012
Junior Member
Hi all,

I'm testing my company's software with Jubula since more than 2 years now, currently using Version 1.3.0. There are periods of time when my test cases have problems with context menus without any relevant source code changes in the AUT done before. Especially (but not only) second level context menus are causing Action Errors. It's kind of funny because in certain cases the error screenshot displays the context menu with the missed menu item shown; in other certain cases the screenshot does not show the menu. Then, for any reason and without any relevant source code changes, everything works fine again. At the moment it - guess what - does not.

Thanks in advance for suggestions/solutions.

Olav

P.S.:
OS: Win 7, Win 2008 R2
AUT: Swing client server app under JRE 6

[Updated on: Fri, 21 June 2013 08:39]

Report message to a moderator

Re: Context menu problems [message #1065060 is a reply to message #1064849] Mon, 24 June 2013 04:03 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1092
Registered: July 2009
Senior Member
Hi,

Can you elaborate on the problems with context menus? Are you receiving action errors (timeouts), or context menu not found, or something else? I know that we did some work on the stability of these actions for the 2.0 release, if you add more details and / or logs, then we might be able to say if these are the sort of things that got fixed.

Best regards,
Alex
Re: Context menu problems [message #1065079 is a reply to message #1065060] Mon, 24 June 2013 05:23 Go to previous message
Olav Beyermann is currently offline Olav Beyermann
Messages: 7
Registered: May 2012
Junior Member
Hi Alex,

the context menu problems are of type "Action Error" and the error description in most cases is "Not found" and sometimes "Context Menu not found".

Olav
Previous Topic:AUT performance tests
Next Topic:Cleaning Testresults takes very long time
Goto Forum:
  


Current Time: Tue Jul 29 10:59:49 EDT 2014

Powered by FUDForum. Page generated in 0.02338 seconds