Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [SOLVED] Parts of EMF Plugin are not deployed on startup
[SOLVED] Parts of EMF Plugin are not deployed on startup [message #1064830] Fri, 21 June 2013 05:29 Go to next message
Joris Lückenga is currently offline Joris Lückenga
Messages: 7
Registered: March 2013
Junior Member
Hello everyone,

I have nearly the same Problem as mentioned in this post:
http://www.eclipse.org/forums/index.php/m/398248/

I´d like to share my plugin with others and therefore wanted to test, if my exported .jar files work with an Eclipse instance.

I made the following steps:
- Exported the Project via "Deployable plug-ins and fragments" (All 3, the original project, .edit and .editor)
- Downloaded Eclipse Classic 4.2.2
- Copied the .jar Files into dropins/plugins (tried it with: dropins/eclipse/plugins and in the original plugins folder too)
- The Plugin does appear in the Plugins-List (About Eclipse, Installation Details)
- Started Eclipse with -clean option
- Started Eclipse as Administrator and also with -clean -console -consoleLog. There weren´t any Error-messages in the console, neither in the Eclipse Error Log
- The Capabilities (Eclipse Preferences) are all enabled

Apperently this is not a problem with Eclipse but my plugin, because i tried the same with a "Test-Plugin" (Hello, Eclipse World), exported it in dropins and it worked just fine.

I don´t have a clue what could be the problem with my code - i even signed the .jar files. When i run the plugin as Eclipse Application in my Workbench, it also works without any trouble (not any error in the console).

When i exported the plugin i had some errors and warnings in the log.zip. I fixed the errors and now there aren´t any log.zip-files created when i export the plugin.

I´d really appreciated if someone could give me a hint!

Thanks,
Joris


EDIT:

Problem: Not all dependencies where installed - the plugins did not work. (There were not any errors displayd, i had to find it out by try and error)

Solution: I created a Feature Project which includes my plugins. I manually added all dependencies in the feature.xml of all three plugins and exported the Feature. When i opened a new eclipse instance i navigated to "install new software.." and used my exported Feature as path as the "local update site". The dependencies are downloaded through the eclipse framework - the plugin then starts up correctly.

[Updated on: Fri, 28 June 2013 04:35]

Report message to a moderator

Re: Exported deployable EMF Plugin is not active [message #1064862 is a reply to message #1064830] Fri, 21 June 2013 09:04 Go to previous message
Joris Lückenga is currently offline Joris Lückenga
Messages: 7
Registered: March 2013
Junior Member
I just figured out, that only the original project is included in the installed plugins.
The .edit and .editor plugins are not inlcuded, but i can´t figure out why :/

This is the only warning which pops up:
NLS unused message: CacheManager_CannotLoadNonUrlLocation in: org.eclipse.equinox.internal.p2.repository.messages

[Updated on: Fri, 21 June 2013 09:08]

Report message to a moderator

Previous Topic:[EMF] EContentAdapter
Next Topic:[EMF] Problems with multiple supertypes in programatic metamodel creation
Goto Forum:
  


Current Time: Wed Jul 30 09:22:46 EDT 2014

Powered by FUDForum. Page generated in 0.01559 seconds