Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Can't start AUT agent(Starting the AUT agent with the mouse doesn't work)
Can't start AUT agent [message #1064609] Thu, 20 June 2013 08:45 Go to next message
Paraita Wohler is currently offline Paraita Wohler
Messages: 8
Registered: June 2013
Junior Member
Hi,
I am using Jubula2 on Windows XP to test a Swing application. If I use the embedded AUT agent from within the ITE, it works like a charm. I'd like to use the external autagent.exe tool, from the documentation I should just run it by clicking on Start->Jubula->Start AUT Agent. The command-line opens up, then closes immediately.

I also tried to run it by double-clicking it from the Jubula install directory, the same happened.

Finally I removed the --launcher.suppressErrors flag in the autagent.ini to see any output errors, you can see the error in the attachement.

Is this issue known ? I've searched in the documentation troublesetting section with no result. I have another computer with Jubula installed (same environment) and starting the AUT this way does work. I'm not familiar with Windows environment, is there something I'm missing or not aware of ?

Also, if I try to run autagent.exe from Cygwin, it actually works, but with windows command line, it doesn't. I get a "JVM could not be started, not enough memory could be allocated" or something.

I guess this is not memory related since it does work under Cygwin.

Also I see that my AUT isn't exited after a test. It means that if I run 10 tests, it will load my AUT 10 times.

Help, please !

[Updated on: Fri, 21 June 2013 09:35]

Report message to a moderator

Re: Can't start AUT agent [message #1065056 is a reply to message #1064609] Mon, 24 June 2013 07:57 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi,

Two possibilities come to mind:

- Port conflicts between the embedded Agent and the standalone. Does changing the port number for the standalone agent alter the behaviour?
- Firewall problems - could the Agent be being blocked?

If neither of these are the case, please open a ticket with the information you've entered here, and the error message as well as any log files for the AUT Agent (in your hime directory /.jubula).
Thanks!
Alex
Re: Can't start AUT agent [message #1065184 is a reply to message #1065056] Mon, 24 June 2013 16:00 Go to previous message
Paraita Wohler is currently offline Paraita Wohler
Messages: 8
Registered: June 2013
Junior Member
Hi Alexandra,
thank you for your answer !
I did check for any port conflicts. Although they were not run at the same time, I kept my AUT agent on the port 70000 and I left the Jubula embedded agent on its default port. It doesn't seem to change anything.
I also checked for my firewall and it is not even enabled. I think this is not related to Jubula because I realized I get the same behaviour on other programs running in dos-mode.
Anyway, I'll keep using Cygwin to run autagent but I still have the problem of the aut agent not "releasing" instances of my AUT. What I currently do is running explicity my AUT via autrun, and within my AUT I just exit the application at the end of my test. The instance is released correctly. I'll investigate further about my autagent problem and post logs.
Previous Topic:Cleaning Testresults takes very long time
Next Topic:Extending Jubula for RCP (version 2.0)
Goto Forum:
  


Current Time: Sun Oct 26 03:59:53 GMT 2014

Powered by FUDForum. Page generated in 0.02248 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software