Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WEB-INF/classes not getting deployed to Glassfish 3.1
WEB-INF/classes not getting deployed to Glassfish 3.1 [message #1064572] Thu, 20 June 2013 01:03 Go to next message
Bart Smyth is currently offline Bart SmythFriend
Messages: 1
Registered: June 2013
Junior Member
I am having trouble getting a web application deployed to Glassfish 3.1.1.

When building the war using maven and deploying it directly via the console, everything works fine. When adding the application to the server, backing beans are not visible to JSF pages.

Upon further investigation, it is apparent that none of the classes under WEB-INF are not being deployed. The jar dependencies under lib are there, but there is no classes directory. When I package the war using maven I can see the classes are in there.

Is there some option I'm missing?

Details :
Eclipse Juno SR2
Glassfish 3.1.1
MacOSX 10.8


Re: WEB-INF/classes not getting deployed to Glassfish 3.1 [message #1064711 is a reply to message #1064572] Thu, 20 June 2013 15:40 Go to previous messageGo to next message
Konstantin Komissarchik is currently offline Konstantin KomissarchikFriend
Messages: 962
Registered: July 2009
Senior Member
For help with GlassFish Tools for Eclipse, please head over to the following forum:

https://forums.oracle.com/community/developer/english/development_tools/application_development_in_java/enterprise_pack_for_eclipse
Re: WEB-INF/classes not getting deployed to Glassfish 3.1 [message #1506024 is a reply to message #1064711] Wed, 10 December 2014 14:09 Go to previous message
Zsolt Bardi is currently offline Zsolt BardiFriend
Messages: 1
Registered: December 2014
Junior Member
Hi!

I had the same problem, try:
- Right click on project/ Properties/Java Build Path/Source and edit the output folder at main/java to default

Hope it helps!
Previous Topic:How to customize deployment ?
Next Topic:How to turn off JSP Indexing, takes too long
Goto Forum:
  


Current Time: Mon Dec 22 00:12:02 GMT 2014

Powered by FUDForum. Page generated in 0.01680 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software