Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » CQuery import issues on Mac using SVN reader
CQuery import issues on Mac using SVN reader [message #1064459] Wed, 19 June 2013 11:44 Go to next message
Sakis Kotisis is currently offline Sakis Kotisis
Messages: 31
Registered: July 2009
Member
Hi,

The issue was encountered while trying to build a platform specific
feature on Mac OS with headless Buckminster v4.2.

Relevant .rmap is quite simple:

<?xml version="1.0" encoding="UTF-8"?>
<rm:rmap xmlns:bc="http://www.eclipse.org/buckminster/Common-1.0"
xmlns:rm="http://www.eclipse.org/buckminster/RMap-1.0">
<rm:locator searchPathRef="resources"/>
<rm:searchPath name="resources">
<rm:provider componentTypes="osgi.bundle,eclipse.feature"
readerType="svn" mutable="false">
<rm:property key="buckminster.mutable" value="false"/>
<rm:uri format="https://user:pass@xxxxxxxx.com/svn/pg/trunk/{0}">
<bc:propertyRef key="buckminster.component"/>
</rm:uri>
</rm:provider>
</rm:searchPath>
</rm:rmap>

And the .cquery as follows:

<?xml version="1.0" encoding="UTF-8"?>
<cq:componentQuery
xmlns:cq="http://www.eclipse.org/buckminster/CQuery-1.0"
resourceMap="site.rmap">
<cq:rootRequest name="c.s.p.releng.macosx"
componentType="eclipse.feature"/>
<cq:property key="target.arch" value="*"/>
<cq:property key="target.os" value="*"/>
<cq:property key="target.ws" value="*"/>
</cq:componentQuery>

Importing the above .cquery freezes at some point, both when using
Subversive and Subclipse.


Using Subversive
(org.eclipse.buckminster.subversive.headless.feature.feature.group
1.5.0.v20120810-0832,
org.eclipse.buckminster.subversive.svnkit16.headless.feature.feature.group
1.5.0.v20121009-0845), the component "c.s.p.releng.macosx" cannot be
resolved.

The log tail is:

!ENTRY org.eclipse.buckminster.core 0 293 2013-06-19 14:19:42.809
!MESSAGE c.s.p.releng.macosx:eclipse.feature: Using search path resources

!ENTRY org.eclipse.buckminster.core 0 293 2013-06-19 14:19:42.810
!MESSAGE c.s.p.releng.macosx:eclipse.feature: Trying provider
svn(https://user:pass@xxxxxxxx.com/svn/pg/trunk/{0}[https://user:pass@xxxxxxxx.com/svn/pg/trunk/c.s.p.releng.macosx])


Using Subclipse
(org.eclipse.buckminster.subclipse.headless.feature.feature.group
1.5.0.v20120810-0832), the SVN reader freezes while trying to check out
components without (it seems) specifying credentials. From the log:

Provider
svn(https://user:pass!@scm.sg.com/svn/pg/trunk/c.s.p.cb.macosx.feature):
materializing to /workspace/pg/features/c.s.p.cb.macosx.feature/
Checking out https://scm.sg.com/svn/pg/trunk/c.s.p.cb.macosx.feature using
revision 4634
Provider svn(https://user:pass!@scm.sg.com/svn/pg/trunk/c.s.p.pt.macosx):
materializing to /workspace/pg/plugins/c.s.p.pt.macosx/
Checking out https://scm.sg.com/svn/pg/trunk/c.s.p.pt.macosx using
revision 4598
Provider svn(https://user:pass!@scm.sg.com/svn/pg/trunk/c.s.p.cb.macosx):
materializing to /workspace/pg/plugins/c.s.p.cb.macosx/
Checking out https://scm.sg.com/svn/pg/trunk/c.s.p.cb.macosx using
revision 4318
Provider svn(https://user:pass!@scm.sg.com/svn/pg/trunk/g.o.p.cb):
materializing to /workspace/pg/plugins/g.o.p.cb/
Checking out https://scm.sg.com/svn/pg/trunk/g.o.p.cb using revision 4597


Checking out works using svn from terminal, and from Eclipse.
I don't know how to test with Subversive/Subclipse headless.

I've scoured the web for the past hours, but could not find any leads.

Any idea what could be wrong?
If not, is it possible to troubleshoot this somehow?


--
Sakis Kotisis

Senior Software Engineer
SciGen Technologies, S.A.
Re: CQuery import issues on Mac using SVN reader [message #1065106 is a reply to message #1064459] Mon, 24 June 2013 11:37 Go to previous message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
You can troubleshoot this by debugging Buckminster itself. The simplest way to do that is probably to install the source
bundles (available on our update site) and then debug Buckminster as a remote java process.

- thomas

On 2013-06-19 13:44, Sakis Kotisis wrote:
> Hi,
>
> The issue was encountered while trying to build a platform specific feature on Mac OS with headless Buckminster v4.2.
>
> Relevant .rmap is quite simple:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <rm:rmap xmlns:bc="http://www.eclipse.org/buckminster/Common-1.0" xmlns:rm="http://www.eclipse.org/buckminster/RMap-1.0">
> <rm:locator searchPathRef="resources"/>
> <rm:searchPath name="resources">
> <rm:provider componentTypes="osgi.bundle,eclipse.feature" readerType="svn" mutable="false">
> <rm:property key="buckminster.mutable" value="false"/>
> <rm:uri format="https://user:pass@xxxxxxxx.com/svn/pg/trunk/{0}">
> <bc:propertyRef key="buckminster.component"/>
> </rm:uri>
> </rm:provider>
> </rm:searchPath>
> </rm:rmap>
>
> And the .cquery as follows:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <cq:componentQuery xmlns:cq="http://www.eclipse.org/buckminster/CQuery-1.0" resourceMap="site.rmap">
> <cq:rootRequest name="c.s.p.releng.macosx" componentType="eclipse.feature"/>
> <cq:property key="target.arch" value="*"/>
> <cq:property key="target.os" value="*"/>
> <cq:property key="target.ws" value="*"/>
> </cq:componentQuery>
>
> Importing the above .cquery freezes at some point, both when using Subversive and Subclipse.
>
>
> Using Subversive (org.eclipse.buckminster.subversive.headless.feature.feature.group 1.5.0.v20120810-0832,
> org.eclipse.buckminster.subversive.svnkit16.headless.feature.feature.group 1.5.0.v20121009-0845), the component
> "c.s.p.releng.macosx" cannot be resolved.
>
> The log tail is:
>
> !ENTRY org.eclipse.buckminster.core 0 293 2013-06-19 14:19:42.809
> !MESSAGE c.s.p.releng.macosx:eclipse.feature: Using search path resources
>
> !ENTRY org.eclipse.buckminster.core 0 293 2013-06-19 14:19:42.810
> !MESSAGE c.s.p.releng.macosx:eclipse.feature: Trying provider
> svn(https://user:pass@xxxxxxxx.com/svn/pg/trunk/{0}[https://user:pass@xxxxxxxx.com/svn/pg/trunk/c.s.p.releng.macosx])
>
>
> Using Subclipse (org.eclipse.buckminster.subclipse.headless.feature.feature.group 1.5.0.v20120810-0832), the SVN reader
> freezes while trying to check out components without (it seems) specifying credentials. From the log:
>
> Provider svn(https://user:pass!@scm.sg.com/svn/pg/trunk/c.s.p.cb.macosx.feature): materializing to
> /workspace/pg/features/c.s.p.cb.macosx.feature/
> Checking out https://scm.sg.com/svn/pg/trunk/c.s.p.cb.macosx.feature using revision 4634
> Provider svn(https://user:pass!@scm.sg.com/svn/pg/trunk/c.s.p.pt.macosx): materializing to
> /workspace/pg/plugins/c.s.p.pt.macosx/
> Checking out https://scm.sg.com/svn/pg/trunk/c.s.p.pt.macosx using revision 4598
> Provider svn(https://user:pass!@scm.sg.com/svn/pg/trunk/c.s.p.cb.macosx): materializing to
> /workspace/pg/plugins/c.s.p.cb.macosx/
> Checking out https://scm.sg.com/svn/pg/trunk/c.s.p.cb.macosx using revision 4318
> Provider svn(https://user:pass!@scm.sg.com/svn/pg/trunk/g.o.p.cb): materializing to /workspace/pg/plugins/g.o.p.cb/
> Checking out https://scm.sg.com/svn/pg/trunk/g.o.p.cb using revision 4597
>
>
> Checking out works using svn from terminal, and from Eclipse.
> I don't know how to test with Subversive/Subclipse headless.
>
> I've scoured the web for the past hours, but could not find any leads.
>
> Any idea what could be wrong?
> If not, is it possible to troubleshoot this somehow?
>
>
Previous Topic:Error 0142
Next Topic: Validate WSDL Ant Task
Goto Forum:
  


Current Time: Sat Sep 20 22:06:13 GMT 2014

Powered by FUDForum. Page generated in 0.01612 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software