Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Problem while deploying xtext plugin
Problem while deploying xtext plugin [message #1063720] Thu, 13 June 2013 20:30 Go to next message
Phil H is currently offline Phil H
Messages: 267
Registered: November 2012
Senior Member
Hi,

When I run my Xtext plugin in another eclipse instance, everything works fine.
Now I tried to deploy my xtext plugins, but it told me that there was error during the deplyoing process. The log tells me the following:

1. ERROR in C:\...\.xtext.ui\src-gen\org\itea2\amalthea\model\variability\xtext\ui\AbstractPldxUiModule.java (at line 108)
	return org.itea2.amalthea.model.variability.xtext.ui.contentassist.PldxProposalProvider.class;
	       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
org.itea2.amalthea.model.variability.xtext.ui.contentassist.PldxProposalProvider cannot be resolved to a type
----------
2. ERROR in C:\...\.xtext.ui\src-gen\org\itea2\amalthea\model\variability\xtext\ui\AbstractPldxUiModule.java (at line 108)
	return org.itea2.amalthea.model.variability.xtext.ui.contentassist.PldxProposalProvider.class;
	       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Class<PldxProposalProvider> cannot be resolved to a type


...Any ideas what is causing this?
Re: Problem while deploying xtext plugin [message #1063722 is a reply to message #1063720] Thu, 13 June 2013 20:35 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6294
Registered: July 2009
Senior Member
Have a look at the build.properties
Make sure there are no warnings. Also have a look at
The jar file is the class file contained?

--
Need training, onsite consulting or any other kind of help for Xtext?
Go visit http://xtext.itemis.com or send a mail to xtext at itemis dot de
Re: Problem while deploying xtext plugin [message #1063723 is a reply to message #1063722] Thu, 13 June 2013 20:51 Go to previous message
Phil H is currently offline Phil H
Messages: 267
Registered: November 2012
Senior Member
Thx,

there was indeed a warning at the build.properties - now I don't get an error anymore Smile
Previous Topic:Removing tests plugin
Next Topic:Error "missing EOF at <token>"
Goto Forum:
  


Current Time: Tue Sep 16 17:33:27 GMT 2014

Powered by FUDForum. Page generated in 0.01714 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software