Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Running an eclipse plugin project on an obsolete version(Need 2004 eclipse pacakge to run a 2004 eclipse project)
Running an eclipse plugin project on an obsolete version [message #1062282] Fri, 07 June 2013 01:29 Go to next message
Sumeet J is currently offline Sumeet JFriend
Messages: 2
Registered: June 2013
Junior Member
My request may sound very strange but what i really want is a 2004 eclipse package . The reason i ask this is because i want to run a sample plugin application described here -> http://www.eclipse.org/articles/Article-Debugger/how-to.html This article was written way back in 2004 and no amount of effort to make it run today in version 4.3 of eclipse seems to be successful . So maybe loading it into 2004 version might be a good try ?


Anyone got any idea ? I searched but they dont have 2004 packages on the eclipse download page either .

Any hope to get it somewhere ?
Re: Running an eclipse plugin project on an obsolete version [message #1062671 is a reply to message #1062282] Mon, 10 June 2013 10:24 Go to previous message
Mickael Istria is currently offline Mickael IstriaFriend
Messages: 769
Registered: July 2009
Location: Grenoble, France
Senior Member
On 06/07/2013 03:29 AM, Sumeet J wrote:
> My request may sound very strange but what i really want is a 2004
> eclipse package . The reason i ask this is because i want to run a
> sample plugin application described here ->
> http://www.eclipse.org/articles/Article-Debugger/how-to.html This
> article was written way back in 2004 and no amount of effort to make it
> run today in version 4.3 of eclipse seems to be successful . So maybe
> loading it into 2004 version might be a good try ?

Have you tried on a recent Eclipse? Although the article is from 2004,
most APIs probably didn't change a lot, and it's probably not a big
effort to apply this tutorial on a recent Eclipse.

> Anyone got any idea ? I searched but they dont have 2004 packages on the
> eclipse download page either .
> Any hope to get it somewhere ?

It's probably easier to get help to move tuto to Eclipse 4.2 than it is
to ask help for a 9 years-old release.

In case you can run and fix the tutorial, here is the Git location:
http://git.eclipse.org/c/www.eclipse.org/articles.git/tree/Article-Debugger
.. Clone it, update it, and then contribute it back.

Cheers,
--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Previous Topic:programmatically import as source project
Next Topic:Dynamicaly changed layout on second page (based on first page)
Goto Forum:
  


Current Time: Thu Nov 20 23:16:33 GMT 2014

Powered by FUDForum. Page generated in 0.06754 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software