Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » class loader exceptions during debugging
class loader exceptions during debugging [message #1062008] Wed, 05 June 2013 08:05 Go to next message
Fratze Fratzesen is currently offline Fratze Fratzesen
Messages: 2
Registered: June 2013
Junior Member
Hey,

I'm trying this once more since I'm not sure if I just forgot to create the topic or it got deleted for some reason. If it's because of the latter case please send me a PM because I don't see where I'm potentially violating information from the stickies.

My problem is that my eclipse juno installation on windows 7 x64 behaves very weirdly. Every time I try to step into a constructor call or something that loads one of my own classes for the first time, I'll get an exception call stack like this:

ClassNotFoundException(Throwable).<init>(String, Throwable) line: 286	
ClassNotFoundException(Exception).<init>(String, Throwable) line: not available	
ClassNotFoundException(ReflectiveOperationException).<init>(String, Throwable) line: not available	
ClassNotFoundException.<init>(String) line: not available	
URLClassLoader$1.run() line: not available	
URLClassLoader$1.run() line: not available	
AccessController.doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext) line: not available [native method]	
Launcher$ExtClassLoader(URLClassLoader).findClass(String) line: not available	
Launcher$ExtClassLoader(ClassLoader).loadClass(String, boolean) line: not available	
Launcher$AppClassLoader(ClassLoader).loadClass(String, boolean) line: not available	
Launcher$AppClassLoader.loadClass(String, boolean) line: not available	
Launcher$AppClassLoader(ClassLoader).loadClass(String) line: not available	
Forge.main(String[]) line: 291	


I can now step out all of these exceptions and the program will continue running fine, but it's the same for each new class and it's obviously very annoying. I've recently uninstalled all of my JREs and JDKs and reinstalled the newest JDK version but the problem still persists. Does anyone have an idea what's going wrong here?
Re: class loader exceptions during debugging [message #1062073 is a reply to message #1062008] Wed, 05 June 2013 13:05 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1336
Registered: July 2009
Senior Member
My guess is that you have an exception breakpoint set and it is enable for both caught and uncaught exceptions. Class loaders are hierarchical. Children call parents. This will lead to ClassNotFound exceptions which indicates to the child that it needs to try and load the class so what you are seeing is expected behavior.

Try to disable the exception breakpoints. This should prevent the debugger from stopping when the exception is hit.
Re: class loader exceptions during debugging [message #1062090 is a reply to message #1062073] Wed, 05 June 2013 17:17 Go to previous message
Fratze Fratzesen is currently offline Fratze Fratzesen
Messages: 2
Registered: June 2013
Junior Member
No, at least not if it should show in the breakpoints view. I also cleared all breakpoints and redid the single one needed - same result.

I found that 'suspend execution on uncaught exceptions' is activated under window -> preferences -> java -> debug and thought I had found the solution (it was checked by default though) but this also didn't change anything.

Can there be hidden breakpoints?
Previous Topic:m2e-wtp included in latest Kepler build?
Next Topic:Subversive Authentication
Goto Forum:
  


Current Time: Wed Jul 30 09:28:55 EDT 2014

Powered by FUDForum. Page generated in 0.01797 seconds