Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » Refining mode - Possible bug when autoformatting text
Refining mode - Possible bug when autoformatting text [message #1061609] Mon, 03 June 2013 09:24 Go to next message
Javier García is currently offline Javier García
Messages: 129
Registered: April 2013
Senior Member
Hi, this seems like a bug but I wanted to check if it has happened to anyone else.
When in a refining module I press ctrl+shift+f to give format to the code all the "drop" words get replaced with an empty, blank, space, so then I thought maybe writing drop and writing nothing was the same, but when I run the transformation those rules just didn't do anything, as if they didn't exist, so I'm guessing this is some kind of bug, has this happened to you too? can someone else confirm this?

regards,
Javier
Re: Refining mode - Possible bug when autoformatting text [message #1061650 is a reply to message #1061609] Mon, 03 June 2013 11:56 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 604
Registered: July 2009
Senior Member
Hello,

This is an already identified bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=394245.
The "drop" keyword is actually needed and has to be put back in this case.


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: Refining mode - Possible bug when autoformatting text [message #1061653 is a reply to message #1061650] Mon, 03 June 2013 12:04 Go to previous message
Javier García is currently offline Javier García
Messages: 129
Registered: April 2013
Senior Member
Thanks Hugo, I couldn't find it before when I searched.
Previous Topic:Use a new instance from a rule in another rule
Next Topic:new instance in an ATL transformation
Goto Forum:
  


Current Time: Tue Sep 16 13:42:13 GMT 2014

Powered by FUDForum. Page generated in 0.03729 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software