Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » No bin.includes for source plug-in
No bin.includes for source plug-in [message #1061587] Mon, 03 June 2013 07:38 Go to next message
Thorsten Meinl is currently offline Thorsten Meinl
Messages: 85
Registered: July 2009
Member
Hi all,

I have a strange problem with a cquery. I have a target platform that
consists of a complete update site including source plug-ins. No I'm
issueing a CQUERY for a component in SVN which needs some components
from the TP. However I get the following error:

ERROR [0004] : CSpec org.knime.jsnippets.source has no action, group,
or local artifact named bin.includes

Yes, a source plug-in does not have bin.includes. But why is Buckminster
trying to resolve the source plug-in in the first place? There are no
dependencies to the source plug-in. Passing cbi.include.source=false
does not help. Any ideas?

Thanks,

Thorsten
Re: No bin.includes for source plug-in [message #1061596 is a reply to message #1061587] Mon, 03 June 2013 08:23 Go to previous message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
My guess is that there's a dependency to this plug-in somewhere.
Buckminster doesn't treat it as a source plug-in but think it's
something that should be included in a build.

- thomas

On 2013-06-03 09:38, Thorsten Meinl wrote:
> Hi all,
>
> I have a strange problem with a cquery. I have a target platform that
> consists of a complete update site including source plug-ins. No I'm
> issueing a CQUERY for a component in SVN which needs some components
> from the TP. However I get the following error:
>
> ERROR [0004] : CSpec org.knime.jsnippets.source has no action, group,
> or local artifact named bin.includes
>
> Yes, a source plug-in does not have bin.includes. But why is Buckminster
> trying to resolve the source plug-in in the first place? There are no
> dependencies to the source plug-in. Passing cbi.include.source=false
> does not help. Any ideas?
>
> Thanks,
>
> Thorsten
>
Previous Topic:org.junit4:osgi.bundle: No provider was found that could resolve the request
Next Topic:Buckminster Headless with JavaCC
Goto Forum:
  


Current Time: Wed Sep 03 07:21:03 GMT 2014

Powered by FUDForum. Page generated in 0.03428 seconds