Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BPMN 2.0 Modeler » FeatureProvider is not getting the DeleteFeature from my customTask
FeatureProvider is not getting the DeleteFeature from my customTask [message #1061279] Thu, 30 May 2013 18:53 Go to next message
Marco Roque is currently offline Marco Roque
Messages: 16
Registered: July 2012
Junior Member
Hello guys,

First of all i'm giving my first steps in BPMN2Modeler project and let me give you my congrats for your work.

I'm currently extending the BPMN2Modeler runtime to add a customTask with the type "TextAnnotation" just like in the "org.eclipse.bpmn2.modeler.runtime.example".
This customTask has a featureContainer where i have adapted the CreateFeature and the AddFeature, and all works just fine.

Now, i want to adapt the DeleteFeature, but it is not executed.

I've been messing around with the debugger, and it seems that the BPMNFeatureProvider is getting the DeleteFeature for the TextAnnotation and not for my customTask, because the getFeatureContainer(context) method is returning the TextAnnotation FeatureContainer.

Do you have any idea of why does this happen and how can i work my way around this in order to make my DeleteFeature work?

I hope this info helps you guys to discover the problem.

Thank you!
Regards,
Marco Roque
Re: FeatureProvider is not getting the DeleteFeature from my customTask [message #1061759 is a reply to message #1061279] Mon, 03 June 2013 15:30 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 580
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Hi Marco,

Are you sure you have provided an override for getDeleteFeature() in your ICustomTaskFeatureContainer? If you can share your code here, maybe I can spot the problem.

Regards,
Bob
Re: FeatureProvider is not getting the DeleteFeature from my customTask [message #1063047 is a reply to message #1061279] Tue, 11 June 2013 17:53 Go to previous messageGo to next message
Marco Roque is currently offline Marco Roque
Messages: 16
Registered: July 2012
Junior Member
Hi Bob,

The code is available here:

[http://]sourceforge.net/p/bpmn2animator/code/HEAD/tree/trunk/org.quasar.bpmn2.animator/src/org/quasar/bpmn2/animator/ResourceFeatureContainer.java

I have also tried to work with the removeFeature but also without any success.
Perhaps it is the object type that i'm returning in the getDeleteFeature(fp) method. I am returning a DefaultDeleteFeature object instance.


Thank you for your help.

Regards,
Marco Roque
Re: FeatureProvider is not getting the DeleteFeature from my customTask [message #1063954 is a reply to message #1063047] Sun, 16 June 2013 12:27 Go to previous messageGo to next message
Marco Roque is currently offline Marco Roque
Messages: 16
Registered: July 2012
Junior Member
Hello Bob,

I was able to get the deleteFeature working.
Thank you for help.

Re: FeatureProvider is not getting the DeleteFeature from my customTask [message #1063968 is a reply to message #1063954] Sun, 16 June 2013 21:10 Go to previous messageGo to next message
Robert Brodt is currently offline Robert Brodt
Messages: 580
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Wow, I love it when things simply "fix themselves" Smile Please keep us informed on your progress. I plan on looking at the BPMN2Animator project next week - if this is what I think it is, I would be VERY interested in the possibility of collaborating with you on this project Wink

Cheers!
Bob
Re: FeatureProvider is not getting the DeleteFeature from my customTask [message #1064375 is a reply to message #1063968] Tue, 18 June 2013 20:42 Go to previous message
Marco Roque is currently offline Marco Roque
Messages: 16
Registered: July 2012
Junior Member
Hello Robert,

Wow,it makes me very happy to see that you are interested in my project.
Like the name indicates, it is a runtime extension that provides the user with an animation layer on top of the process diagram.

I'll be needing your help in the near future, so i'll be posting so more questions.
If you want to i could send you my email or skype contact, to speak more about the project.

Thanks
Regards
Marco Roque

[Updated on: Wed, 19 June 2013 18:32]

Report message to a moderator

Previous Topic:Possible bug? Sequenceflow
Next Topic:import BPMN2.0 file in the JBPM eclipse editor
Goto Forum:
  


Current Time: Wed Jul 30 13:14:44 EDT 2014

Powered by FUDForum. Page generated in 0.04741 seconds