Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Update sites for Papyrus nightly builds
Update sites for Papyrus nightly builds [message #1061174] Thu, 30 May 2013 11:33 Go to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
Hi !

I followed the following steps to install Papyrus and MARTE

1)Installing Eclipse Modeling Tool package (Juno)
Re: Update sites for Papyrus nightly builds [message #1061185 is a reply to message #1061174] Thu, 30 May 2013 13:10 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
2) from menu bar
Help--> install modeling components-->flag the following options:
Papyrus
QVT
ACCELEO
OCL-Tools
XText
2) from menu bar
Help--> install modeling components-->flag the following options:
Papyrus
QVT
ACCELEO
OCL-Tools
XText

after completing the above installations

3) from menu bar
Help--> install Papyrus additional components-->flag MARTE


Re: Update sites for Papyrus nightly builds [message #1061186 is a reply to message #1061185] Thu, 30 May 2013 13:11 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
new post
Re: Update sites for Papyrus nightly builds [message #1061187 is a reply to message #1061186] Thu, 30 May 2013 13:12 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
new post
Re: Update sites for Papyrus nightly builds [message #1061188 is a reply to message #1061187] Thu, 30 May 2013 13:12 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
new post
Re: Update sites for Papyrus nightly builds [message #1061189 is a reply to message #1061188] Thu, 30 May 2013 13:13 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
Now I am able to insert a link.

According to the following link:
http://www.eclipse.org/papyrus/updates/

There are two types of update:

1)Update sites for Papyrus release versions.
2)Update sites for Papyrus nightly builds.


Now ,I would like to update my version using Update sites for Papyrus nightly builds
so I followed the following steps:

Menu Help/Install New software/ and enter the update site
http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/juno/

http://postimg.org/image/d24pesnfr/

and then
http://postimg.org/image/3ma362qwh/

and the last step was
http://postimg.org/image/kmg6bi8eb/

1-How the last step can be processed?

2-How regularly the Papyrus version should be updated? Is it advisable to update my version every night as its name implies(nightly builds)?

Regards

Andrew

[Updated on: Thu, 30 May 2013 13:15]

Report message to a moderator

Re: Update sites for Papyrus nightly builds [message #1061203 is a reply to message #1061189] Thu, 30 May 2013 13:57 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 457
Registered: February 2011
Senior Member
Hi Andrew,


In Juno, there's an issue with mixing the discovery site ("Help > Install Papyrus additional components") and the update sites ("Help > Install new software").

You have two solutions for step 3:

- Uninstall all extra components (Help > About Eclipse Platform > Installation Details > Uninstall all Papyrus- features (Except Papyrus UML)), then go back to Help / Install new software and try again
- Or, more simply, use Help > Check for updates

Although Papyrus Juno is built every night, there are really few commits on this branch (Juno is not officially maintained anymore), so it is pretty much useless to update every day.


If you want to test the very latest features, you should use Kepler instead (Which will be released next month)


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Update sites for Papyrus nightly builds [message #1061236 is a reply to message #1061203] Thu, 30 May 2013 16:42 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member

Camille, thank you very much that's very kind of you.

I followed your instructions:

1-Uninstall all extra components (Except Papyrus UML) as illustrated through screenshot in the attachment



2-Go back to Help / Install new software and enter the update site
http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/juno/

(also illustrated through screenshot in the attachment 3,4)


-I can't proceed this step .Does I miss some steps?

-Does the method that you provided (help-->check for update) is about Papyrus release versions or Papyrus nightly builds?
because I noticed this method doesn't ask me to enter any update link through updating process.


Regards

Andrew
Re: Update sites for Papyrus nightly builds [message #1061239 is a reply to message #1061236] Thu, 30 May 2013 16:57 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 457
Registered: February 2011
Senior Member
Hi,

The "Check for updates" action will use all available update sites. So, it depends on what you've configured in the "Install new software" dialog.

For the other error, I guess this is the same kind of issue, although I couldn't tell what exactly is wrong. So I'll recommend the same thing: Uninstall Papyrus SDK, and try to install it directly from the nightly update site.


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Update sites for Papyrus nightly builds [message #1061252 is a reply to message #1061239] Thu, 30 May 2013 18:56 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
Hi Camille !

The following is another try :

1-Uninstall Papyrus SDK.
(I illustrated it through screenshot in the attachment)

2-Install Papyrus SDK directly from the nightly update site
Menu Help/Install New software/ and enter the update site

http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/juno/

(also illustrated through screenshot in the attachment )

but I can't proceed this step because of the following error:
cannot complete the install because one or more required items could not be found

Could you please check the attachments?

Regards

Andrew
  • Attachment: 1.PNG
    (Size: 75.14KB, Downloaded 48 times)
  • Attachment: EMF-2-.PNG
    (Size: 64.00KB, Downloaded 46 times)
  • Attachment: 3.PNG
    (Size: 113.15KB, Downloaded 47 times)
  • Attachment: 4.PNG
    (Size: 114.76KB, Downloaded 43 times)
  • Attachment: 5.PNG
    (Size: 105.69KB, Downloaded 54 times)
Re: Update sites for Papyrus nightly builds [message #1061331 is a reply to message #1061252] Fri, 31 May 2013 09:10 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 457
Registered: February 2011
Senior Member
Hi,

If the error message (Which is partially hidden in Screenshot 5) is the following:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Papyrus Extra Binaries and Sources (Incubation) 0.9.2.v201305310519 (org.eclipse.papyrus.extra.sources.feature.feature.group 0.9.2.v201305310519)
  Missing requirement: UML Compare Models (Incubation) 0.9.2.v201305310519 (org.eclipse.papyrus.uml.compare.subelement 0.9.2.v201305310519) requires 'bundle org.eclipse.emf.compare.uml2 0.0.0' but it could not be found


Then you need to add the following update site:

EMF Compare 1.3 Releases - http://download.eclipse.org/modeling/emf/compare/updates/releases/1.3


If the error message is different, please provide the full error message.


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Update sites for Papyrus nightly builds [message #1061405 is a reply to message #1061331] Fri, 31 May 2013 13:36 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
Hi Camille !

Here is the full error message:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Papyrus Extra Feature (Incubation) 0.9.2.v201305310519 (org.eclipse.papyrus.extra.feature.feature.group 0.9.2.v201305310519)
  Missing requirement: Papyrus Compare UML File (Incubation) 0.9.2.v201305310519 (org.eclipse.papyrus.uml.compare.file 0.9.2.v201305310519) requires 'bundle org.eclipse.emf.compare.uml2 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: Papyrus Extra Feature (Incubation) 0.9.2.v201305310519 (org.eclipse.papyrus.extra.feature.feature.group 0.9.2.v201305310519)
    To: org.eclipse.papyrus.extra.uml.compare.feature.feature.group [0.9.2.v201305310519]
  Cannot satisfy dependency:
    From: Papyrus UML Compare Feature (Incubation) 0.9.2.v201305310519 (org.eclipse.papyrus.extra.uml.compare.feature.feature.group 0.9.2.v201305310519)
    To: org.eclipse.papyrus.uml.compare.file [0.9.2.v201305310519]



Regards

Andrew
Re: Update sites for Papyrus nightly builds [message #1061414 is a reply to message #1061405] Fri, 31 May 2013 14:13 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 457
Registered: February 2011
Senior Member
Hi,

You should add this update site, then try again:

http://download.eclipse.org/modeling/emf/compare/updates/releases/1.3

Camille


Camille Letavernier
Papyrus developer
Re: Update sites for Papyrus nightly builds [message #1061432 is a reply to message #1061414] Fri, 31 May 2013 15:22 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
Hi Camille !

After adding the following update site and then starting up Eclipse Modelling Framework I got a dialog

http://download.eclipse.org/modeling/emf/compare/updates/releases/1.3

Is it a bug or I should install one of these connector?

Could you please check the attachments?

Regards

Andrew
  • Attachment: 1.PNG
    (Size: 117.43KB, Downloaded 45 times)
  • Attachment: 2.PNG
    (Size: 125.10KB, Downloaded 39 times)
  • Attachment: svn.PNG
    (Size: 123.38KB, Downloaded 56 times)

[Updated on: Fri, 31 May 2013 15:27]

Report message to a moderator

Re: Update sites for Papyrus nightly builds [message #1061438 is a reply to message #1061432] Fri, 31 May 2013 15:46 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 457
Registered: February 2011
Senior Member
Actually, adding the update site would've been enough (Just so that Papyrus Compare can resolve its required dependency to EMF Compare). You installed all the EMF Compare integration components, including the Subversive (SVN) integration. Subversive opens this dialog when it cannot find any SVN connector.

So, you can simply ignore this dialog.


Camille


Camille Letavernier
Papyrus developer
Re: Update sites for Papyrus nightly builds [message #1061452 is a reply to message #1061438] Fri, 31 May 2013 16:52 Go to previous messageGo to next message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member
Hi Camille !

After successfully completing the installation of Papyruss (Menu Help/Install New software/ and enter the update site

http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/juno/

) and trying to add MARTE
(Help--> install Papyrus additional components-->flag MARTE) some errors occured

Could you please check the attachments?

Regards

Andrew

[Updated on: Fri, 31 May 2013 16:54]

Report message to a moderator

Re: Update sites for Papyrus nightly builds [message #1061888 is a reply to message #1061452] Tue, 04 June 2013 14:17 Go to previous message
Andrew Smith is currently offline Andrew Smith
Messages: 12
Registered: May 2013
Junior Member

A little more advice would be nice
Previous Topic:How to run a Papyrus SysML file?
Next Topic:Parameterized class as an operation parameter type
Goto Forum:
  


Current Time: Sat Sep 20 10:09:01 GMT 2014

Powered by FUDForum. Page generated in 0.02400 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software