Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » No Applicable Items on File | New
No Applicable Items on File | New [message #1061095] Wed, 29 May 2013 21:24 Go to next message
rob montgomery is currently offline rob montgomery
Messages: 11
Registered: July 2012
Junior Member
This is a new installation of Eclipse Modeling Tools, Version: Juno Release
Build id: 20120620-1657. After installation on Win8(64-bit), I ran the Install Modeling Components from the Help menu. I selected the Papyrus component and the install seem to proceed without a problem. When i try to create a new project using File | New, there are no options available ("No Applicable Items" value in the submenu. When i select Help | Install New Software using the Papyrus - http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/juno URL, there are a list of files that will be installed under the Papyrus category including:
Papyrus Extra Binaries and Sources (Incubation) 0.9.2.v201302131017
Papyrus Extra Feature (Incubation) 0.9.2.v201302131017
Papyrus SDK Binaries (Incubation) 0.9.2.v201302131112
Papyrus SDK Binaries and sources (Incubation) 0.9.2.v201302131112

When I try to install these, I get the following error message.
Your original request has been modified.
"Papyrus SDK Binaries (Incubation)" will be ignored because it is already installed.
Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus Extra Binaries and Sources (Incubation) 0.9.2.v201302131017 (org.eclipse.papyrus.extra.sources.feature.feature.group 0.9.2.v201302131017)
Missing requirement: UML Compare Models (Incubation) 0.9.2.v201302131017 (org.eclipse.papyrus.uml.compare.subelement 0.9.2.v201302131017) requires 'bundle org.eclipse.emf.compare.uml2 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Papyrus Extra Feature (Incubation) 0.9.2.v201302131017 (org.eclipse.papyrus.extra.feature.feature.group 0.9.2.v201302131017)
To: org.eclipse.papyrus.extra.uml.compare.feature.feature.group [0.9.2.v201302131017]
Cannot satisfy dependency:
From: Papyrus Extra Binaries and Sources (Incubation) 0.9.2.v201302131017 (org.eclipse.papyrus.extra.sources.feature.feature.group 0.9.2.v201302131017)
To: org.eclipse.papyrus.extra.feature.feature.group [0.9.2.v201302131017]
Cannot satisfy dependency:
From: Papyrus UML Compare Feature (Incubation) 0.9.2.v201302131017 (org.eclipse.papyrus.extra.uml.compare.feature.feature.group 0.9.2.v201302131017)
To: org.eclipse.papyrus.uml.compare.subelement [0.9.2.v201302131017]

What am i missing?

[Updated on: Wed, 29 May 2013 21:28]

Report message to a moderator

Re: No Applicable Items on File | New [message #1061097 is a reply to message #1061095] Wed, 29 May 2013 21:41 Go to previous messageGo to next message
rob montgomery is currently offline rob montgomery
Messages: 11
Registered: July 2012
Junior Member
I also used the Help |Install Additional Papyrus Components (Additional Components Discovery) to install ALL of the Modeler extensions (there are 6 sets of extensions). They seem to install correctly, but I still can not create a project.
Re: No Applicable Items on File | New [message #1061098 is a reply to message #1061097] Wed, 29 May 2013 21:49 Go to previous message
rob montgomery is currently offline rob montgomery
Messages: 11
Registered: July 2012
Junior Member
Self-help / Resolution
There are two selections in the IDE in the upper right corner; Java EE and Resource. It was set to Java EE. When I selected Resource, I can now create a Papyrus UML.
Previous Topic:Adding new buttons in Papyrus Palette
Next Topic:Show Multiplicity on use case diagrams?
Goto Forum:
  


Current Time: Wed Oct 01 00:05:38 GMT 2014

Powered by FUDForum. Page generated in 0.02040 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software