Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » white screen when waiting for response
white screen when waiting for response [message #1060946] Wed, 29 May 2013 09:16 Go to next message
Dirk Polke is currently offline Dirk Polke
Messages: 3
Registered: May 2013
Junior Member
Hello,

after switching from RAP 1.5.1 to 2.1 M2 I always got white screens, when doing some action in the application. The application is running on a JBoss AS 7 server. When I start the app locally with jetty I got a nice light grey transparent screen and see an action wheel. Is this possible on war installations too?

thx, Dirk
Re: white screen when waiting for response [message #1061001 is a reply to message #1060946] Wed, 29 May 2013 13:34 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1816
Registered: July 2009
Senior Member
Hi Dirk,
do you have your own custom theme? It seems that during the migration
from 1.5.1 to 2.1 M2 your theme is not updated with all the needed
properties from RAP 2.0+. Or... in case it is, the theme (CSS) is not
included in the war.
Best,
Ivan

On 5/29/2013 4:02 PM, Dirk Polke wrote:
> Hello,
>
> after switching from RAP 1.5.1 to 2.1 M2 I always got white screens,
> when doing some action in the application. The application is running
> on a JBoss AS 7 server. When I start the app locally with jetty I got
> a nice light grey transparent screen and see an action wheel. Is this
> possible on war installations too?
>
> thx, Dirk

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: white screen when waiting for response [message #1061117 is a reply to message #1061001] Thu, 30 May 2013 06:55 Go to previous messageGo to next message
Dirk Polke is currently offline Dirk Polke
Messages: 3
Registered: May 2013
Junior Member
Hello Ivan,

I have activated from the examples the business theme, which looks like as expected...

regards, Dirk
Re: white screen when waiting for response [message #1065699 is a reply to message #1061117] Thu, 27 June 2013 08:05 Go to previous messageGo to next message
André Kemter is currently offline André Kemter
Messages: 4
Registered: June 2013
Junior Member
Hey,

I have the same problem than you, have you found any solution?

thx André
Re: white screen when waiting for response [message #1065818 is a reply to message #1065699] Thu, 27 June 2013 15:19 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1816
Registered: July 2009
Senior Member
Hi André,
please look at your theme about the following CSS:
....
SystemMessage-DisplayOverlay {
background-color: rgba( 128, 128, 128, 0.3 );
background-image: none;
}
....
Do you have it? If not add it to your theme and try again.
HTH,
Ivan

On 6/27/2013 5:27 PM, André Kemter wrote:
> Hey,
> I have the same problem than you, have you found any solution?
>
> thx André

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: white screen when waiting for response [message #1066133 is a reply to message #1065818] Mon, 01 July 2013 07:59 Go to previous messageGo to next message
André Kemter is currently offline André Kemter
Messages: 4
Registered: June 2013
Junior Member
Thank you Ivan for your answer it fixed the problem. Smile

André

[Updated on: Mon, 01 July 2013 08:15]

Report message to a moderator

Re: white screen when waiting for response [message #1066145 is a reply to message #1066133] Mon, 01 July 2013 09:27 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf Sternberg
Messages: 1290
Registered: July 2009
Senior Member

André,

when a response from the server is delayed, the screen is blocked by an
overlay to prevent further interaction. The look of this overlay can be
changed in the theme, as Ivan explained.

However, you shouldn't usually see this overlay often, unless you have
an unusually long network latency. If you do anyway, you should have a
look at the response times.

Long response times can be caused by time-consuming operations running
directly in the UI thread. Could this be the case in your application?

Regards,
Ralf

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: white screen when waiting for response [message #1066222 is a reply to message #1066145] Mon, 01 July 2013 15:06 Go to previous messageGo to next message
André Kemter is currently offline André Kemter
Messages: 4
Registered: June 2013
Junior Member
I had made a mistake, but now it works with the solution from Ivan.
But Ralf thank you for helping.

Yours sincerely
André
Re: white screen when waiting for response [message #1066759 is a reply to message #1066222] Thu, 04 July 2013 09:04 Go to previous message
Dirk Polke is currently offline Dirk Polke
Messages: 3
Registered: May 2013
Junior Member
Hi again,

solved for me now too, after deleting all temporary files on the jboss server and undeploying the application. I also added the latest example design to the war file.

regards, Dirk
Previous Topic:toolitem's dynamic width to grab the right space of toolbar?
Next Topic:RAP tools in Kepler
Goto Forum:
  


Current Time: Mon Sep 22 02:22:12 GMT 2014

Powered by FUDForum. Page generated in 0.02367 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software