Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] Which Acceleo version do I need for UML 1.3
[Acceleo] Which Acceleo version do I need for UML 1.3 [message #1060944] Wed, 29 May 2013 05:14 Go to next message
Félix SILINOU KAMDEM is currently offline Félix SILINOU KAMDEM
Messages: 52
Registered: April 2013
Member
Hello,
I have a XMI for UML 1.3 I export through StarUML.
I would like to make an m2t transformation using Acceleo but I don't know which version of Acceleo I should use.
I've tried Acceleo 2.5 but it does work. It probably because, it-s not possible to use a metamodel of uml1.3
<%
metamodel http://www.eclipse.org/uml2/2.0.0/UML
%>

It's possible to use Acceleo 3.3 for UML 1.3? if yes, which metamodel do I need?
Thank you for your advice.

Re: [Acceleo] Which Acceleo version do I need for UML 1.3 [message #1061078 is a reply to message #1060944] Wed, 29 May 2013 16:03 Go to previous message
Ed Willink is currently offline Ed Willink
Messages: 3844
Registered: July 2009
Senior Member
Hi

AFAIK there is no Eclipse support for any UML 1.x.

Regards

Ed Willink

On 29/05/2013 10:14, Félix SILINOU KAMDEM wrote:
> Hello,
> I have a XMI for UML 1.3 I export through StarUML.
> I would like to make an m2t transformation using Acceleo but I don't
> know which version of Acceleo I should use.
> I've tried Acceleo 2.5 but it does work. It probably because, it-s not
> possible to use a metamodel of uml1.3
> <%
> metamodel http://www.eclipse.org/uml2/2.0.0/UML
> %>
> It's possible to use Acceleo 3.3 for UML 1.3? if yes, which metamodel
> do I need?
> Thank you for your advice.
>
>
Previous Topic:XML2SQLtext
Next Topic:how can i extract the data from model to text
Goto Forum:
  


Current Time: Mon Apr 21 00:46:53 EDT 2014

Powered by FUDForum. Page generated in 0.01554 seconds