Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EMF-IncQuery » Package declaration "does not match the container package"
Package declaration "does not match the container package" [message #1060923] Wed, 29 May 2013 07:52 Go to next message
Remy Honig is currently offline Remy Honig
Messages: 4
Registered: March 2012
Junior Member
My .eiq files have errors in them since I updated to 0.7M3

The package declaration in the top of the file is marked as having the error "does not match the container package". The declaration however matches the package the file is located in. I tried guessing the correct names and I tried to find the rules for this in the documentation but I didn't succeed.

Given (what i had but now is incorrect):

package "org.rh.package"
file "derived.eiq"
package declaration in file "org.rh.package"

How should naming be done now?
Re: Package declaration "does not match the container package" [message #1060926 is a reply to message #1060923] Wed, 29 May 2013 08:12 Go to previous messageGo to next message
Istvan Rath is currently offline Istvan Rath
Messages: 54
Registered: July 2009
Member
Your naming is correct (just make sure that you enter the package declaration without quotation marks into the eiq file).

I cannot reproduce your issue though; please try a full clean and rebuild on the project. If that doesn't help, please try the procedure described in http://wiki.eclipse.org/EMFIncQuery/Releases/MigrateTo0.7#Changes_to_Generated_Code

If these don't work, then you have found a bug. If that should be the case, I would kindly ask you to submit a bug report through bugzilla (with a test project that can reliably reproduce the problem), and we'll fix it ASAP.
Re: Package declaration "does not match the container package" [message #1060927 is a reply to message #1060923] Wed, 29 May 2013 08:13 Go to previous messageGo to next message
Zoltan Ujhelyi is currently offline Zoltan Ujhelyi
Messages: 221
Registered: July 2009
Senior Member
Hi Remy,

we have changed our system to be consistent with the Java package conventions - in other words, the package declaration should match the Java package the software is in. In your case, the package declaration «package "org.rh.package» should be placed inside an eiq file in «projectname»/src/org/rh/package folder (Java package).

However, when I was trying to create that package, the New package wizard in JDT told me that it is not allowed, so maybe you have triggered something like that.

Cheers,
Zoltán
Re: Package declaration "does not match the container package" [message #1066065 is a reply to message #1060923] Sat, 29 June 2013 17:04 Go to previous message
Remy Honig is currently offline Remy Honig
Messages: 4
Registered: March 2012
Junior Member
Thank you for your replies and my apologies for my late reply!

I have tried your suggestions without success. I tried it on OSX and on a different system running Ubuntu. Both gave me the package declaration error message on existing and new projects.

What did fix it for me was to use the switch to the integration build update site to update the runtimes in the latest Kepler release. This solved the error message.

Previous Topic:Support for Xtext 2.4?
Next Topic:After each workspace build every pattern has the same error
Goto Forum:
  


Current Time: Tue Oct 21 20:00:16 GMT 2014

Powered by FUDForum. Page generated in 0.01576 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software