Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » Problem with ATL transformation BPMN2PN
Problem with ATL transformation BPMN2PN [message #1060556] Sun, 26 May 2013 19:05 Go to next message
achraf lyazidi is currently offline achraf lyazidi
Messages: 10
Registered: May 2013
Junior Member
Hello everybody,

i've already program a BPMN.ecore and a PetriNet.ecore (i did the BPMN.ecore by myself because it's not found in any website, and there is no standard Ecore yet as i know). After that, i wrote my ATL file BPMN2PN.atl, and an XMI file in order to transform it from a BPMN model to a PetriNet model, but i get the following problems :

1- ClassNotFoundException : Class 'Process' in not found or is abstract
2- PackageNotFoundException : Package with uri 'BPMN' not found

(Note that i did specify an nsURI to my BPMN)

I did try to write my model example in .ecore, but the source model is not generated

can you help me please.

Thanks

Achraf.
Re: Problem with ATL transformation BPMN2PN [message #1060676 is a reply to message #1060556] Mon, 27 May 2013 16:19 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 607
Registered: July 2009
Senior Member
Hello,

You should try to use the BPMN2 metamodel (in Ecore) and modeler to get your BPMN models.
Then, you should be able to reuse them properly in your transformation.
Note that, if your metamodel in Ecore has not been first registered/loaded into the Eclipse registry, you cannot access it via its URI (and you have to specify the file path instead in your ATL launch configuration).


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: Problem with ATL transformation BPMN2PN [message #1425442 is a reply to message #1060676] Wed, 17 September 2014 10:16 Go to previous message
walma gharbi is currently offline walma gharbi
Messages: 12
Registered: April 2014
Junior Member


I have the same problem my tansformation is from BPMN to UPPAAL , I have tested my atl file on a different .ecore that I created and contains the same classes as the BPMN2.0.ecore. With the .ecore I've created it worked.

But when I changed to the BPMN2.0.ecore I faced the same problem.
My question is how could I know if my metamodel in ecore has been registered/loaded into the Eclipse registry because I am new at all of this .

I also have tried to replace my file xmi with an other file bpmn the error disappeared and the file .xmi of uppal was generated but Empty Sad

I really need help , I've tried many things but since I am new to this I really couldn't get this to work
Previous Topic:creating a RULE just to rename a ClassUNIT
Next Topic:ATL Debug Mode Working?
Goto Forum:
  


Current Time: Sun Oct 26 00:24:52 GMT 2014

Powered by FUDForum. Page generated in 0.01670 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software