Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Extension point & stereotype & pallete
Extension point & stereotype & pallete [message #1059860] Tue, 21 May 2013 20:51 Go to next message
Noelia as is currently offline Noelia as
Messages: 13
Registered: June 2012
Junior Member
Hello,

I have created several prefiles for different elements, and I have created custom palettes with stereotype of these profiles, the problem is that for the element called extension point when i create a palette with stereotypes, these are not actually applied in the use case diagram, although the element is drawn .. Does anyone know if in this respect there is a problem with the element called extension point?

Thanks. Noelia.
Re: Extension point & stereotype & pallete [message #1059947 is a reply to message #1059860] Wed, 22 May 2013 06:10 Go to previous messageGo to next message
Leila A is currently offline Leila A
Messages: 17
Registered: February 2013
Junior Member
Hej,

Did you create palette programmatically?

RegardsLeila
Re: Extension point & stereotype & pallete [message #1059975 is a reply to message #1059947] Wed, 22 May 2013 08:14 Go to previous messageGo to next message
Noelia as is currently offline Noelia as
Messages: 13
Registered: June 2012
Junior Member
I have continued this manual to do the palette:

http://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&cad=rja&ved=0CDcQFjAB&url=http%3A%2F%2Fdev.eclipse.org%2Fsvnroot%2Fmodeling%2Forg.eclipse.mdt.papyrus%2Ftrunk%2Fdoc%2FDevelopperDocuments%2FHow-To%2FPapyrusDevelopperTutorial_OnPaletteCustomization_v1.0_d2010-05-10.odt&ei=ObOcUeP2FYXy7AaX2YDoAw&usg=AFQjCNGSZR9A41zmKEafxm_r9uOguGBcgw&sig2=pWAPvCmwlelxHGQpRebKFw&bvm=bv.46751780,d.ZGU
Re: Extension point & stereotype & pallete [message #1066740 is a reply to message #1059975] Thu, 04 July 2013 03:50 Go to previous messageGo to next message
Dennis D. is currently offline Dennis D.
Messages: 23
Registered: April 2013
Junior Member
Hi,

I have a similar problem: I have a device stereotyped with no additional properties (yet). When I draw an device and apply the stereotype via properties->profile->... it works fine and the stereotype is applied. However, when I use the customization palette, the stereotype is not applied.

I tried it with classes before and it worked. I cannot make stereotype application from palette work with devices or artifacts.

Any news on this? I followed the tutorial mentioned above.

thanks
Re: Extension point & stereotype & pallete [message #1070122 is a reply to message #1066740] Wed, 17 July 2013 05:22 Go to previous message
Dennis D. is currently offline Dennis D.
Messages: 23
Registered: April 2013
Junior Member
Bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=412476
Previous Topic:Customized Palette for Stereotypes with String Properties
Next Topic:How to specify flow condition in activity diagrams
Goto Forum:
  


Current Time: Wed Aug 27 21:25:34 EDT 2014

Powered by FUDForum. Page generated in 0.02073 seconds