Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Gemini » Gemini JPA 1.1 and EclipseLink 2.5
Gemini JPA 1.1 and EclipseLink 2.5 [message #1059674] Tue, 21 May 2013 07:38 Go to next message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 451
Registered: July 2009
Senior Member
Hi,

Is Gemini JPA 1.1 compatible to EclipseLink 2.5?

-Gunnar

--
Gunnar Wagenknecht
gunnar@xxxxxxxx
http://wagenknecht.org/
Re: Gemini JPA 1.1 and EclipseLink 2.5 [message #1059795 is a reply to message #1059674] Tue, 21 May 2013 15:53 Go to previous messageGo to next message
Michael Keith is currently offline Michael Keith
Messages: 212
Registered: July 2009
Senior Member
I believe there are currently some issues with EclipseLink 2.5. We will have a milestone out soon that is compatible. Are you looking to ship with 2.5 in Kepler?
Re: Gemini JPA 1.1 and EclipseLink 2.5 [message #1059827 is a reply to message #1059795] Tue, 21 May 2013 18:43 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 451
Registered: July 2009
Senior Member
Am 21.05.2013 17:53, schrieb Mike Keith:
> I believe there are currently some issues with EclipseLink 2.5. We will have a milestone out soon that is compatible. Are you looking to ship with 2.5 in Kepler?

I was looking into this today but ran across an import-package problem
with javax.persistence in the Gemini JPA bundle. Thus, I currently tend
to stay with 2.4.1. Well, technically we can also consume a new Gemini
JPA release post-Kepler. We are in good shape in terms of EclipseLink,
though.

-Gunnar


--
Gunnar Wagenknecht
gunnar@xxxxxxxx
http://wagenknecht.org/
Re: Gemini JPA 1.1 and EclipseLink 2.5 [message #1059853 is a reply to message #1059827] Tue, 21 May 2013 23:11 Go to previous messageGo to next message
Michael Keith is currently offline Michael Keith
Messages: 212
Registered: July 2009
Senior Member
Yes, that is the problem. It also arises in the 2.4.2 release.
Re: Gemini JPA 1.1 and EclipseLink 2.5 [message #1061079 is a reply to message #1059853] Wed, 29 May 2013 20:12 Go to previous messageGo to next message
Michael Keith is currently offline Michael Keith
Messages: 212
Registered: July 2009
Senior Member
A bug has been entered for this: Bug 408607

There is also a workaround listed (thanks Tom).

-Mike
Re: Gemini JPA 1.1 and EclipseLink 2.5 [message #1064728 is a reply to message #1061079] Thu, 20 June 2013 16:44 Go to previous messageGo to next message
Michael Keith is currently offline Michael Keith
Messages: 212
Registered: July 2009
Senior Member
The latest 1.2.0 milestone is available and contains support for EclipseLink 2.5.

-Mike
Re: Gemini JPA 1.1 and EclipseLink 2.5 [message #1064844 is a reply to message #1064728] Fri, 21 June 2013 10:36 Go to previous message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 451
Registered: July 2009
Senior Member
Am 20.06.2013 18:44, schrieb Mike Keith:
> The latest 1.2.0 milestone is available and contains support for EclipseLink 2.5.

Thanks a lot Mike!

-Gunnar


--
Gunnar Wagenknecht
gunnar@xxxxxxxx
http://wagenknecht.org/
Previous Topic:Gemini Blueprint Configuration Admin Runtime Updates
Next Topic:[Solved]Problem with: example
Goto Forum:
  


Current Time: Wed Sep 24 02:32:45 GMT 2014

Powered by FUDForum. Page generated in 0.01844 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software