Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Jubula 2.0 to VNC on Linux
Jubula 2.0 to VNC on Linux [message #1059604] Mon, 20 May 2013 18:39 Go to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
I am running Jubula 2.0.00148 on Linux RH 6.4 on a remote machine which I am viewing using VNC. Let's call this machine jubula. Jubula seems alive and well and I am able to manually control it through VNC without any problems. This machine is not the problem.

However I am having problems running a test case from the jubula machine to my AUT on Linux RHEL 6.2. Let's call this machine autlinux. Because the autlinux machine is remote I am using VNC to view its "display". The AUT is Eclipse, and jubula can start it up correctly. When it tries to run the first test step in the test case which selects 'File'/'Exit' the test fails. This is because it tries to select ***the VNC menu*** and not the AUT's menu.

Note: If I run that same test to my AUT on Windows XP SP 3 it runs successfully. Let's call this machine autwindows. In other words, the test case drives the AUT and the I see the mouse move, the File & Exit menus get selected, etc. all of which I am viewing on my local Windows display (not through VNC).

Is there any known problems using VNC on AUT machines? Or do you have any suggestions for running remote AUT machines such as Linux?

[Updated on: Mon, 20 May 2013 18:46]

Report message to a moderator

Re: Jubula 2.0 to VNC on Linux [message #1059685 is a reply to message #1059604] Tue, 21 May 2013 08:21 Go to previous messageGo to next message
Achim Loerke is currently offline Achim Loerke
Messages: 349
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

Is the VNC menu auto-mapped inside the display when the mouse gets near the borders? That could explain why the RC clicks there.
Re: Jubula 2.0 to VNC on Linux [message #1059813 is a reply to message #1059685] Tue, 21 May 2013 17:31 Go to previous messageGo to next message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
There is no auto-mapping taking place. The VNC display is fixed and represents the Linux GNOME desktop which consists of a title-bar and as set of desktop menus. When the Jubula RC clicks on a menu item it skips the title bar, but then tries to selects one of the GNOME desktop menu items accidentally. In other words, the Jubula RC is unaware of where the top left corner of the AUT is started (relative location) and instead treats the top left corner of the VNC display (absolute location).

See index.php/fa/14992/0/.

So I was able to configure GNOME to move its set of desktop menus to the bottom of the screen. Again it failed because it tried to select the AUT's title-bar's window menu items. It looks like it was again selecting from the top left corner of the VNC display (absolute location).

See index.php/fa/14993/0/.

As I said earlier everything works fine on Windows (non-VNC) because there is no graphical 'overhead', that is, the title bar and menu belong to the AUT.

See index.php/fa/14994/0/.
  • Attachment: VNC1.jpg
    (Size: 25.33KB, Downloaded 153 times)
  • Attachment: VNC2.jpg
    (Size: 21.17KB, Downloaded 145 times)
  • Attachment: VNC3.jpg
    (Size: 19.73KB, Downloaded 151 times)

[Updated on: Tue, 21 May 2013 17:35]

Report message to a moderator

Re: Jubula 2.0 to VNC on Linux [message #1060013 is a reply to message #1059813] Wed, 22 May 2013 14:24 Go to previous message
Brian Watt is currently offline Brian Watt
Messages: 20
Registered: February 2012
Junior Member
One more piece of information. I ran on the remote Linux machine, autlinux, without using VNC, but instead using X-Windows and exported my display output back to an X-server running on my Windows, autwindows. What surprised me is that this still failed. I see the cursor moving to the top left corner and selecting the Windows menu that is in the title bar (circled in red below) and not the AUT "File" menu item just below it. Then I get an error back in Jubula stating "The submenu for "File" did not appear."

index.php/fa/15015/0/
  • Attachment: VNC4.jpg
    (Size: 16.56KB, Downloaded 143 times)
Previous Topic:Click on button with combobox doesn't work on jubula2.
Next Topic:Multi-line Cut and Paste error on Jubula 2.0
Goto Forum:
  


Current Time: Thu Oct 23 04:34:58 GMT 2014

Powered by FUDForum. Page generated in 0.01807 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software